PDA

View Full Version : Trackpad, Keyboard, USB port not working




omaragra
Dec 21, 2008, 10:15 AM
Hi Guys,

I have a 2 Gen MBA and today suddenly the keyboard, trackpad and even the USB port stopped working, I tried connect an external mouse but it didn't work, even other USB devices are not working !! I tried the display port it is fine, but I am not sure about the audio port. I tried the SMC reset but it did me no good.

I had bought the MBA from Apple UK but currently I am in INDIA for my winter break from UNI. I don't have my OSX discs at the moment they are back in UK, I tried calling the Applecare but they are closed being a Sunday, and I don't want the local Apple Authorised Service center to touch my air as I don't trust them (The appointment of these repair centers in INDIA is not upto the highest standards !)

The keyboard and the trackpad are working in the Apple hardware test, I was able to move around the cursor and even use the keyboard to select the various options, so I believe the hardware is fine.

So any suggestions what can I do in the meantime, I will call Apple Care in UK tomorrow. I am not back in the UK till the 26th January.

Regards

Omar



justit
Dec 21, 2008, 11:03 AM
So any suggestions what can I do in the meantime, I will call Apple Care in UK tomorrow.

Do you know if the keyboard works at the time of bootup? if so you can try a reset:

MacBook Air
If the MacBook Air is on, turn it off.
Connect the power adaptor to a working power source.
On the MacBook Air keyboard, press (left) Shift-Control-Option along with the power button once.
Note: You must use the keys on the left side of the MacBook Air keyboard.
Wait 5 seconds and press the power button to start the MacBook Air.

omaragra
Dec 21, 2008, 11:14 AM
Do you know if the keyboard works at the time of bootup? if so you can try a reset:

Yes I think it works, because I was able to press the shift key and go into safe mode and also i was able to hold the D button and start the hardware test.

I already tried resetting it but it doesnt work:(

Ironic
Dec 21, 2008, 11:37 AM
Call Apple?

omaragra
Dec 21, 2008, 11:39 AM
Call Apple?

Will call them tomorrow in UK:apple:

anasta
Dec 21, 2008, 05:08 PM
I just expereinced the same problem!!! I am not sure, but I installed the latest version of coolbook and restarted the system. I am not sure if this caused it, because I may have not restarted for a few days, so I need to remember if I installed any other things...
Anyway, both mouse and keyboard are locked, no way to use an external mouse. BUT the keyboard works when you boot, because you can start in safe mode. I also tried to reset, but no luck.
Any idea?!?!
thanks!

:(

omaragra
Dec 21, 2008, 09:00 PM
Called Apple and the guy made me do a SMC and PRAM reset and he said the hardware is fine but the driver files maybe corrupted, so he advised me to do a OS reinstall, but I don't have the discs with me at the moment so I was wondering if I can use my friend's set of discs(White Macbook), if not can I buy a new leopard install disc and will that work ?

Regards

Omar

darwinian
Dec 21, 2008, 09:02 PM
I don't know this for sure, but I bet the trackpad and the kbd are also USB devices - sounds to me like there's something going wrong (either SW or HW) with the entire USB device system there.

McGilli
Dec 21, 2008, 09:58 PM
TRY THIS :

turn OFF the MBA,

press OPTION/COMMAND/R/P

all 4 of those keys at the same time AND KEEP THEM DOWN

now - stretch a pinky and push the power button on your MBA.

KEEP THE 4 KEYS HELD DOWN.

your MBA will start up - then beep, and then restart.

then it will beep, and restart.

then it will beep and restart

THREE TIMES

after the 3rd time , let go of the keys on the keyboard.

let it boot into OSX and see if all is better now.

This solved my hardware issue 2 days ago, so i am curious to see if it helps you...

Apple care tech called this a HARDWARE RESET..

omaragra
Dec 22, 2008, 01:52 AM
Tried that as well, but didn't work, I think its a Software because the keyboard and trackpad are working in the hardware test section.

The only problem is that I dont have the restore discs, i have asked the Apple guys in India to send me a set of new discs.

Cheers guys for your help.

rleoni
Dec 22, 2008, 03:31 PM
My MBA asks for a Mouse anda Trackpad bluetooth on start up. But i never paired any device like that. So i can't start the MBA... i 've tried all the options listed above.. anyone can help?
Thanks