PDA

View Full Version : youtube HD




byke
Dec 31, 2008, 07:40 PM
I just tried to load this page and see if the video worked on my MBA GEN 2 ...
the large file loaded but was kinda jerky .... does anyone else get this?


http://news.cnet.com/8301-17939_109-10104182-2.html?tag=TOCmoreStories.0


cheers



richard.mac
Dec 31, 2008, 07:49 PM
yeh its not smooth on my MBP. most likely due to Flash being over CPU intensive in OS X. however i have watched other HD YouTube videos fine.

SFStateStudent
Jan 2, 2009, 03:48 AM
Definitely, a huge difference between HD and the regular video... I even ran it on my Mac Pro 3.0 and there was still some jerkiness going on throughout the HD video...:eek:

lloydh
Jan 2, 2009, 03:59 AM
In terms of playback frame rate, the footage was totally smooth on my MBP (both cores ~75%) though camera shake from the acquisition was still very apparent (as true with the low-res version).

I totally agree though, flash is a dog on OS X.

macjram
Jan 2, 2009, 04:05 AM
It jerked a little on mine

but I'm on a HP Pavilion dv6000 =[

justit
Jan 2, 2009, 09:23 AM
To get HD enabled, you have to render it again at the higher HD resolution and re-upload. Could it just be badly dropped frames when the author rendered it and uploaded to youtube?
I've tested many 1080p youtube videos on the MBA and smooth as silk.

alphaod
Jan 2, 2009, 02:00 PM
May be just a poor encode.

tubbymac
Jan 3, 2009, 07:16 PM
Could it just be badly dropped frames when the author rendered it and uploaded to youtube?

Nope.

May be just a poor encode.

Nope.

The reason I say this is that I did a test with my MB Alum and the linked video randomly stutters while loading on Mac OSX under Safari but is perfectly smooth under my customized bootcamp install under Vista 32 and Firefox. By customized I've taken the default install with Apple's junk drivers and force upgraded to current drivers.

So looks like either an issue with flash under OSX or an Apple driver issue. I've seen the same stuttering on other HD youtube videos under OSX while the same ones play perfect under Windows.

mhnajjar
Jan 3, 2009, 08:43 PM
I just tried it on my wife's Vaio and it ran silk smooth under FireFox. I am too lazy to turn on any of my Macs at this time!

Heb1228
Jan 3, 2009, 08:52 PM
It's a little jerky on my G4 Powerbook too. :D I think its getting close to time for an upgrade.

HLdan
Jan 3, 2009, 09:24 PM
Ironically the video plays MUCH better in Windows. I have a MBA Rev B/SSD and that HD video stutters in OS X. I booted up to Windows Vista (bootcamp) and the video plays a whole lot better with only a very slight stutter at the beginning and played smoothly till the end. I hate that flash is better in Windows. I just don't really know why?
Anyone have insight to this?

EDIT: Although it did play better in Windows on my MBA I tried it on my 24" 2.8Ghz iMac and the video played perfectly without a hiccup even while it was loading. Go figure.

pgharavi
Jan 3, 2009, 09:49 PM
The video is jerky if it plays while it loads. If I pause it and wait for it to load completely, it plays fine.

tubbymac
Jan 4, 2009, 12:27 AM
I hate that flash is better in Windows. I just don't really know why?
Anyone have insight to this?

EDIT: Although it did play better in Windows on my MBA I tried it on my 24" 2.8Ghz iMac and the video played perfectly without a hiccup even while it was loading. Go figure.

Ready for some wild speculation? :) Adobe Photoshop is much faster and efficient on Windows than on OSX given the same machine. Apple refuses to add flash support to Safari on the iPhone. Put those two together and my guess is there's some bad blood between Apple and Adobe and there is some back and forth chest beating going on between those two. When they kiss and make up suddenly flash and photoshop will get awesome under OSX.

The video is jerky if it plays while it loads. If I pause it and wait for it to load completely, it plays fine.

I get the same behavior. Most likely it has to do with both flash being badly programmed on OSX and the broadcom wireless driver being a piece of garbage. It's a big pain to get a bootcamp install to not stutter with the POS that is broadcom's wireless drivers under windows, so I imagine Apple has similar headaches writing the driver under OSX.

As long as the broadcom wireless isn't downloading/uploading while the flash video is playing it doesn't seem to stutter on HD on OSX on the notebooks. iMacs I don't know if they have the broadcom wireless or if they use a different driver.

mabaker
Jan 5, 2009, 01:18 PM
The video is absolutely unwatchable on my Dual G5. It's rather a disgrace how Apple and Adobe handled the Flash implementation in Mac Os X.

NC MacGuy
Jan 5, 2009, 02:25 PM
It's not super awful on mine as long as I let it load all the way before I play it and don't have a boatload of windows open.

quovadis
Jan 5, 2009, 04:21 PM
runs smooth here ...

Nermal
Jan 5, 2009, 04:26 PM
Fine on my 3 GHz C2D.

tdream
Jan 17, 2009, 10:29 PM
Choppy on Aluminium Macbook 2.0

juanster
Jan 17, 2009, 10:32 PM
yeah it's pretty choppy on my MB too

Hurd111
Jan 17, 2009, 10:43 PM
it runs smooth on my 2.0ghz imac...

Wotan31
Mar 2, 2009, 10:42 PM
Here's what you need to do to get youtube videos to play SMOOTHLY. Pay attention now, it's very simple.

Go to Adobe.com and download the latest flash player version. As of today, it's version 10.0.22.87

After installing this, all youtube videos, even HD videos, played silky smooth, both on my C2D MBP, and on my PB G4.

If you have choppy youtube, chances are your installed flash version is 9.x which sucks hairy goat balls. Upgrade now!

faxao
Mar 3, 2009, 01:58 AM
Here's what you need to do to get youtube videos to play SMOOTHLY. Pay attention now, it's very simple.

Go to Adobe.com and download the latest flash player version. As of today, it's version 10.0.22.87

After installing this, all youtube videos, even HD videos, played silky smooth, both on my C2D MBP, and on my PB G4.

If you have choppy youtube, chances are your installed flash version is 9.x which sucks hairy goat balls. Upgrade now!

Done...still some stuttering present on my rev.B 1,86 SSD when palying back the fully downloaded video.....must be a Flash/OSX issue.....:(

mabaker
Mar 3, 2009, 08:59 AM
Here's what you need to do to get youtube videos to play SMOOTHLY. Pay attention now, it's very simple.

Go to Adobe.com and download the latest flash player version. As of today, it's version 10.0.22.87

After installing this, all youtube videos, even HD videos, played silky smooth, both on my C2D MBP, and on my PB G4.

If you have choppy youtube, chances are your installed flash version is 9.x which sucks hairy goat balls. Upgrade now!

Powerbook G4 playing flash HD video smoothly? :eek:

I find it hard to believe, but thanks for your input, Wotan! I am here completely resigned on my Powermac G5 dual which won't play any single flash HD video cuzz the perfoamnce is abysmal. ABYSMAL.