PDA

View Full Version : Trying to set up localhost




MDMstudios
Apr 12, 2009, 02:40 PM
Hey all, I'm trying to get Apache working on my iMac (running latest OS and update), I turn on web sharing, which from what I understand should get everything working. When I try to accsess a file in my Sites dirrectory though, I get error 403 " Forbidden

You don't have permission to access /~daniel/index.html on this server. " The URL I am trying to connect to is localhost/~daniel/index.html

I can connect to localhost, just not localhost/~daniel and anything that comes after that.
Permissions are set so I can read and write, and everyone else can just read. I have the correct firewall settings as well.



milk242
Apr 12, 2009, 07:51 PM
You can check your permissions on your user folder.

MDMstudios
Apr 12, 2009, 07:53 PM
You can check your permissions on your user folder.

They are set correctly.

milk242
Apr 13, 2009, 01:28 AM
No idea seems to work for me, you can try MAMP

dampfdruck
Apr 13, 2009, 07:24 AM
Apache keeps an error log where you can see what the problem is. In your case, though, it is very clear: Fix the permissions.

GroovyLinuxGuy
Apr 13, 2009, 07:37 AM
Ran across this problem myself when I first installed 10.5

http://support.apple.com/kb/TA25038

That should help you.

Cheers

MDMstudios
Apr 13, 2009, 03:05 PM
Ran across this problem myself when I first installed 10.5

http://support.apple.com/kb/TA25038

That should help you.

Cheers

That did the trick! Thanks for helping me out!