PDA

View Full Version : iBook G4 won't restart/shutdown




sheaitisnotso
Jun 16, 2009, 11:43 PM
Okay so I've searched all around the internet and can't find anything so hoping someone can help me.

Last week I noticed that when I tried to shutdown my computer the main screen would go blank and then that little spinning thingy in the middle would start spinning, but then it freezes up and just keeps spinning and never shuts down completely. So I have to shutdown manually by holding the power button down. I thought no big deal, I just won't shut it down very often.

Now the new problem is it won't restart either. Same thing happens where the screen goes blank and the spinning thingy keeps going. So today I downloaded and installed the new Safari and to finish installing it, it says the computer has to be restarted. However with the computer not restarting on its own, the software can never fully install. What do I do?

I tried resetting the PMU but that didn't do anything but change my date and time back to 1969.

Any help would be much appreciated.



iBookowner
Jun 20, 2009, 01:18 PM
I had that trouble too with my second hand iBook, I had to reinstall OSX again, I managed to get a copy of Tiger and used that as it came with Panther installed. After the installation it started and shut down without any problems. Hope this helps.

~Wibble~
Jun 20, 2009, 01:21 PM
safe booting it might sort it out. i've had various problems while booting recently and safe booting seemed to of sorted it out.
just hold Shift on boot just after the startup tone and keep it held until the spinning cog and the apple symbol appear.

hope that helps

~wibble

SHADO
Jun 20, 2009, 01:45 PM
Have you tried resetting disk permissions and using a disk repair utility like DiskWarrior or Drive Genius 2?

sheaitisnotso
Jun 29, 2009, 11:50 AM
Okay I tired safe booting and resetting the disk permissions but still no luck. Before I do anything else I'm gonna find an external hard drive to save all of my files. Thanks very much for the input.

iLog.Genius
Jun 29, 2009, 01:42 PM
Did you try resetting PMU/SMC/PRAM?

sheaitisnotso
Jun 30, 2009, 12:32 PM
I did try the PMU but it had no effect. Thanks I'll try the SMC and PRAM.