PDA

View Full Version : Wifi not working right. White 13" MacBook1,1




philip.n.robbin
Jul 24, 2009, 01:33 PM
Hi,

My wireless is not functioning well at all recently and I have no idea why. Could it be that the Apple updates have finally sent me some sort of "kill" command so that I have to upgrade? :P

Full description:


My Wifi has been perfect since 2006, but this week I can't do a thing.
I can access Wifi perfectly on my iPod Touch but in the same location my AirPort struggles to find the SSID and then struggles to connect.
Connects and then disconnects or never actually connects (shows bars, but can't do anything online)
Wired: works fine when connected to a modem/router with a cat 5 cable.
I check for viruses and I keep updated with all patches and security upgrades
Tried 3 good locations with WEP, with no protection at all, and with WPA2. No luck.



Stats:

Body: White Macbook 13" v 1,1
OS: Originally had the "Tiger" o/s and I have since upgraded (clean install) to Leopard 10.5.7
Applecare: Ended recently.

AirPort Card Information:

Wireless Card Type: AirPort Extreme (0x168C, 0x86)
Wireless Card Locale: USA
Wireless Card Firmware Version: 1.4.10.3
Current Wireless Network: AirPort is currently turned off

Can anyone help me?

Phil



philip.n.robbin
Jul 24, 2009, 02:22 PM
I found this on apple.com

"Recommendation was to remove the AirPort preferences file in /Library/Preferences/SystemConfiguration
(com.apple.airport.preferences.plist) and let it be regenerated."

I just tried it and it connected fine. Now, I will roam around the house and see what happens.

Phil

Update:

I cano now get connected in the same room as the router, but as soon as I enter another room (where another white macbook and iPod Touch get full bars, I get nothing. All my bars fall to zero.

Can anyone help?