PDA

View Full Version : MKV = Fine, MOV = Fail! Movie Converting Help




DoFoT9
Jul 25, 2009, 05:18 PM
Hey everyone,

I am having a very wierd problem with some MKVs that I am trying to burn to DVD.

I used VisualHub to directly convert the MKV into an .iso ready to burn. All went fine it took about 4-5hrs (was an 8gb Blu-Ray rip) to make it properly, the problem was that it selected the "German" language of audio.

I tried searching for a way for VisualHub to select the audio track (English is track 2) but I came up with nothing.

My second method was to open the movie in QT Pro, and delete the German track, thus making the other English track the primary track. That went fine, but WHENEVER I try to convert it with anything (Toast, VisualHub etc) it has massive calculation times (VisualHub estimated 3000 minutes to complete). Toast has been going overnight and is only at 12%.

I am curious why this container 'reformat' makes the time required to finish so much higher!

I am now copying the file over to a faster computer and will see how that goes, though I know it will still take yonks.


Thanks for any help, I'll be back in a few hours after work :)

DoFoT9



NJuul
Jul 26, 2009, 04:55 AM
I don't know why the converting mov takes that much longer, but you might be able to remove the german track from the mkv, and then run the "new" mkv through either VH or toast.

MKVtools claims it is possible:
http://www.emmgunn.com/mokgvm2dvd/mokgvmhome.html

DoFoT9
Jul 26, 2009, 05:35 AM
I don't know why the converting mov takes that much longer, but you might be able to remove the german track from the mkv, and then run the "new" mkv through either VH or toast.

MKVtools claims it is possible:
http://www.emmgunn.com/mokgvm2dvd/mokgvmhome.html

thanks for your reply!! its very confusing :-S. thanks for the link i shall give it a go :)

(visual hub still says 2304minutes left to go haha).

DoFoT9
Jul 26, 2009, 05:40 AM
i must also add:: it must have problems reading the file or something, CPU usage is only hoverring around 90% (of 200%) and Disk Usage doesnt go above 1mbps (thats only every 5 seconds), it might have to check the file everytime or something??

DoFoT9
Jul 26, 2009, 06:52 AM
im back!! i used MKVTools to get rid of the unwanted subtitles, and a muxed m4v was created (pass-through), buuut the problem still stands, its going to take forever (again).

DoFoT9
Jul 28, 2009, 07:05 AM
well its been nearly 3 days but VisualHub is not far off finishing! (the time remaining thing has been stuck on 2122 minutes for the whole time). this better be worth it. wish me luck!