PDA

View Full Version : My O2 App




sneeks
Sep 15, 2009, 11:19 AM
An official app has been released today for checking inclusive allowance etc for o2 customers



PhantomZone
Sep 15, 2009, 11:55 AM
can you get it to work?

i either get a 'network unavailable' error or a '500' error :rolleyes:

redgaz26
Sep 15, 2009, 11:59 AM
Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 3_1 like Mac OS X; en-us) AppleWebKit/528.18 (KHTML, like Gecko) Version/4.0 Mobile/7C144 Safari/528.16)

I was having problems signing in too. I went on to their website and signed in and out then done it again on the app and it worked straight away. No sure if that's what did it right enough. Cool app though. Well done o2.

BNZ1
Sep 15, 2009, 12:02 PM
worked fine for me first time. Nice looking app.

OllyW
Sep 15, 2009, 12:07 PM
can you get it to work?

i either get a 'network unavailable' error or a '500' error :rolleyes:

I got the network unavailable message when I entered the wrong password. :o

It's working great now I've entered the correct info. :D

stephendoc1984
Sep 15, 2009, 12:58 PM
I get a message saying 'Could not retrieve data. Please try again later'. Anyone else any tips on signing in. Signed in on main site fine. Can't get into the app. Anyone tried this who has their email address as the username and not the original username supplied to them?

Curley
Sep 15, 2009, 05:10 PM
Im having trouble signing in also

stephendoc1984
Sep 15, 2009, 05:17 PM
Thanks for all the great comments on our My O2 app.
We're looking into the login issues a few of you are telling us about.

O2 Twitter Feed (http://twitter.com/O2/status/4006745677)

soulghost
Sep 16, 2009, 04:12 AM
worked fine for me first time. Nice looking app.
+1

philgilder
Sep 16, 2009, 04:23 AM
i prefer mobile allowance

no PIN login, and it loads the data faster. it also shows it in an easier to understand way

macinhand
Sep 16, 2009, 05:12 AM
Same here! i can't log on either :confused: i log on no problems through Safari so it's not a user name/password issue.

sneeks
Sep 16, 2009, 05:18 AM
can you get it to work?

i either get a 'network unavailable' error or a '500' error :rolleyes:

I have the same problem with the app and cannot login. O2 customer services said they will look into it and get back to me. The details work without any issue via Safari or the 3rd party Allowance app.

LostLogik
Sep 16, 2009, 07:00 AM
Just tried this - nice app. Good clean interface and works very well. No problems with login, PIN registration or subsequent use. Like it a lot.

Did read somewhere that this will not work with Business accounts, in case there are any having problems that have business accounts.

biggrim
Sep 16, 2009, 09:52 AM
Looks like the issue with this has been resolved as I have managed to log in and set up a PIN ok. Nice app, easy to use and interpret.

sneeks
Sep 16, 2009, 09:57 AM
No success for me yet, with my login details I continue to get this screen. The network connection is working perfectly.

http://www.sneeks.co.uk/iphone3g/myo2.jpg

macinhand
Sep 16, 2009, 10:13 AM
I get a different message :confused:

LostLogik
Sep 16, 2009, 10:30 AM
No success for me yet, with my login details I continue to get this screen. The network connection is working perfectly.

http://www.sneeks.co.uk/iphone3g/myo2.jpg

Well it's obvious what your problem is. You're on 3G! We all know how rubbish the O2 3G network is. No wonder the app couldn't find any network. :D

biggrim
Sep 16, 2009, 03:54 PM
Was working for me today and the majority of the evening. Just tried it 10 mins ago and it was fine. Tried it 5 mins ago and getting error message again. Clearly an issue with O2's servers/systems (for a change lol). When it works though, it is nice.

darkpaw
Sep 16, 2009, 04:23 PM
Doesn't work at all for me. Tried a few hours ago and couldn't get in. Tried now, and still can't get in. Correct username and password. Can get in via Safari without a problem.

I see from the O2 twitter feed that they've identified the problem and are working on fixing it. Guess I'll wait then...