PDA

View Full Version : MKV video converted to itunes wont play on AppleTV




Fulgham
Oct 18, 2009, 08:35 PM
So I have an MKV video file that plays fine on my machine using VLC.

I converted the file using MKV tools 2.2.1 to an MP4 file. Using the attached settings.

Then i copied the completed file over into iTunes 9.0.1 (9). I now have the file in my movies library in iTunes and can play perfectly fine on machine.

Now the file will appear on my AppleTV - My Movies folder. (it has not had a chance to copy yet). The file will play on the AppleTV fine via streaming. If I let the apple tv sit and force a sync to copy the newly added file over to the AppleTV, I will now get an unrecognized file type error.


Any help? Im going bald at 25 over this issue!


Edit:
I am currently working around by turning on Custom Sync and removing that file from the list of movies being transferred to the AppleTV. Again the file will play on the AppleTV just fine via streaming, but if i put automatic sync back on the file will not play.



Perrumpo
Oct 26, 2009, 07:54 PM
I've never been able to get converted-mkv's to play well on tv. Sometimes, they screw up iTunes, too. It's like they look compatible but aren't. Sorry that I can't help.

The Mad Kiwi
Oct 26, 2009, 11:48 PM
I use handbrake to convert MKVs and it usually works fine.

SHIVERINGGOAT
Oct 27, 2009, 04:54 AM
You need to keep within the Apple TV specs:

(maximum resolution: 1280 by 720 pixels at 24 fps, 960 by 540 pixels at 30 fps) in .m4v, .mp4, and .mov file formats

I have had this problem on some files when I use handbrake as one of the presets for Apple Tv does not make the output file fit the above specs.

In the example you showed I would reduce the frame rate to 24fps and make sure that the output file is no bigger than 1280 x 720 then it should be fine you can tweak the output size in settings on handbrake.

Basically for me the problem is when you get a 1080 mkv file you need to shrink it to fit into 1280 x 720 and make sure the frame rate is 24fps.

Good luck.

Cave Man
Oct 27, 2009, 10:16 AM
In addition, you need to make sure the video bit rate does not exceed 5.5 mbps.