PDA

View Full Version : Macbook Air Screen Problems




MacRuler
May 8, 2010, 09:26 PM
I have been having this problem for like 3 months now. I am talking about the black squares and the color of the menu bar. It happens when the computer gets a little hot, it is really annoying and cant find the fix anywhere. I dont even know what to call it or how to address it. Does anyone else have this problem or know how to solve it? Thanks



stoconnell
May 8, 2010, 09:49 PM
Looks similar to the video corruption in this thread (http://forums.macrumors.com/showthread.php?t=902721).

MacRuler
May 8, 2010, 10:03 PM
can anyone else shed some light on this? I looked at the logic board, and cant seem to find any corrosion or anything wrong with the logic board.

MacRuler
May 8, 2010, 10:09 PM
can anyone else shed some light on this? I looked at the logic board, and cant seem to find any corrosion or anything wrong with the logic board.

myuserid08
May 9, 2010, 09:44 AM
Have you restored?
Have you reset pram, nvram etc? http://support.apple.com/kb/ht1379

If you have I would say you need a new logic board.

Scottsdale
May 9, 2010, 02:26 PM
Have you restored?
Have you reset pram, nvram etc? http://support.apple.com/kb/ht1379

If you have I would say you need a new logic board.

Looks like the graphics card is fried.

MacRuler
May 9, 2010, 07:52 PM
well if it does have something to do with the logic board, would it be safe to clean it with rubbing alcohol? i dont want to spend money on it, because it only happens sometimes and it goes away when i log out or restart or shut down the computer so its not a Huge deal.

PsyD4Me
May 9, 2010, 09:59 PM
I have been having this problem for like 3 months now. I am talking about the black squares and the color of the menu bar. It happens when the computer gets a little hot, it is really annoying and cant find the fix anywhere. I dont even know what to call it or how to address it. Does anyone else have this problem or know how to solve it? Thanks

which Rev do you have? how heavily do you use your air?

Scottsdale
May 9, 2010, 10:23 PM
well if it does have something to do with the logic board, would it be safe to clean it with rubbing alcohol? i dont want to spend money on it, because it only happens sometimes and it goes away when i log out or restart or shut down the computer so its not a Huge deal.

That's not your problem. Unless you know you had spilled something there's nothing to use alcohol on it to clean up. I think you should see if there's warranty coverage.

stoconnell
May 9, 2010, 10:29 PM
Sorry, my comment wasn't meant to imply that a spill would necessarily be the root cause. More than you likely have a bad GPU in there, which probably would require a new logic board. Is this machine still under warranty? If not, you might try replacing the thermal grease and see if that helps maybe there isn't sufficient contact between the GPU and the heat sink.

MacRuler
May 10, 2010, 02:16 PM
this is the rev A 1.6, and since like 15 minutes ago i am facing even more problems! the computer is VERY sluggish even with just safari open, like when i type it takes like half a second for the letter to appear. i guess ill just have to call apple.:(

MacRuler
May 10, 2010, 02:26 PM
nevermind about the slowing down of the computer, i just did a reset of the pram, and it seems to be ok. I just called apple and they said that my phone support expired 90 days ago. So i cant even talk to them about the problem......:eek: i guess i'll just get applecare from ebay, if it becomes to much of a problem. Does anyone think this will be a problem, considering that i will be installing a runcore ssd in about 1-2 weeks from now? thank you

MacRuler
May 10, 2010, 03:15 PM
and to scottsdale i might of spilt soapy water in it from when i installed the bestkinsever i bought. could that have caused the problem? and if so, could i safely fix it with rubbing alcohol? thanks

AlanShutko
May 10, 2010, 04:51 PM
Do you have the Flash 10.1 beta installed? Or Adobe CS5 (which installs the flash beta)? Flash 10.1 beta causes problems that look like this on the MBA rev A.

Scottsdale
May 10, 2010, 05:31 PM
and to scottsdale i might of spilt soapy water in it from when i installed the bestkinsever i bought. could that have caused the problem? and if so, could i safely fix it with rubbing alcohol? thanks

No. It's really NOT your problem. If you spilled a glass of orange juice or a bowl of soup, maybe. This is something in your graphics or logic board and it's not going to be cleaned up with alcohol.

gan6660
Jun 25, 2010, 06:15 PM
Having the same issue on a MBA I recently bought and was wondering if you ever found a fix?

zedsdead
Jun 25, 2010, 08:41 PM
This was one of the many issues with the Rev A that i had. I believe apple replaced the entire logic board and graphics card.

gan6660
Jun 25, 2010, 08:58 PM
This was one of the many issues with the Rev A that i had. I believe apple replaced the entire logic board and graphics card.

Do you think they would do it out of warranty? Like with the cracking on the macbooks?