PDA

View Full Version : Weird YouTube connection problem on my MacBook




eraykarakuzu
May 27, 2010, 08:10 AM
Hi everybody,

I've got a weird problem: I can't seem to access YouTube. I've tried all that I could think of. I'm using a MacBook 5.1 running OS 10.6.3.

A couple of days ago, and for no apparent reason as far as I am concerned, I started getting this message when I tried to go on YouTube: ''Safari can’t open the page “http://www.youtube.com/” because the server where this page is located isn’t responding.'' I also tried Firefox and Chrome to no avail. I was using OpenDNS at the time. I haven't experienced a similar problem with any other site. At it seems that the network I'm using makes no difference whatsoever; same story at home, at a friend's or in the campus.

Desperate for a remedy, I switched to Google DNS and went through all steps at http://code.google.com/speed/public-dns/docs/using.html#testing . DNS settings seem to be working properly and it resolves YouTube through Terminal. Plus, when I use Network Utility to ping www.youtube.com I get the following result: 10 packets transmitted, 0 packets received, 100.0% packet loss.

My current settings are:

TCP/IP: Using DHCP (IPv4) / Automatically (IPv6)
DNS: 8.8.8.8 / 8.8.4.4 Google
Proxy: Use Passive FTP mode (PASV)

I also checked to see whether any of the programs I'm using might be interfering. I've run out of ideas.
Should I reinstall the whole OS?

Thanks.



1ne
May 27, 2010, 02:25 PM
Do you have another machine to try accessing youtube?

eraykarakuzu
May 28, 2010, 12:18 AM
Do you have another machine to try accessing youtube?

Well, my roommate has an HP (wireless at home), and one of my classmates has a MBP (wireless in the campus), neither seems to experience any problems accessing YouTube.

What do you suggest I do with these machines?

eraykarakuzu
May 28, 2010, 03:16 AM
Problem solved!

Apparently, the hosts file got modified somehow. There were 2 lines related to YouTube (domain name, IP address etc.). I deleted those lines and saved the hosts file.

Voilà!

itaigoldman
Dec 10, 2010, 02:48 PM
i feel stupid, have the same problem on my HP.
what exactly did you do??
thanks,
Itai