PDA

View Full Version : oh crap!


lowam
Nov 19, 2004, 11:36 PM
hey everybody. a couple of nights ago i cleaned out the inside of my powermac, nothing crazy. but when i closed it all up and tried to fire it up the usb wouldn't work and the monitor wouldn't come on. i know the monitor is fine because i tried it on another pc. any ideas and please dont say logic board crash. thanks

DanTekGeek
Nov 19, 2004, 11:49 PM
1. How/what did you clean it with/
2. check that all cables are attached.

CanadaRAM
Nov 20, 2004, 01:40 AM
Need more information in order to help

What Mac model is it?
How old is it?
Do you get the startup chime, but the monitor won't come on?
What happens if you reset the PRAM (Command-Option-P-R at startup, hold down till it chimes three times and then release)
If it's over 4 years old, have you replaced the PRAM battery?

Thanks
Trevor
CanadaRAM.com

lowam
Nov 20, 2004, 10:20 PM
its a digital audio g4. now it wont even power up. i guess the power supply is totally shot. do i have to replace the ps with the same exact one that came out of it or can i use one from a different powermac? are there other ones that are compatible? can the ps go out slowly over time or do they usually just go poof? sorry for all the questions. im a mac newby. thank you for your help.

jimsowden
Nov 20, 2004, 11:52 PM
Hit it up with a PMU reset. (PMU button on the logic board near processor)

G5orbust
Nov 20, 2004, 11:56 PM
You might have zapped the mobo with some static, in which case youre not in good shape.

efoto
Nov 21, 2004, 01:55 AM
Google it, always good.

I have not read this through, but it potentially seemed useful:
TidBITS PSU Replacement (http://db.tidbits.com/getbits.acgi?tbart=07230)

I just skimmed it and it appears to be more appropriately related to replacing some drive PS or something...but it could prove useful, not sure...hope it helps.

Abstract
Nov 21, 2004, 02:34 AM
Did you clean it using a liquid? Did you wait for it to dry?