Go Back   MacRumors Forums > News and Article Discussion > Mac Blog Discussion

Reply
 
Thread Tools Search this Thread Display Modes
Old Feb 24, 2012, 07:30 PM   #1
MacRumors
macrumors bot
 
Join Date: Apr 2001
Apple Releases iMac Wi-Fi Update v1.0






Apple just released an update for all iMacs, Late 2009 or newer. It requires OS X Lion 10.7.3.
Quote:
About iMac Wi-Fi Update v1.0

This update resolves an issue that may cause an iMac to not automatically connect to a known Wi-Fi network after waking from sleep.

It is recommended for all iMac (Late 2009 or newer) users running 10.7.3.
Weighing in at 25.81MB, the update can be downloaded from Apple's software update page.

Article Link: Apple Releases iMac Wi-Fi Update v1.0
MacRumors is offline   6 Reply With Quote
Old Feb 24, 2012, 07:32 PM   #2
NXTMIKE
macrumors 6502
 
Join Date: Nov 2008
Location: Canada
FINALLLLLYYYYYYYYYYYYY.

took them long enough. This issue has been happening to many users since August when Lion was released.
__________________
iMac 2.8Ghz 27" i5 Retina MBP iPhone 4
Check out my GraphicRiver Portfolio at http://bit.ly/fhz5jF Design and print business cards, brochures, flyers & more at Inkly.ca
NXTMIKE is offline   11 Reply With Quote
Old Feb 24, 2012, 07:41 PM   #3
JimMacFan
macrumors regular
 
Join Date: Jan 2009
I wonder of it will help with intermittent wifi connection that drops on and off.
JimMacFan is offline   1 Reply With Quote
Old Feb 24, 2012, 07:48 PM   #4
Ubuntu
macrumors 68000
 
Join Date: Jul 2005
Location: UK/US
Quote:
Originally Posted by NXTMIKE View Post
FINALLLLLYYYYYYYYYYYYY.

took them long enough. This issue has been happening to many users since August when Lion was released.
Earlier than that for me. Was one of the main reasons I sold my iMac, as much as I loved it.
__________________
Windows & Mac user, iOS & Android developer.
Ubuntu is online now   0 Reply With Quote
Old Feb 24, 2012, 07:52 PM   #5
Reddmanz
macrumors regular
 
Join Date: Jul 2010
Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

I've never had this problem on mine actually. Didn't even know it was an issue.
Reddmanz is offline   -4 Reply With Quote
Old Feb 24, 2012, 07:54 PM   #6
Lancetx
macrumors 68000
 
Lancetx's Avatar
 
Join Date: Aug 2003
Location: Texas
Quote:
Originally Posted by Reddmanz View Post

I've never had this problem on mine actually. Didn't even know it was an issue.
I didn't either until the 10.7.3 update. Glad they got this fix out.
Lancetx is offline   0 Reply With Quote
Old Feb 24, 2012, 07:54 PM   #7
aper1202
macrumors newbie
 
Join Date: Feb 2012
I have this issue with my Fall 2010 11" MBA. When I open the lid from sleep sometimes the wifi won't connect or will connect to another network. I hope this issue is addressed for my model as well.
aper1202 is offline   4 Reply With Quote
Old Feb 24, 2012, 07:54 PM   #8
Nielsenius
macrumors 6502a
 
Join Date: Apr 2011
Location: Virginia
There was a similar issue involving the MacBook Airs, as well, correct? If so, I think that issue was fixed a long time ago. What took so long for this update?
__________________
15" MacBook Pro with Retina Display
27" Cinema Display
iPhone 6 Plus
Nielsenius is offline   0 Reply With Quote
Old Feb 24, 2012, 08:25 PM   #9
nicklad
macrumors 6502
 
Join Date: Jun 2007
Location: Nottingham, UK
For information, this update just changes the AirPortAtheros40.kext from 5.0.2 (502.60.2) to 5.0.3 (503.60.3) inside IO80211Family.kext.
nicklad is offline   0 Reply With Quote
Old Feb 24, 2012, 08:39 PM   #10
apple101
macrumors regular
 
Join Date: Jan 2008
Location: New Jersey
Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

The aluminum May 2009 MacBook has this problem too. It is annoying.
__________________
- 2007 iPod touch (16 GB)
- 2009 Aluminum MacBook (2.0)
- 2011 iPhone 4 (32GB Verizon)
apple101 is offline   0 Reply With Quote
Old Feb 24, 2012, 08:41 PM   #11
nicklad
macrumors 6502
 
Join Date: Jun 2007
Location: Nottingham, UK
Quote:
Originally Posted by apple101 View Post
Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

The aluminum May 2009 MacBook has this problem too. It is annoying.
I think it's just the Atheros chipsets that have had problems...
nicklad is offline   0 Reply With Quote
Old Feb 24, 2012, 08:52 PM   #12
daneoni
macrumors G4
 
daneoni's Avatar
 
Join Date: Mar 2006
No love for MBPs?
__________________
15" rMBP Core i7 | 27" ACD | AEBS | 5G iPod | iPhone 5S | 3G Apple TV | rMini
daneoni is offline   0 Reply With Quote
Old Feb 24, 2012, 08:55 PM   #13
nicklad
macrumors 6502
 
Join Date: Jun 2007
Location: Nottingham, UK
Quote:
Originally Posted by daneoni View Post
No love for MBPs?
None of them use the KEXT they changed...
nicklad is offline   0 Reply With Quote
Old Feb 24, 2012, 09:26 PM   #14
philbeeney
macrumors 6502
 
Join Date: Jul 2004
Location: Brampton, ON
They've changed the firmware for the Atheros chipset.

Before: 4.0.61.4-P2P
After: 4.0.61.5-P2P

I hope this does fix the dropping Wi-Fi problem because it really was a PITA.
philbeeney is offline   0 Reply With Quote
Old Feb 24, 2012, 09:31 PM   #15
nicklad
macrumors 6502
 
Join Date: Jun 2007
Location: Nottingham, UK
Quote:
Originally Posted by philbeeney View Post
They've changed the firmware for the Atheros chipset.

Before: 4.0.61.4-P2P
After: 4.0.61.5-P2P

I hope this does fix the dropping Wi-Fi problem because it really was a PITA.
It has fixed the issue on my Mid 2007 MBP that has had its wireless card swapped out with an AR9380. I installed it with Pacifist and then used KEXT Helper's "kext permissions" advanced option, and a reboot.
nicklad is offline   0 Reply With Quote
Old Feb 24, 2012, 09:36 PM   #16
Lucent336
macrumors newbie
 
Join Date: Dec 2011
Mbp

Well, my MBP has had the same issue since updating from SL to Lion a couple weeks ago. It doesn't happen -every- time, but it happens enough to be a nuisance.
Lucent336 is offline   0 Reply With Quote
Old Feb 24, 2012, 09:37 PM   #17
sterlingindigo
macrumors 6502
 
Join Date: Dec 2007
Location: East Lansing
Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

Opsh
__________________
"How do you like them 's?"
-Good Will Hunting

Last edited by sterlingindigo; Feb 24, 2012 at 09:39 PM.
sterlingindigo is offline   -2 Reply With Quote
Old Feb 24, 2012, 09:38 PM   #18
Sardonick007
macrumors regular
 
Join Date: May 2011
Good

Never an issue on my iMac, but I do love updates. Curious thing is this IS an issue on my 2011 Macbook Pro. Minor inconvenience if anything. Going back to the fact that I do LOVE updates.
Sardonick007 is offline   4 Reply With Quote
Old Feb 24, 2012, 10:51 PM   #19
TreyCox
macrumors regular
 
Join Date: Jan 2012
Location: Swainsboro, Ga
Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

Finally! This was sooo needed.
__________________
21.5" iMac (Mid 2011), 27" iMac (Late 2010), iPhone 5, iPhone 5s (CDMA), iMac G3 (Summer 2000), tv 2, Power Mac G5 (Mid 2005), 24" iMac (Late 2006)
TreyCox is offline   2 Reply With Quote
Old Feb 24, 2012, 11:26 PM   #20
macbookguy
macrumors regular
 
Join Date: Dec 2006
Location: Columbus, Ohio
I agree with some of the previous posters in saying this was never a problem for my iMac, but my late 2011 MacBook Pro could really use it...
__________________
2011 Mac mini | 2012 Mac mini | 2011 iMac 21.5 | Late 2011 15" MacBook Pro | iPhone 5s Gold | iPad Air LTE
iPad mini LTE | 2nd Gen AppleTV | 3rd Gen AppleTV
macbookguy is offline   0 Reply With Quote
Old Feb 24, 2012, 11:29 PM   #21
hexor
macrumors regular
 
Join Date: Nov 2002
Location: Minnesota
It fixes it! Finally! I thought it was something on just my system. It also fixes finding wi-fi on reboot as well. No more manually trying to get on a wi-fi network that takes up to 30 seconds after waking from sleep. Now it is automatically reconnecting to my wi-fi network and loading a web page within 5 seconds of wake up.
hexor is offline   3 Reply With Quote
Old Feb 25, 2012, 12:10 AM   #22
Yebubbleman
macrumors 68020
 
Yebubbleman's Avatar
 
Join Date: May 2010
Location: Los Angeles, CA
Eerily enough, I'm having the same problem on my dad's Mid 2010 Mac mini, which is running OS X Lion 10.7.3, though this started happening fairly recently. My Mid 2010 Mac mini Server running OS X (Client, not Server) Snow Leopard 10.6.8 doesn't have the problem. Must be a Lion quirk.
__________________
MacBook Pro (15" Mid 2012); PC Tower (3.4GHz Phenom II x4; Radeon HD 6850); 5th Gen iPod touch; 2nd and 3rd Gen tv; iPad Air Verizon; Galaxy S5 Verizon
"Don't Cry, Eat Pie"
Yebubbleman is offline   0 Reply With Quote
Old Feb 25, 2012, 12:13 AM   #23
PlaceofDis
macrumors Core
 
Join Date: Jan 2004
i had some issues with the first release of lion but none since i did a fresh install. hopefully this doesn't break anything along the way but seems fine so far after installation.
__________________
dim my eyes on the waves of confessions...
PlaceofDis is offline   -1 Reply With Quote
Old Feb 25, 2012, 12:42 AM   #24
tirerim
macrumors regular
 
Join Date: Aug 2006
Well, this would be useful if I hadn't long since given up on wireless with the iMac and hooked up an ethernet cable.
__________________
27" iMac; 11" MacBook Air; Power Mac G5; 12" PowerBook G4; Lime iMac; PowerBook 3400c; Power Mac 7200; ][e
tirerim is offline   3 Reply With Quote
Old Feb 25, 2012, 12:48 AM   #25
Macman45
macrumors G5
 
Macman45's Avatar
 
Join Date: Jul 2011
Location: Somewhere Back In The Long Ago
Strange thing is, I wasn't suffering the issue that many had, perhaps because my wifi infrastructure is based on Apple kit, but I installed it anyway. It ran my internal HDD into a frantic state for about 10 minutes but settled back down.

Can't say I've noticed any difference, but hopefully it will fix the bugs that have been experienced by others. Cynics say that it was non Apple equipment that had the most of these issues, but I doubt it, I'm sure people with AEBS TC also had issues, I'm just lucky.
__________________
Thats Not All Folks
Macman45 is offline   0 Reply With Quote

Reply
MacRumors Forums > News and Article Discussion > Mac Blog Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Apple Releases EFI Update for New Late 2013 iMac Models to Address Boot Camp Install Issues MacRumors Mac Blog Discussion 9 Sep 25, 2013 08:56 AM
Apple Releases iMac EFI Update 2.0 to Fix Sleep and Thunderbolt Issues MacRumors Mac Blog Discussion 20 Jan 5, 2013 01:11 AM
Apple Releases iPhoto 9.4.1 Update MacRumors Mac Blog Discussion 65 Nov 29, 2012 11:17 AM
Apple Releases 5.1 Update for 2nd and 3rd Generation Apple TV MacRumors MacRumors.com News Discussion 300 Oct 26, 2012 10:41 PM
Apple Releases 5.0.2 Update for 2nd and 3rd Generation Apple TV MacRumors iOS Blog Discussion 62 Jun 10, 2012 08:19 PM

Forum Jump

All times are GMT -5. The time now is 09:32 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC