Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone

Reply
 
Thread Tools Search this Thread Display Modes
Old Sep 27, 2012, 01:44 PM   #1
acousticbiker
macrumors 6502
 
Join Date: Jun 2008
Can't send MMS on Verizon iPhone 5

iMessages (text & pics) are working fine, but standard MMS to a non-iPhone user on a different carrier is not going through. I've tried toggling MMS on/off, using WiFi & LTE, power cycling, and resetting but with no success. Verizon tech support has escalated the issue, but I was curious whether anyone else was having this issue (and whether you know of a solution).
acousticbiker is offline   0 Reply With Quote
Old Sep 27, 2012, 01:56 PM   #2
Buckeyestar
macrumors 6502a
 
Buckeyestar's Avatar
 
Join Date: Sep 2011
Don't know what to tell you. I've sent pictures to both of my parent's Tracfones without any problems.
Buckeyestar is offline   0 Reply With Quote
Old Sep 27, 2012, 01:58 PM   #3
iceterminal
macrumors 68000
 
iceterminal's Avatar
 
Join Date: May 2008
Location: Dallas Tx.
So you're saying that you can send MMS fine to iMessage and other Verizon customers, right?

If you are unable to send any MMS to any non-Verizon customer, your best bet is to contact Verizon directly.

Sounds like a carrier issue since the phone is sending properly.
__________________
The amount of material possessions one owns should not qualify them as a successful or just person.

The only worth these items have is the one you give them.
iceterminal is offline   0 Reply With Quote
Old Sep 27, 2012, 02:36 PM   #4
acousticbiker
Thread Starter
macrumors 6502
 
Join Date: Jun 2008
Quote:
Originally Posted by iceterminal View Post
So you're saying that you can send MMS fine to iMessage and other Verizon customers, right?

If you are unable to send any MMS to any non-Verizon customer, your best bet is to contact Verizon directly.

Sounds like a carrier issue since the phone is sending properly.
Pictures going out fine through iMessage (blue), but not through MMS (green). Verizon is working on it but thought I'd check here just in case. Not sure if it's related, but my Visual Voicemail doesn't work either.
acousticbiker is offline   0 Reply With Quote
Old Sep 27, 2012, 02:38 PM   #5
Frasern1
macrumors 6502a
 
Join Date: Oct 2011
Location: North Carolina
Huh both my MMS and my visual voicemail are working fine for me. Although last time I sent an MMS it failed the first time I tried.
Frasern1 is offline   0 Reply With Quote
Old Sep 27, 2012, 03:30 PM   #6
Big Ern
macrumors newbie
 
Join Date: Sep 2012
I had a similar issue with my iPhone 5. I could receive MMS messages fine but couldn't send. I had ported my number over from Sprint and restored my phone from a backup of a jailbroken unlocked iPhone I was using on T-mobile's service. I spent about an hour with verizon customer support and tried all of their ideas but nothing worked. I finally tried resetting network settings which did nothing. The solution for me ended up being erasing all data and settings on the phone under the Settings->General->Reset->Erase All Content and Settings and setting it up as a new phone. Then my MMS messages would go through instead of hanging at the end and saying "Not delivered."

This may also work with choosing reset all settings instead.

Last edited by Big Ern; Sep 27, 2012 at 06:54 PM.
Big Ern is offline   0 Reply With Quote
Old Sep 27, 2012, 04:17 PM   #7
acousticbiker
Thread Starter
macrumors 6502
 
Join Date: Jun 2008
Quote:
Originally Posted by Big Ern View Post
I had a similar issue with my iPhone 5. I could receive MMS messages fine but couldn't send. I had ported my number over from Sprint and restored my phone from a backup of a jailbroken unlocked iPhone I was using on T-mobile's service. I spent about an hour with verizon customer support and tried all of their ideas but nothing worked. I finally tried resetting network settings which did nothing. The solution for me ended up being erasing all data and settings on the phone under the Settings->General->Reset->Erase All Content and Settings and setting it up as a new phone. Then my MMS messages would go through instead of hanging at the end and saying "Not delivered."
Ugh...I was afraid that might be the solution (I restored from a non-Verizon iPhone). Thanks for taking the time to share
acousticbiker is offline   0 Reply With Quote
Old Sep 27, 2012, 05:29 PM   #8
Big Ern
macrumors newbie
 
Join Date: Sep 2012
Yea I wasn't thrilled about it either. I had to manually replace all the pictures on my camera roll which took a long time and redo all of my custom ringers. I also lost the notes in the notes app I had saved and my prior text message threads. I didn't want to do it but Verizon support basically wouldn't do anything else for me until I reset the whole phone. Some people with similar issues have said that it is a carrier issue that can be changed on their end. When I talked to them they couldn't even see that I was trying to send the messages so they weren't even making it off my phone.
Big Ern is offline   0 Reply With Quote
Old Sep 27, 2012, 05:50 PM   #9
acousticbiker
Thread Starter
macrumors 6502
 
Join Date: Jun 2008
Quote:
Originally Posted by Big Ern View Post
Yea I wasn't thrilled about it either. I had to manually replace all the pictures on my camera roll which took a long time and redo all of my custom ringers. I also lost the notes in the notes app I had saved and my prior text message threads. I didn't want to do it but Verizon support basically wouldn't do anything else for me until I reset the whole phone. Some people with similar issues have said that it is a carrier issue that can be changed on their end. When I talked to them they couldn't even see that I was trying to send the messages so they weren't even making it off my phone.
Just got off with VZW support and the suggested 'Erase all settings' (not content), which fixed the MMS problem but not visual VM. Had to redo all my settings but not as bad as reloading all content! Now if I can just get VVM to work!
acousticbiker is offline   0 Reply With Quote
Old Sep 28, 2012, 09:44 AM   #10
iceterminal
macrumors 68000
 
iceterminal's Avatar
 
Join Date: May 2008
Location: Dallas Tx.
Quote:
Originally Posted by acousticbiker View Post
Pictures going out fine through iMessage (blue), but not through MMS (green). Verizon is working on it but thought I'd check here just in case. Not sure if it's related, but my Visual Voicemail doesn't work either.
I know way back when, I had to have AT&T enable my visual voice mail separately. So it might be on Verizons end. But it seems that your'e able to send MMS over data, but not cellular. Which is again on Verizon.
Would be interested in the resolution.
__________________
The amount of material possessions one owns should not qualify them as a successful or just person.

The only worth these items have is the one you give them.
iceterminal is offline   0 Reply With Quote
Old Sep 29, 2012, 12:15 AM   #11
acousticbiker
Thread Starter
macrumors 6502
 
Join Date: Jun 2008
Hey all, forum user 'Arbagel' pointed out this solution to me:

http://www.fredmckinnon.com/myblog/2012/07/05/verizon-iphone-text-mms-and-visual-voicemail-mystery-solved/

This fixed my VVM problem and probably would have saved me from a 'Reset All Settings' operation to revive my MMS functionality
acousticbiker is offline   0 Reply With Quote
Old Sep 29, 2012, 12:46 AM   #12
Dennis3553
macrumors newbie
 
Join Date: Sep 2012
Same problem minus the vvm
Dennis3553 is offline   0 Reply With Quote
Old Sep 30, 2012, 06:04 AM   #13
mytran80
macrumors regular
 
Join Date: Mar 2009
Quote:
Originally Posted by Big Ern View Post
I had a similar issue with my iPhone 5. I could receive MMS messages fine but couldn't send. I had ported my number over from Sprint and restored my phone from a backup of a jailbroken unlocked iPhone I was using on T-mobile's service. I spent about an hour with verizon customer support and tried all of their ideas but nothing worked. I finally tried resetting network settings which did nothing. The solution for me ended up being erasing all data and settings on the phone under the Settings->General->Reset->Erase All Content and Settings and setting it up as a new phone. Then my MMS messages would go through instead of hanging at the end and saying "Not delivered."

This may also work with choosing reset all settings instead.
didn't work for iPhone 5 with at&t
mytran80 is offline   0 Reply With Quote
Old Sep 30, 2012, 12:14 PM   #14
Dennis3553
macrumors newbie
 
Join Date: Sep 2012
Quote:
Originally Posted by acousticbiker View Post
iMessages (text & pics) are working fine, but standard MMS to a non-iPhone user on a different carrier is not going through. I've tried toggling MMS on/off, using WiFi & LTE, power cycling, and resetting but with no success. Verizon tech support has escalated the issue, but I was curious whether anyone else was having this issue (and whether you know of a solution).
any luck with this? i have the same issue
Dennis3553 is offline   0 Reply With Quote
Old Sep 30, 2012, 01:00 PM   #15
DrakeMcEachern
macrumors 6502
 
Join Date: Mar 2012
Quote:
Originally Posted by acousticbiker View Post
iMessages (text & pics) are working fine, but standard MMS to a non-iPhone user on a different carrier is not going through. I've tried toggling MMS on/off, using WiFi & LTE, power cycling, and resetting but with no success. Verizon tech support has escalated the issue, but I was curious whether anyone else was having this issue (and whether you know of a solution).
You don't have the Onavo data saving app installed by chance, do you? I downloaded it and had the same problem. I deleted it and my mms started working again.
DrakeMcEachern is offline   0 Reply With Quote
Old Sep 30, 2012, 08:45 PM   #16
acousticbiker
Thread Starter
macrumors 6502
 
Join Date: Jun 2008
Quote:
Originally Posted by DrakeMcEachern View Post
You don't have the Onavo data saving app installed by chance, do you? I downloaded it and had the same problem. I deleted it and my mms started working again.
Thanks - yes, that is what I was referring to in my post (#11) above.

----------

Quote:
Originally Posted by Dennis3553 View Post
any luck with this? i have the same issue
Yes, please see post #9 & #11 for two different options
acousticbiker is offline   0 Reply With Quote
Old Oct 1, 2012, 07:00 AM   #17
Dennis3553
macrumors newbie
 
Join Date: Sep 2012
Quote:
Originally Posted by acousticbiker View Post
Thanks - yes, that is what I was referring to in my post (#11) above.

----------



Yes, please see post #9 & #11 for two different options
Verizon called me back i had to delete my msg threads and gointo my contacts delete any of them that did not have the area code in the number and re enter them, it didnt work unless the msg thread from that person was erased first.
Dennis3553 is offline   0 Reply With Quote
Old Nov 22, 2012, 06:35 AM   #18
Ldoonngg
macrumors newbie
 
Join Date: Nov 2012
Quote:
Originally Posted by acousticbiker View Post
Just got off with VZW support and the suggested 'Erase all settings' (not content), which fixed the MMS problem but not visual VM. Had to redo all my settings but not as bad as reloading all content! Now if I can just get VVM to work!
This Is what I had to do as well, since verizon customer services didnt help at all, but it worked. Trying to remember all my settings was the hard part.
Ldoonngg is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
iPhone: Force iPhone to send as MMS instead of SMS? shenan1982 iOS 7 26 Apr 28, 2014 09:11 AM
iPhone 4 - unable to send MMS messages - O2 UK myuserid08 iPhone Tips, Help and Troubleshooting 1 Jan 1, 2013 01:00 PM
Trying to send an MMS from iPhone 5 AT&T to T-Mobile Help mac.fanatic iPhone 1 Nov 5, 2012 02:34 PM
iPhone 5 won't send MMS LadyX iPhone 3 Oct 12, 2012 10:00 AM
iPhone 5 cant send mms (AT&T) roger1111 iPhone 0 Sep 30, 2012 07:09 PM

Forum Jump

All times are GMT -5. The time now is 09:46 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC