Go Back   MacRumors Forums > Special Interests > Mac and PC Games > Console Games

Thread Tools Search this Thread Display Modes
Old Jul 12, 2011, 07:00 PM   #151
macrumors 68030
AlBDamned's Avatar
Join Date: Mar 2005
It's definitely worth buying the proper Sony ones from a local store. My original PS3 controller wouldn't charge. I replaced the battery to be sure and it just drained and wouldn't charge. The store I bought the PS3 pack from replaced it, but not after I had confirmation from Sony that they had to replace it in store (first tried telling me I had to get Sony to replace it). Always buy decent controllers, not knock off ones. Like buying cheap work shoes it's a false economy.

Also, beware taking the controllers apart, there's lots of little springs and screws which can be a bugger to put back together.
AlBDamned is offline   0 Reply With Quote
Old Aug 22, 2011, 09:52 AM   #152
macrumors newbie
Join Date: Aug 2011
Yes I have no idea.

Hi. My son left one of his PS3 controllers here while visiting. I am trying to get it to work on my laptop via USB cable but the 4 lights just blink all the time, even after resetting. The Main PS3 console is not here. The laptop wont even let me calibrate the controller. I am trying to get it to work so I can use it in my older games like Lylat Wars, and some of the old Nintendo 64 games. Any ideas?

PS: I have downloaded these games so they work on PC but using the keyboard is an absloute nightmare.
Oh, and the Laptop recognises it, actually knows what its called. I've downloaded and used the ps3sixaxis_en exe file, still not working.

Last edited by Admiralchaos; Aug 22, 2011 at 10:04 AM.
Admiralchaos is offline   0 Reply With Quote
Old Nov 8, 2011, 06:14 PM   #153
macrumors newbie
Join Date: Nov 2011
ok...heres my problem. PS3 controller wont sync. wont turn on without usb cable plugged into the console. wont turn on with the usb cable plugged into the console. as soon as you connect it to the PS3, all 4 lights blink for about 5 seconds, then they stop blinking and go away. I have reset the controller plugged in, not plugged in...did a restore default settings on the console. NOTHING. I know the battery is good because I swapped the battery out of the other controller to prove this theory.

Heres a curve ball though. I plugged in the controller to my pc, and loaded up the drivers to that the pc would recognize it. The controller blinks like its charging so its all good. i unplug the controller and plug it into the PS3. The controller reads #2 (the other controller reads #1) and Im getting excited. however, I can't navigate through the menus unless I use the left joystick. No buttons work, the directional pad doesn't work....just the left joystick. As soon as I reset the PS3, the controller doesn't work again. WFT??? HELP!!!
mcclain71 is offline   0 Reply With Quote
Old Dec 21, 2011, 02:34 PM   #154
macrumors newbie
Join Date: Dec 2011
playstation 3 controller


My playstation 3 is not even a yr old yet. Yesterday and today my controller quit working. I'm not great at wording things so i'm going to try.

it wouldn't do anything unplugged so i plugged it in and the lights would blink but when i would press the PS button it wouldn't connect. When I unplugged it the lights went away but still wouldn't work. i turned it on and off unplugged everything and plugged it back in. I couldn't play games watch movies or anything so i left it plugged up with system on for awhile. i troubleshot the problem online and found out about the reset button on the back of the controller i pushed it several times plugged in not plugged in and nothing.

eventually it decided to work and worked fine for the rest of the day (i left it plugged in for in case it needed to charge) i turned the system off when i was done.

then today got up put a movie in and the controller wouldn't work again and i reset it and everything else. then finally worked again.

does anybody have any clue to whats going on with my ps3 controller. it is the controller that came with the system its the sixaxis
i only have 3 games i played and beat them once and didn't use it for months then started using it again and it worked fine up until yesterday. the whole system is practically new.

could you email me anything you know or think could help... oreo212@msn.com thank you

Last edited by CeCe212; Dec 21, 2011 at 02:35 PM. Reason: forgot something
CeCe212 is offline   0 Reply With Quote
Old Dec 23, 2011, 04:32 PM   #155
macrumors newbie
Join Date: Dec 2011
I've had my PS3 for almost exactly 2 years now and yesterday my controllers suddenly started having this problem. I've had the system in the same place for a while and I haven't added anything that could interfere with the connection. I have tried the reset button on both and have tried leaving the controllers charging for a while. Nothing seems to work and obviously after 2 years I don't like the idea of losing everything. So is there seriously no full- proof way to fix this?
InfernoEnforcer is offline   0 Reply With Quote
Old Jan 17, 2012, 05:48 PM   #156
macrumors member
Join Date: Jan 2008
The solution is so simple, just buy a new console with a controller, it cant be more simple than that. Its the same way i do with my cars, when they stop working i just buy a new one...
gr8pics is offline   0 Reply With Quote
Old Feb 15, 2012, 01:33 PM   #157
macrumors newbie
Join Date: Feb 2012
PS3 sixaxis on MBP 2008 via USB and BT

Hello, everyone!

I first bought PS3 controller some years ago, tried connecting to My mac with no luck, decided to wait for drivers. Now there have past 3 years, and I have been trying to connect my PS3 sixaxis to my mac now running Lion 10.7.3 for more than a week now. I have read all tutorials and how-tos and forum threads I could find on this subject. And have tried every single suggested method with no avail. (installing and unnstalling Tattiebogles driver, pluging, unpluging usb cable, holding ps button, entering 0000 etc.) - The situation is always the same - Mac recognizes gamepad for 10 seconds and then disconnects. One intersting thng - I tried using GamePad Companin to test input - and it does recognize gamepad when connected via USB, but not Bluetooth. However, despite it recognizes that gamepad is connected it does not receive input from buttons. Only exception is when it is at first connected via BlueTooth, and then plugged thru USB, then - for 10 seconds, while 4 red leds are rapidly blinking(for 10 secs, then it disconnects again) then and only then it is getting input from buttons.

I am so envious of every person, who had just to plug it it and it worked.
It's been like that from 2010, when ii first bought PS3 controller to use it with my 2008 MBP 17" then running Tiger, then Leopard, Snow, and now Lion. I had clean OS installs, so I guess it is somehow hardware related - Bluetooth module maybe, despite the fact that it works flawlessly with any other BT device whitch had zero problems connecting, except this damn PS3 controller.
I feel bitter and sad, as I am starting to think there is no solution.
And on top of it - it would be nice if it worked at least via USB, but no luck there also.

PS - the controller is fine - as I have used it with my Windows PS laptop with no problems, so the one to blame is Mac.

And it's a shame.

Apologies for my English, as I am not native speaker.
reinis is offline   0 Reply With Quote
Old Mar 16, 2012, 07:30 PM   #158
macrumors newbie
Join Date: Mar 2012
Fixed the problem for me

I turned off my system and my controller. if the controller keeps blinking just wait it will shuts off in about a minute or hit the reset button on the back with a needle or whatever,then plug it in with a usb cord. turn on the system. then turn on the controller. it will give you the single charge blink and i waited a few seconds and then unplugged it. it blinked normally like it does when you unplug it and then it was fine. just wait until the ps3 is on at the log in menu and then turn on the controller
101mercenary is offline   0 Reply With Quote
Old Mar 31, 2012, 05:52 PM   #159
macrumors newbie
Join Date: Mar 2012
This post may help some people who have a playstation 3 where the contoller won't register or link back to the playstation. I had the issue where there was just 4 blinking lights continuously on the controller, but It would never link successfully. There are a few things you can try:

1a. Make sure the controller has some battery charge - to do this: hard wire the controller via the usb cable (plug the usb end of the cable into the playstation usb slot and then the other end into the controller slot). You shouldn't have to charge it for more than 10 minutes for it to get some basic amount of charge. <Most controllers should work straight out of the box if they are hard wired via the usb cable - but I suggest charging up a little bit just in case). - then:

1b. with the usb cable still plugged in - press the PS button on the controller.
Now the 4 red lights on the controller should be blinking rapidly.

2. If all 4 red lights just keep blinking rapidly, and it does not swap to just 1 single solid red light (usually below the 1 label) then you may have my problem.


1. ((While the playstation is on and you have the main menu visible on your monitor/TV)) Plug in a mouse and keyboard into the usb slots of your playstation 3. If moving the mouse makes your menu scroll and/or if you can use your keyboard to interact with the menu (eg: esc key)- then the problem is probably NOT YOUR USB SLOTS.

2. If your USB slots are working fine - then try a different controller. Hard wire other controllers to your Playstation 3 and then try the standard connect process. If the other controllers connect correctly then it could be the incorrectly operating controller that that has the problem. BUT If all the other controllers still do not connect to your playstation then it MAY NOT BE A CONTROLLER PROBLEM - you can now try:

3. THIS IS WHAT FIXED MY ISSUE: Your wireless dualshock controller uses bluetooth to connect to the playstation 3... Other bluetooth enabled devices in the area of your playstation could be causing interference. Turn off all other bluetooth devices in the room, (or move your playstation set up to another "clean" room away from all other devices). I had mine in my office which had 2 wireless computers and another playstation turned on at the same time. (You may also want to turn off your bluetooth phone or headset devices as well).

3a. If you can isolate your playstation 3 from other devices then:
A. switch it off.
B. hardwire the problem controller to the playstation 3 using the usb cable.
C. Turn the playstation 3 back on.
D. {the 4 red lights should now be blinking rapidly}
E. Press the PS button on the controller
F. If it connects then you have fixed the problem
G. {if it still does not connect and the 4 lights just keep blinking and then go blank}. - THEN: turn off the playstation 3 and repeat the above process and then add the following steps:
{E: press the PS button}: G: uplug the usb cable.
H: press the PS button once more.

IF IT WAS A BLUETOOTH CONFLICT - then your problem controller should now connect and work correctly.

BACKGROUND: I have been having the problem of my controllers not linking to the PS unit, off and on, since I bought my second slim PS3 160 gig.I already had an older 20 gig (fat) playstation 3 that had x2 wireless dual shock controllers attached to (and operating correctly) in the house. I have my second slim PS3 160gig in my office next to 2 computers with: wireless internet and wireless mouse/keyboard/headphones/mic set up in the same room. My older 20gig PS never had any problems - but my newer slimline 160gig has been causing issues ever since I got it out of the box. Mostly surrounding the new dualshock controller not linking to correctly to the PS unit. But it would only happen sometimes??? I even tried sending the controller back to Sony (and I suspect) even got sent a new one. But still the controller would not link. I tried my other older controllers but they did not work either. Eventually I tried turning off my PC and Mac computers and unplugging them from the wall, moving my mobile phone to another room and turning it off and even turning off and unplugging the older PS3 in the other room. THIS DID THE TRICK. My problematic dualshock controller successfully connected to the PS3 unit and worked correctly.

you are trying lots of things to fix the dualshock controller not connecting properly and nothing seems to be working - before you tear your hair out and send the PS3 back to SONY or do a hard reboot - try turning off and uplugging all other devices surrounding your PS3 (especially wireless devices) and restart your PS3 and follow standard steps to link the controller - it might save you some headaches!
pstation3contro is offline   0 Reply With Quote
Old Apr 25, 2012, 12:57 PM   #160
macrumors newbie
Join Date: Apr 2012
controller problems

Originally Posted by ahmoda View Post
My console is PS3

I'm playing PES 2010 almost daily since had been released,

Ok so I'm having this really weird problem in PES 2010, the buttons work fine in the menu's (square, circle, triangle and x) etc but when it comes to playing then it is just not working, i.e I can't shoot or pass and the player just go around by arrows.(Just arrows buttons are working)

and also tried free training and I can't pass, shoot lob or anything so I'm stuck running around doing nothing else.

Any idea what's wrong?

The buttons working fine on other games (menus and inside game) but in PES only working in menu.

I Tried to reset from behind ( small hall) but it did not solve the problem.

Can you please help?

Thank you in advance

Hi Guys,

Does anybody know how to solve this problem?

Thank you
ShadowplayCouto is offline   0 Reply With Quote
Old May 4, 2012, 12:14 AM   #161
macrumors newbie
Join Date: May 2012
my controller wont connect to my cosole even if i use the usb cord, when i press the ps button four lights blink for 5secs and then turn off..........does any one have a solution for the problem?
manuera is offline   0 Reply With Quote
Old May 5, 2012, 06:58 AM   #162
macrumors newbie
Join Date: May 2012
4 blinking lights

hey people, had the same problem. try this,take apart your controller,take ot one screw that holds the circuit board to the case and behind that there is a ribbon that connects the board to the controlls clean that off and make sure there is s piece of black foam behind the controll side of the ribbon put back together and see what happens
epixinaz is offline   0 Reply With Quote
Old May 14, 2012, 06:38 PM   #163
macrumors newbie
Join Date: May 2012
Also about resetting the controller.

If you also haven't tried this:

1.turn on the ps3 and the little red light should turn on

2.hold the power button until u hear three beaps the system should turn off again and the little red light should appear again.

3. hold the power button until u hear three beaps that should take u to recovery mode

4.chose the setting that says restore playstation 3 file system...

then it will fix your ps3 file system and WHILE IT IS DOING SO; TRY TO SYNC YOUR CONTROLLER TO YOUR PS3 (also you should've already plugged it in with the supplied or any usb cable) the process of trying to make it sync wirelessly while fixing the file system SHOULD ALSO FIX YOUR PS3 CONTROLLER'S WIRELESS SETTINGS AS WELL. I Have just done this withing 10 minutes of this post and I can tell you FOR WHATEVER REASON; (it worked.)

"When you have eliminated the impossible, whatever remains, however improbable, must be the truth". - Sherlock Holmes
jasoncoker8878 is offline   0 Reply With Quote
Old Oct 18, 2012, 01:38 PM   #164
macrumors newbie
Join Date: Oct 2012
Hi guys! I have tried everything for this problem to stop and I have found the soultion all u need is a pin and the contoller... There's a tiny hole in the back of ur controller stick a pin in it and prestoe! Problem solved! Hope this work it did for me! X
nicolashaw is offline   0 Reply With Quote
Old Oct 26, 2012, 07:59 PM   #165
macrumors newbie
Join Date: Oct 2012
Taking it apart worked for me!

Originally Posted by epixinaz View Post
hey people, had the same problem. try this,take apart your controller,take ot one screw that holds the circuit board to the case and behind that there is a ribbon that connects the board to the controlls clean that off and make sure there is s piece of black foam behind the controll side of the ribbon put back together and see what happens
I had a controller with the 4 blinking lights (in fact I had another that was sent back under warranty with the same exact problem) and could do nothing with it. I tried everything that everyone on these posts suggested to do. I did what this post said, I took the controller apart and took out the screw and just brushed off and blew off the ribbon and contacts with a brush that came with a camera lens cleaner kit. Then I brushed and blew off the circuit board, put it back together and voila, it worked! Thanks so much for all your help!
tfire is offline   0 Reply With Quote
Old Oct 26, 2012, 09:33 PM   #166
macrumors 6502a
Join Date: Jul 2011
Location: Manchester
Have any of you guys tried playing GTA: Vice City using the official PS3 controller?
13" 2013 MacBook Pro with Retina Display (10.9 Mavericks & Windows 8)
iPhone 5S 32GB
PC (Windows 7)
32GB iPod Touch (3G)
Xcallibur is offline   0 Reply With Quote
Old Dec 13, 2012, 07:34 PM   #167
macrumors newbie
Join Date: Dec 2012
I have two controllers - one seemed to be going faulty. First of all, the only way it would connect was it if it was the controller used to turn the PS3 on. Then it stopped connecting altogether a month later. It would give me slow, flashing lights when plugged in via USB lead but wouldn't connect - pushing the reset button on the back did not help.

I thought it might be a battery problem so swapped batteries with my working controller. Hey presto, both controllers are now working fine. Therefore I don't think it was a dead battery but more likely due to taking apart and moving things around/dislodging dirt/fixing a loose connection - as mentioned a couple of times in the past few posts.

Hope this helps someone else.. I really didn't want to spend £30-40 on a new controller!
ickleden is offline   0 Reply With Quote
Old Dec 26, 2012, 08:00 AM   #168
macrumors newbie
Join Date: Dec 2012
problem with ps3 controle not connecting when it starts up

hi i have been having prblems with my ps3 controller not connecting when i turn on the console it says to press the ps button i do that and nothing happens have you got a solution for this
jackie19 is offline   0 Reply With Quote
Old Feb 10, 2013, 06:52 PM   #169
macrumors 68020
miamialley's Avatar
Join Date: Jul 2008
Location: California
Originally Posted by e≤Studios View Post
Thanks, at helped me. I didn't even know there was a reset button.
Bring back the down vote MR! +345, -0
miamialley is offline   0 Reply With Quote
Old Jul 21, 2013, 09:27 PM   #170
macrumors newbie
Join Date: Jul 2013
Originally Posted by kmckinn3 View Post
Just wanted to post this because I had the same problem controller problem and was able to fix it using someones advice on this post.

I've had a 40 gb PS3 for about 10 months and the problem just started today. Syncing the controllers and resetting them were not working so I kept reading.

The method that did work said to reassign your controller to 2 then 3,4,5,6,7 then 1 again. Turn off the PS3 using the xmb and then turn off the switch in the back. He then said to wait a couple hours but I waited a couple seconds. Flipped the switch then pressed the power button, right when it said Press the PS button I plugged it in, hit the PS button, then unplugged it.

Now it's working fine. Thanks.

Also, my 1 year warranty is almost up, think I should send it in or what's the best thing to do? I know they don't make the 40 gb anymore so I don't know what they'd do.

YOUR post is what finally solved things for me, for now, at least. Thanks for that, and to everyone else for their insight too.
pgmurphy is offline   0 Reply With Quote
Old Nov 4, 2014, 01:33 PM   #171
macrumors newbie
Join Date: Nov 2014
Same Type of Problem as well and another strange thing along with it

So I bought a PS3 Dualshock (Not the original one) from a store in Harrow, West London about a week ago and at first it was working fine for about 3-4 days, but after that it just won't sync without me plugging in my USB cable to the controller and mind you it will still have four lights but that won't blink even after I connected my USB cable to the controller so I have to get a pin and reset it via the botton at the back. After that it syncs but it still has to be connected to the PS3.

Any suggestions please would help tremendously.

Thank You
LoveCFC is offline   0 Reply With Quote
Old Nov 13, 2014, 06:37 PM   #172
macrumors newbie
Join Date: Nov 2014
I have the sixaxis remote. All lights were flashing after a reasonable charge. I tried changing the remote settings but nothing. So i literally reset the remote with an earing and it sorated itself straight away.
georgiejames is offline   0 Reply With Quote
Old May 14, 2015, 05:37 PM   #173
macrumors newbie
Join Date: May 2015
You are using a faulty cable!!

Fix>>>>>>faulty cable <<<<<<<fix
KIRK10000 is offline   0 Reply With Quote

MacRumors Forums > Special Interests > Mac and PC Games > Console Games

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
OS X: Problem with PS3 Controller crookedyouth Mac and PC Games 5 Feb 4, 2014 04:36 PM
OS X: PS3 Controller *Flashing Lights* bobbytomorow Mac and PC Games 5 Jan 17, 2014 07:52 AM
LTE signal are like blinking lights johndman iOS 7 0 Oct 23, 2013 12:18 AM
OS X: PS3 Controller Sync Problem Rando Mac and PC Games 1 Nov 13, 2012 08:39 AM
Problem PS3 controller Arn0 Mac Peripherals 0 Jul 31, 2012 03:09 PM

Forum Jump

All times are GMT -5. The time now is 03:32 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2015, MacRumors.com, LLC