Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Notebooks > MacBook Air

Reply
 
Thread Tools Search this Thread Display Modes
Old Dec 29, 2012, 07:52 PM   #1
Drew017
macrumors 65816
 
Drew017's Avatar
 
Join Date: May 2011
Location: East coast, USA
Send a message via Skype™ to Drew017
New MacBook Air slow to shut down...

I just got my MacBookAir (11 inch, early 2012) today and I'm very pleased with it, however it seems to take a while to shut down (like 20 seconds or so, instead of like 2-3) I know from using other MacBook airs that this doesn't seem quite normal. What could the issue be? I'm running OS X 10.8.2 (with the latest software updates) Thanks!!
__________________
Who'll put on my shoes while I'm walking slowly down the hall of fame?
MacBook Air 13 inch (Mid 2013); Intel Core i5; 4GB RAM; OS X 10.10 Yosemite
Focusrite Scarlett 2i2
Drew017 is offline   0 Reply With Quote
Old Dec 29, 2012, 08:16 PM   #2
Mrbobb
macrumors 601
 
Join Date: Aug 2012
External-attached devices incl USB, monitor and LAN shares will cause this delay. I suppose u can manually eject them before hand but that's the reason.
Mrbobb is offline   0 Reply With Quote
Old Dec 29, 2012, 08:19 PM   #3
Drew017
Thread Starter
macrumors 65816
 
Drew017's Avatar
 
Join Date: May 2011
Location: East coast, USA
Send a message via Skype™ to Drew017
Quote:
Originally Posted by Mrbobb View Post
External-attached devices incl USB, monitor and LAN shares will cause this delay. I suppose u can manually eject them before hand but that's the reason.
Thanks, but nope... nothing is attached. It does this even when I have no apps running in the background :/
__________________
Who'll put on my shoes while I'm walking slowly down the hall of fame?
MacBook Air 13 inch (Mid 2013); Intel Core i5; 4GB RAM; OS X 10.10 Yosemite
Focusrite Scarlett 2i2
Drew017 is offline   0 Reply With Quote
Old Dec 29, 2012, 08:28 PM   #4
Blaine
macrumors 6502a
 
Blaine's Avatar
 
Join Date: Dec 2007
Location: Abilene TX
I believe it's a known issue with 10.8.2

Maybe it'll be fixed with 10.8.3
Blaine is offline   0 Reply With Quote
Old Dec 29, 2012, 08:35 PM   #5
Drew017
Thread Starter
macrumors 65816
 
Drew017's Avatar
 
Join Date: May 2011
Location: East coast, USA
Send a message via Skype™ to Drew017
Quote:
Originally Posted by Blaine View Post
I believe it's a known issue with 10.8.2

Maybe it'll be fixed with 10.8.3
hopefully!
__________________
Who'll put on my shoes while I'm walking slowly down the hall of fame?
MacBook Air 13 inch (Mid 2013); Intel Core i5; 4GB RAM; OS X 10.10 Yosemite
Focusrite Scarlett 2i2
Drew017 is offline   0 Reply With Quote
Old Dec 29, 2012, 08:43 PM   #6
aristobrat
macrumors Demi-God
 
Join Date: Oct 2005
Location: Virginia Beach
Quote:
Originally Posted by Drew017 View Post
hopefully!
x2, as I'm having it also!
aristobrat is online now   0 Reply With Quote
Old Dec 29, 2012, 08:49 PM   #7
Drew017
Thread Starter
macrumors 65816
 
Drew017's Avatar
 
Join Date: May 2011
Location: East coast, USA
Send a message via Skype™ to Drew017
hmmmm if I repair permissions before I shut down it is normal, but when I restart it again it is back to the same old slow startup
__________________
Who'll put on my shoes while I'm walking slowly down the hall of fame?
MacBook Air 13 inch (Mid 2013); Intel Core i5; 4GB RAM; OS X 10.10 Yosemite
Focusrite Scarlett 2i2
Drew017 is offline   0 Reply With Quote
Old Dec 29, 2012, 08:56 PM   #8
washburn
macrumors 6502
 
Join Date: Apr 2010
Choose Apple menu > System Preferences, click Startup Disk, and select a disk

that you boot from
washburn is offline   0 Reply With Quote
Old Dec 29, 2012, 09:02 PM   #9
aristobrat
macrumors Demi-God
 
Join Date: Oct 2005
Location: Virginia Beach
Quote:
Originally Posted by Drew017 View Post
hmmmm if I repair permissions before I shut down it is normal, but when I restart it again it is back to the same old slow startup
From reading various posts over the last few weeks, it seems like a lot of people are having this problem, and I don't think anyone's found a reasonable (i.e. not dicking around in terminal) workaround.
aristobrat is online now   0 Reply With Quote
Old Dec 29, 2012, 09:51 PM   #10
Mrbobb
macrumors 601
 
Join Date: Aug 2012
What about if u DONT SHUT IT DOWN, but merely put it to sleep like lots of people do? U know, go with the flow?
Mrbobb is offline   0 Reply With Quote
Old Dec 29, 2012, 10:02 PM   #11
coldjeanzzz
macrumors 6502a
 
Join Date: Nov 2012
Quote:
Originally Posted by Mrbobb View Post
What about if u DONT SHUT IT DOWN, but merely put it to sleep like lots of people do? U know, go with the flow?
Because I like to shut my laptop down, I don't give a **** what other people do

OP I'm experiencing the same thing, I noticed it right away the first time I shut it down. Hopefully it gets fixed some how
coldjeanzzz is offline   2 Reply With Quote
Old Dec 29, 2012, 10:11 PM   #12
PBG4 Dude
macrumors 65816
 
Join Date: Jul 2007
I figured it out and it is easily repeatable. If you check that box to reopen everything when it restarts, it will take 10-20 seconds to shut down. If you uncheck the box, it'll only take a couple seconds because it doesn't have to save configuration.
PBG4 Dude is offline   0 Reply With Quote
Old Dec 29, 2012, 10:21 PM   #13
Mrbobb
macrumors 601
 
Join Date: Aug 2012
Quote:
Originally Posted by PBG4 Dude View Post
I figured it out and it is easily repeatable. If you check that box to reopen everything when it restarts, it will take 10-20 seconds to shut down. If you uncheck the box, it'll only take a couple seconds because it doesn't have to save configuration.

Makes perfect sense. Also set sleep mode to 0, as detailed on past's posts.

Lots of stressed out people on this forum! ^)
Mrbobb is offline   0 Reply With Quote
Old Dec 29, 2012, 10:30 PM   #14
Drew017
Thread Starter
macrumors 65816
 
Drew017's Avatar
 
Join Date: May 2011
Location: East coast, USA
Send a message via Skype™ to Drew017
Quote:
Originally Posted by PBG4 Dude View Post
I figured it out and it is easily repeatable. If you check that box to reopen everything when it restarts, it will take 10-20 seconds to shut down. If you uncheck the box, it'll only take a couple seconds because it doesn't have to save configuration.
its about the same for me here...idk
__________________
Who'll put on my shoes while I'm walking slowly down the hall of fame?
MacBook Air 13 inch (Mid 2013); Intel Core i5; 4GB RAM; OS X 10.10 Yosemite
Focusrite Scarlett 2i2
Drew017 is offline   0 Reply With Quote
Old Dec 30, 2012, 01:36 AM   #15
coldjeanzzz
macrumors 6502a
 
Join Date: Nov 2012
Quote:
Originally Posted by PBG4 Dude View Post
I figured it out and it is easily repeatable. If you check that box to reopen everything when it restarts, it will take 10-20 seconds to shut down. If you uncheck the box, it'll only take a couple seconds because it doesn't have to save configuration.
I read about this but people said it only worked the first time they shut down

I tried it and it has worked a few times now so hopefully it continues to work! My shutdowns are instant while before it was a good 15-20 seconds
coldjeanzzz is offline   0 Reply With Quote
Old Dec 30, 2012, 06:34 AM   #16
cedwhatev
macrumors 6502
 
Join Date: Oct 2011
Location: Canada
This has been an issue with A LOT of people for the last few months, it seems to be an issue with 10.8.2. Every resolution has been attempted (deleting certain programs, fresh installations, SMC reset and so on..) and nothing seems to work. Fingers are crossed for 10.8.3 to fix it!
__________________
MacBook Air 11" 2013 1.7GHz, 8GB, 256SSD
iPad Mini 16GB iPhone 5C 16GB
TV 3 iPod Nano 16GB 4th Gen
cedwhatev is offline   0 Reply With Quote
Old Dec 30, 2012, 07:06 AM   #17
mag01
macrumors member
 
Join Date: Apr 2011
All I can say about the possible fix in 10.8.3 is that the current 10.8.3 beta build 12D44 doesn't make any difference...
mag01 is offline   0 Reply With Quote
Old Dec 30, 2012, 08:39 AM   #18
PBG4 Dude
macrumors 65816
 
Join Date: Jul 2007
Quote:
Originally Posted by coldjeanzzz View Post
I read about this but people said it only worked the first time they shut down

I tried it and it has worked a few times now so hopefully it continues to work! My shutdowns are instant while before it was a good 15-20 seconds
I just tried this for the first time yesterday (was wondering if it would make a difference). Didn't know other people had reported on this but it makes sense other people would try too.
PBG4 Dude is offline   0 Reply With Quote
Old Dec 30, 2012, 12:19 PM   #19
coldjeanzzz
macrumors 6502a
 
Join Date: Nov 2012
Quote:
Originally Posted by PBG4 Dude View Post
I just tried this for the first time yesterday (was wondering if it would make a difference). Didn't know other people had reported on this but it makes sense other people would try too.
Unfortunately I spoke too soon, shut down last night after a few hours of use and it went back to taking 12-15 seconds.

As others have said I don't think any "quick fix" will do the job here. Stupid Apple will just have to correct this on their own.
coldjeanzzz is offline   0 Reply With Quote
Old Dec 30, 2012, 01:36 PM   #20
Jamesbot
macrumors member
 
Join Date: Jun 2009
Maybe check the logs on your mac and see what the os is spending its time on during shutdown. Here's a link that'll help you find the logs:

http://apple.stackexchange.com/quest...utdown-process

There's a good tip in there for shutting down in verbose mode, which might also be helpful in troubleshooting the problem.
Jamesbot is offline   0 Reply With Quote
Old Dec 30, 2012, 03:15 PM   #21
Drew017
Thread Starter
macrumors 65816
 
Drew017's Avatar
 
Join Date: May 2011
Location: East coast, USA
Send a message via Skype™ to Drew017
here's the permissions that keep having to be repaired after every restart... I'm not sure how to keep them permanently fixed... any ideas? It shuts down normally if I repair these permissions, but i have to do it again before I shut it down again or I get the same old 15- 20 sec. delay
Attached Thumbnails
Click image for larger version

Name:	Screen Shot 2012-12-30 at 4.12.52 PM.png
Views:	54
Size:	198.9 KB
ID:	386799   Click image for larger version

Name:	Screen Shot 2012-12-30 at 4.13.04 PM.png
Views:	26
Size:	200.3 KB
ID:	386800  
__________________
Who'll put on my shoes while I'm walking slowly down the hall of fame?
MacBook Air 13 inch (Mid 2013); Intel Core i5; 4GB RAM; OS X 10.10 Yosemite
Focusrite Scarlett 2i2
Drew017 is offline   0 Reply With Quote
Old Dec 30, 2012, 04:09 PM   #22
Drew017
Thread Starter
macrumors 65816
 
Drew017's Avatar
 
Join Date: May 2011
Location: East coast, USA
Send a message via Skype™ to Drew017
submitted a bug report to apple through the feedback part of their letter... maybe I'll get a response
__________________
Who'll put on my shoes while I'm walking slowly down the hall of fame?
MacBook Air 13 inch (Mid 2013); Intel Core i5; 4GB RAM; OS X 10.10 Yosemite
Focusrite Scarlett 2i2
Drew017 is offline   0 Reply With Quote
Old Dec 30, 2012, 05:22 PM   #23
Mactabulous
macrumors member
 
Join Date: Dec 2011
I'm also getting this on my 2012 MBA 13". I submitted a bug report to Apple.
__________________
Oh duck!
Mactabulous is offline   0 Reply With Quote
Old Dec 31, 2012, 12:50 AM   #24
krravi
macrumors 65816
 
Join Date: Nov 2010
Quote:
Originally Posted by Drew017 View Post
I just got my MacBookAir (11 inch, early 2012) today and I'm very pleased with it, however it seems to take a while to shut down (like 20 seconds or so, instead of like 2-3) I know from using other MacBook airs that this doesn't seem quite normal. What could the issue be? I'm running OS X 10.8.2 (with the latest software updates) Thanks!!
Just curious, if you have configured the Mail app and it has lot of accounts?

Next time quit the mail app completely and then do a shutdown and see if its faster.
__________________
Lots of Apple,Sony and other gadgets.
krravi is offline   0 Reply With Quote
Old Dec 31, 2012, 12:22 PM   #25
Drew017
Thread Starter
macrumors 65816
 
Drew017's Avatar
 
Join Date: May 2011
Location: East coast, USA
Send a message via Skype™ to Drew017
Quote:
Originally Posted by krravi View Post
Just curious, if you have configured the Mail app and it has lot of accounts?

Next time quit the mail app completely and then do a shutdown and see if its faster.
I only have my icloud email in it... and yeah I've tried it, but it still doesn't work :/
__________________
Who'll put on my shoes while I'm walking slowly down the hall of fame?
MacBook Air 13 inch (Mid 2013); Intel Core i5; 4GB RAM; OS X 10.10 Yosemite
Focusrite Scarlett 2i2
Drew017 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Notebooks > MacBook Air

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
New Macbook Air takes ages to shut down. travod MacBook Air 28 Oct 10, 2013 04:23 PM
Shut Down of MacBook Air Takes Long Time ksharin MacBook Air 8 Sep 17, 2013 01:13 PM
Macbook Pro slow after shut down and reboot 2TallGreg MacBook Pro 2 May 6, 2013 09:42 AM
Macbook air 13" shut down Serban MacBook Air 4 Mar 9, 2013 06:09 PM
How often should i shut down my Macbook Air? saleemyas3 MacBook Air 22 Jun 19, 2012 10:29 PM

Forum Jump

All times are GMT -5. The time now is 03:49 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC