Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone

Reply
 
Thread Tools Search this Thread Display Modes
Old Oct 20, 2011, 01:03 PM   #1
spartanrob
macrumors 6502
 
Join Date: Aug 2008
iCloud as default email? Why?

I have my gmail account set as default, but often times when I access Mail, it defaults to iCloud. I have 2 gmail and one exchange account. Why does it keep defaulting to iCloud
spartanrob is offline   0 Reply With Quote
Old Oct 20, 2011, 01:16 PM   #2
CmdrThor
macrumors member
 
Join Date: Jun 2011
Settings -> Mail, Contacts, Calendars -> Default Account
CmdrThor is offline   0 Reply With Quote
Old Oct 20, 2011, 04:41 PM   #3
spartanrob
Thread Starter
macrumors 6502
 
Join Date: Aug 2008
Quote:
Originally Posted by CmdrThor View Post
Settings -> Mail, Contacts, Calendars -> Default Account
Yep, already done "I have my gmail account set as default"
spartanrob is offline   0 Reply With Quote
Old Oct 20, 2011, 04:56 PM   #4
TheNinjaJedi
macrumors regular
 
Join Date: Jul 2011
so you're saynig it switches it back to iCloud?
TheNinjaJedi is offline   0 Reply With Quote
Old Oct 20, 2011, 05:01 PM   #5
verwon
macrumors 68030
 
verwon's Avatar
 
Join Date: Jul 2011
Location: Seattle
It's not really defaulting to it, but if you're sending from mail, it will send from whatever box you're currently in, unless you change it.
verwon is offline   0 Reply With Quote
Old Oct 20, 2011, 05:03 PM   #6
verwon
macrumors 68030
 
verwon's Avatar
 
Join Date: Jul 2011
Location: Seattle
IE: If I open mail to send something and the last box I was in was my iCloud, that's what it will send from, unless I change it.

It only reads the one you have set as a default, when you are sending from some other application, like photos, or Safari.
verwon is offline   0 Reply With Quote
Old Oct 20, 2011, 05:42 PM   #7
spartanrob
Thread Starter
macrumors 6502
 
Join Date: Aug 2008
gmail is always set as default.
I never use iCloud email.

Many times when I access email, it goes directly to iCloud. Makes no sense.
spartanrob is offline   0 Reply With Quote
Old Oct 20, 2011, 07:11 PM   #8
spartanrob
Thread Starter
macrumors 6502
 
Join Date: Aug 2008
Just power-cycled the phone.
Clicked on eMail and it went right to iCloud
spartanrob is offline   0 Reply With Quote
Old Oct 31, 2011, 06:08 AM   #9
spartanrob
Thread Starter
macrumors 6502
 
Join Date: Aug 2008
Still having this issue. Anyone else?
spartanrob is offline   0 Reply With Quote
Old Oct 31, 2011, 06:21 AM   #10
jayenh
macrumors 6502
 
Join Date: Nov 2008
Quote:
Originally Posted by spartanrob View Post
Still having this issue. Anyone else?
yes.

if i compose an email from the top level of the email app (ie looking at all my mail boxes) it will default as being sent from my @me address. if i force quit or power off and on my phone and access mail it will go straight in to my icloud inbox, so i have to go back and then in to my gmail. i have 3 email accounts on my phone; icloud, gmail and a work exchange account. gmail is set as my default. i sometimes forget about this so occasionally send emails out from my @me address when i don't want to. it's a little bit of an annoyance because i never used to have a me account so never had this problem, it always used my gmail account as you'd expect since it is my default.

i'll probably try restoring again at some point.
jayenh is offline   0 Reply With Quote
Old Oct 31, 2011, 06:57 AM   #11
Menel
macrumors 601
 
Menel's Avatar
 
Join Date: Aug 2011
Location: Atlanta
turn off icloud email
goto icloud.com and set to forward to gmail and delete

have one email account in phone, nice and simple...
__________________
iPhone 5 iPad Air Mac mini i5
Menel is offline   0 Reply With Quote
Old Oct 31, 2011, 07:32 AM   #12
Cynikal.Mindset
macrumors 6502a
 
Join Date: Jul 2010
Location: Guelph ON, Canada
I have 5 email accounts on my phone and gmail is default and it always uses gmail unless I am in a specific mailbox and compose an email there or replying to an email from whatever account.
Cynikal.Mindset is offline   0 Reply With Quote
Old Oct 31, 2011, 07:39 AM   #13
r2shyyou
macrumors 68000
 
r2shyyou's Avatar
 
Join Date: Oct 2010
Location: Paris, France
Quote:
Originally Posted by spartanrob View Post
I have my gmail account set as default, but often times when I access Mail, it defaults to iCloud. I have 2 gmail and one exchange account. Why does it keep defaulting to iCloud
I've found that when you open the Mail.app after either restarting the phone or fully closing out the app (via the multitasking toolbar), the app will open right to the inbox of the top-most email account in Settings>Mail, Contacts, Calendars. I have my Gmail (set up as Exchange) as my default as well but my iCloud account is at the top of the accounts list in Settings>Mail, Contacts, Calendars so the Mail.app often opens up to the iCloud inbox regardless.
__________________
"kkkkkkkk ....ok" - iphone4s16gb
r2shyyou is offline   0 Reply With Quote
Old Oct 31, 2011, 08:02 AM   #14
ZBoater
macrumors 603
 
ZBoater's Avatar
 
Join Date: Jul 2007
Location: Sunny Florida
This is Apple's not so subtle way of telling you to ditch Gmail and go iCloud....

This happens to me too. Must be a bug. Or a feature.
__________________
iPhone 6 Plus | iPad Air | MacBook Air | Thunderbolt Display | Apple TV | Time Capsule
ZBoater is offline   1 Reply With Quote
Old Oct 31, 2011, 10:58 AM   #15
DeusInvictus7
macrumors 68020
 
Join Date: Aug 2008
Location: Kitchener, Ontario
I just tried changing my Default Email and it actually changed it...I'm actually using my iCloud email more now compared to my Gmail, but I can change my default in the settings...

Try changing it to something else and then going back?

Also, when I force quit and go back like some others have said, it opens up to my "All Inboxes" inbox, not the iCloud one. Seems like mine is working properly lol
__________________
iPhone 6 Plus - Hackintosh - Apple TV
DeusInvictus7 is offline   0 Reply With Quote
Old Jan 28, 2013, 07:25 PM   #16
jzamudio
macrumors newbie
 
Join Date: Jan 2013
icloud defaulting as first email a problem? Here's the solution!

Quote:
Originally Posted by spartanrob View Post
I have my gmail account set as default, but often times when I access Mail, it defaults to iCloud. I have 2 gmail and one exchange account. Why does it keep defaulting to iCloud
In ios 6, open the mail app. Go back to mailboxes view. Press edit in the top right. Now rearrange your accounts putting the one you want to be open on app open at the top and vola!
hope that helps!
jzamudio is offline   3 Reply With Quote
Old Jan 28, 2013, 09:39 PM   #17
adam044
macrumors 65816
 
adam044's Avatar
 
Join Date: Jan 2012
Location: Boston
Just turn off th icloud email thats what I did
__________________
13" Late 2011 MacBook Pro, 2.4 GHz > iPhone 5s 32GB Space Grey AT&T > iPad 4 > Apple TV 3
adam044 is offline   0 Reply With Quote
Old Jan 29, 2013, 08:37 AM   #18
Bobby.e
macrumors 6502
 
Join Date: Mar 2012
Location: Kansas
Quote:
Originally Posted by jzamudio View Post
In ios 6, open the mail app. Go back to mailboxes view. Press edit in the top right. Now rearrange your accounts putting the one you want to be open on app open at the top and vola!
hope that helps!
This person is correct.
Bobby.e is offline   1 Reply With Quote
Old Jan 29, 2013, 09:02 AM   #19
MacLovin78
macrumors regular
 
Join Date: Apr 2008
This has plagued me since my first iPhone. As best I can tell, no matter what you set as the "default" email for sending emails from your iPhone, iOS always loads the mail account that was added first when setting up the phone. Because alot of us have iCloud mailboxes when you set up your phone and sign into iCloud with your apple ID it automatically adds the iCloud email account. Then you add gmail and set to default but if you restart your phone or force quit the mail app it will always show the iCloud account when you go back into the mail app. It is really annoying to me, especially when you utilize the "All Accounts" feature in the mail app.

To get around it I believe you can delete all your mail accounts and re-add them starting with your primary gmail account first and you should have that default from now on.

It is probably at the very very very bottom of the list of fixes apple has to make.
MacLovin78 is offline   0 Reply With Quote
Old Jun 13, 2013, 12:11 AM   #20
HarleyLaurie
macrumors newbie
 
Join Date: Jun 2013
Same problem - open Mail and iCloud opens the app.
I fixed it by editing the order if my four emails so that my private Outlook mailbox appears on top of my business ones
Next step was to make the default mailbox the same.
Now I open Mail and my private client automatically opens.
HarleyLaurie is offline   0 Reply With Quote
Old Jul 30, 2013, 04:59 PM   #21
nosarrra
macrumors newbie
 
Join Date: Jan 2011
Quote:
Originally Posted by Bobby.e View Post
This person is correct.
I don't think this is correct. Just tried it, power cycled, hit compose email, and iCloud was the default email. I had no idea I was sending email from iCloud until I sent one to myself, then realized I've been sending email from that address for months. So frustrating.

----------

Quote:
Originally Posted by Bobby.e View Post
This person is correct.
Quote:
Originally Posted by nosarrra View Post
I don't think this is correct. Just tried it, power cycled, hit compose email, and iCloud was the default email. I had no idea I was sending email from iCloud until I sent one to myself, then realized I've been sending email from that address for months. So frustrating.
Ok, I figured out how to stop it for my issue:
Settings/Mail/iCloud Make sure Mail is set to "Off" Somehow it got turned to "On" (not by me!!)
nosarrra is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Anybody use email OTHER THAN iCloud but use iCloud for contacts? DramaLLama iCloud and Apple Services 7 Mar 14, 2014 04:31 PM
Apple iCloud Email sends/receives email in Plain Text Compile 'em all Apple, Industry and Internet Discussion 1 Feb 14, 2014 08:32 AM
Simultaneously use iCloud email & me.com email on iOS Let's Sekuhara! iOS 6 2 Jul 28, 2013 01:21 AM
Default saving not into iCloud DoctorCrap OS X 10.8 Mountain Lion 2 Oct 11, 2012 03:24 PM
Does setting up an iCloud email (@me/@icloud.com) replace your Apple ID's email? benguild iCloud and Apple Services 5 Jul 19, 2012 03:28 PM

Forum Jump

All times are GMT -5. The time now is 09:03 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC