Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Mac Community > Site and Forum Feedback

Reply
 
Thread Tools Search this Thread Display Modes
Old Mar 2, 2013, 08:25 AM   #1
SandboxGeneral
Moderator
 
SandboxGeneral's Avatar
 
Join Date: Sep 2010
Location: Great Lakes State
JavaScript Slow Loading

I've been noticing pages taking a while to completely load (up to 2 minutes) on the iPad. I hooked it up to the iMac and enabled the developer menu so I could watch what's loading on it and found that the script macrumors.com-async.js seems to be the culprit.

I was also able to replicate this on Safari for OS X as well, but it's less noticeable on the desktop than the iPad.





Thumb resize.
__________________
Magnificent Seventh
SandboxGeneral is online now   0 Reply With Quote
Old Mar 2, 2013, 08:29 AM   #2
Intell
macrumors G5
 
Intell's Avatar
 
Join Date: Jan 2010
Location: Inside
Which CDN node are you hitting? http://debug.netdna-cdn.com/
__________________
Last edited by Intell; Yesterday at 10:24 AM.
Intell is offline   0 Reply With Quote
Old Mar 2, 2013, 08:30 AM   #3
SandboxGeneral
Thread Starter
Moderator
 
SandboxGeneral's Avatar
 
Join Date: Sep 2010
Location: Great Lakes State
Quote:
Originally Posted by Intell View Post
Which CDN node are you hitting? http://debug.netdna-cdn.com/
The one in Chicago.

__________________
Magnificent Seventh
SandboxGeneral is online now   0 Reply With Quote
Old Mar 2, 2013, 08:31 AM   #4
Intell
macrumors G5
 
Intell's Avatar
 
Join Date: Jan 2010
Location: Inside
I've been having similar problems, but only on FireFox and Chrome. I'm hitting the New York datacentre.
__________________
Last edited by Intell; Yesterday at 10:24 AM.
Intell is offline   0 Reply With Quote
Old Mar 6, 2013, 11:23 AM   #5
Michaelgtrusa
macrumors 68040
 
Michaelgtrusa's Avatar
 
Join Date: Oct 2008
Location: Everywhere And Nowhere
I've seen this on opera also.
__________________
iMACAll life is an experiment. The more experiments you make the better.
TWITTER TUMBLR
Michaelgtrusa is online now   0 Reply With Quote
Old Mar 9, 2013, 08:28 AM   #6
SandboxGeneral
Thread Starter
Moderator
 
SandboxGeneral's Avatar
 
Join Date: Sep 2010
Location: Great Lakes State
Arn, following up on our IM from last week, later that day I visited some friends who live over an hour's drive from me and I brought the iPad with me (which is the device I was having this issue). I got on their Wi-Fi and had no troubles. Additionally, on AT&T 4G (at home) and AT&T LTE (near my friends place), again had no troubles.

I assumed after that, that it had to be my local network or my home ISP. I haven't done anything to my network in a very long time, or since last week.

As of yesterday, on my home Wi-Fi it's now working as it should. So whatever it was, seems to have fixed itself. Who knows?
__________________
Magnificent Seventh
SandboxGeneral is online now   0 Reply With Quote
Old Mar 9, 2013, 01:17 PM   #7
arn
macrumors god
 
arn's Avatar
 
Join Date: Apr 2001
Send a message via AIM to arn
Quote:
Originally Posted by SandboxGeneral View Post
Arn, following up on our IM from last week, later that day I visited some friends who live over an hour's drive from me and I brought the iPad with me (which is the device I was having this issue). I got on their Wi-Fi and had no troubles. Additionally, on AT&T 4G (at home) and AT&T LTE (near my friends place), again had no troubles.

I assumed after that, that it had to be my local network or my home ISP. I haven't done anything to my network in a very long time, or since last week.

As of yesterday, on my home Wi-Fi it's now working as it should. So whatever it was, seems to have fixed itself. Who knows?
thanks for the update. ya, seemed like a local dns issue. which are hard to diagnose

arn
arn is offline   0 Reply With Quote


Reply
MacRumors Forums > Mac Community > Site and Forum Feedback

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:20 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC