Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > OS X > Mac OS X 10.7 Lion

Reply
 
Thread Tools Search this Thread Display Modes
Old Feb 26, 2011, 03:57 PM   #1
kirky29
macrumors 65816
 
kirky29's Avatar
 
Join Date: Jun 2009
Location: Lincolnshire, England
Send a message via Yahoo to kirky29 Send a message via Skype™ to kirky29
Quicktime - AVI

Hey all,

If someone could point me in the right direction, Quicktime X isn't playing AVI's. I've installed several codecs.

Now I can't remember if I had this problem when I first installed Snow Leopard...(it's been that long!)

I'm posting this here because I don't remember it been such a pain before, so it could be a Lion bug? - but really might not be!

-- I'm tired and this is getting me cranky ;-) haha!

Thank you!
Attached Thumbnails
Click image for larger version

Name:	Screen Shot 2011-02-26 at 21.52.38.jpg
Views:	85
Size:	32.8 KB
ID:	273092  
__________________
27" iMac, 15" MacBook Pro 2.2GHz i7 2011, iPhone 5 16GB - iPad 1/2/3/Mini - 24" Cinema Display,
Apple Magic Mouse, Trackpad, Time Machine, Apple TV,
| Check out my flickr |
kirky29 is online now   0 Reply With Quote
Old Feb 26, 2011, 03:59 PM   #2
simsaladimbamba
Guest
 
Join Date: Nov 2010
Location: located
What codecs did you install? Did you try Perian yet?
simsaladimbamba is offline   0 Reply With Quote
Old Feb 26, 2011, 04:01 PM   #3
kirky29
Thread Starter
macrumors 65816
 
kirky29's Avatar
 
Join Date: Jun 2009
Location: Lincolnshire, England
Send a message via Yahoo to kirky29 Send a message via Skype™ to kirky29
Yep, installed Perian & DivX. Heck even Flip4Mac...

Like I said, I don't remember having issues when I first installed SL all that time ago... :-/
__________________
27" iMac, 15" MacBook Pro 2.2GHz i7 2011, iPhone 5 16GB - iPad 1/2/3/Mini - 24" Cinema Display,
Apple Magic Mouse, Trackpad, Time Machine, Apple TV,
| Check out my flickr |
kirky29 is online now   0 Reply With Quote
Old Feb 26, 2011, 04:04 PM   #4
simsaladimbamba
Guest
 
Join Date: Nov 2010
Location: located
Seems the codecs you installed are not yet compatible with Lion yet. Maybe they will some day, when Lion gets officially released.
Maybe you could contact the Divx, Perian and Flip4Mac developers, if they haven't already tried it themselves.
simsaladimbamba is offline   0 Reply With Quote
Old Feb 26, 2011, 04:04 PM   #5
kainjow
Moderator emeritus
 
kainjow's Avatar
 
Join Date: Jun 2000
Did you try VLC?
kainjow is offline   0 Reply With Quote
Old Feb 26, 2011, 04:08 PM   #6
kirky29
Thread Starter
macrumors 65816
 
kirky29's Avatar
 
Join Date: Jun 2009
Location: Lincolnshire, England
Send a message via Yahoo to kirky29 Send a message via Skype™ to kirky29
Quote:
Originally Posted by kainjow View Post
Did you try VLC?
Yeah, VLC works fine, did without any having to install anything else.
Even Quicktime 7 on my Snow Leopard partition loads them fine..
Even funnier.. Quick Look loads them fine!
__________________
27" iMac, 15" MacBook Pro 2.2GHz i7 2011, iPhone 5 16GB - iPad 1/2/3/Mini - 24" Cinema Display,
Apple Magic Mouse, Trackpad, Time Machine, Apple TV,
| Check out my flickr |
kirky29 is online now   0 Reply With Quote
Old Feb 26, 2011, 04:13 PM   #7
kirky29
Thread Starter
macrumors 65816
 
kirky29's Avatar
 
Join Date: Jun 2009
Location: Lincolnshire, England
Send a message via Yahoo to kirky29 Send a message via Skype™ to kirky29
I'm thinking it's gotta be a bug.. Everything else that I've thrown at Quicktime loads fine.. Just not the avi files...

Certainly when Quick Look from the finder is loading them fine!
__________________
27" iMac, 15" MacBook Pro 2.2GHz i7 2011, iPhone 5 16GB - iPad 1/2/3/Mini - 24" Cinema Display,
Apple Magic Mouse, Trackpad, Time Machine, Apple TV,
| Check out my flickr |
kirky29 is online now   0 Reply With Quote
Old Feb 26, 2011, 04:13 PM   #8
Tazjin
macrumors newbie
 
Join Date: Aug 2010
For me Perian does not work with Lion yet.
Tazjin is offline   0 Reply With Quote
Old Feb 26, 2011, 04:19 PM   #9
kuwisdelu
macrumors 65816
 
Join Date: Jan 2008
QTX doesn't support plug-ins yet. I was hoping it would on Lion there's still time, though.

On Snow Leopard, lots of stuff that QTX couldn't play used a separate QT7 process to play things in the QTX player window, which included most things that Perian did.

It looks like there's just no QT7 in Lion. Here's to hoping QTX will be mature enough by release it won't be necessary...
__________________
2.0 GHz quad-core i7 15" MacBook Pro 2011
iPad 2 (Black) WiFi+3G 64GB
iPhone 4S (White) 64 GB
kuwisdelu is offline   0 Reply With Quote
Old Feb 26, 2011, 07:36 PM   #10
3goldens
macrumors 68000
 
3goldens's Avatar
 
Join Date: Feb 2008
The DivX codec is working for me with quicktime.
it did not at first but then I installed Perian and then it started to work!
3goldens is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > Mac OS X 10.7 Lion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
.AVI movies wont play on Quicktime fitworldmac Digital Video 4 Dec 18, 2013 07:45 AM
Quicktime not open .AVI Files ? Humex OS X Mavericks (10.9) 31 Oct 23, 2013 12:11 AM
no sound playing avi file on quicktime X kazeth MacBook Air 13 Apr 22, 2013 08:41 AM
Need help with QuickTime Codecs (Casio .avi file playing only audio via iPhoto) purpleinnej Mac Applications and Mac App Store 4 Aug 14, 2012 07:38 AM
Casio Digital Camera video .avi file audio only in QuickTime purpleinnej Mac Applications and Mac App Store 9 Aug 11, 2012 07:18 AM

Forum Jump

All times are GMT -5. The time now is 04:36 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC