Go Back   MacRumors Forums > Apple Systems and Services > OS X > Mac OS X 10.7 Lion

Reply
 
Thread Tools Search this Thread Display Modes
Old Jul 7, 2011, 06:32 AM   #1
Sean-B-89
macrumors newbie
 
Join Date: Jul 2011
No sound through HDMI

Hi all,
I am using Mac OS X 10.7 Lion GM and everything is working like a charm, but I have found one bug that I got a problem with.

If I connect my TV through the mini displayport, it does not pass through the sound like Snow Leopard does.

If I go to the System Preference -> Sound I do not see the HDMI output anymore. What can I do about this? Does anyone else have trouble with this?

I have upgraded straightly from 10.6.8 and am using the MacBook Pro 13inch 2011.

Check the screenshot. Thanks!
Attached Thumbnails
Click image for larger version

Name:	Schermafbeelding 2011-07-07 om 13.32.02.png
Views:	239
Size:	76.4 KB
ID:	292746  
Sean-B-89 is offline   0 Reply With Quote
Old Jul 7, 2011, 06:48 AM   #2
Hansr
macrumors 6502a
 
Join Date: Apr 2007
Mini displayport doesn't have an audio channel simple.

Use the 3,5" audio out with a jack or tos link.
Hansr is offline   -5 Reply With Quote
Old Jul 7, 2011, 06:51 AM   #3
robbieduncan
Moderator
 
robbieduncan's Avatar
 
Join Date: Jul 2002
Location: London
Quote:
Originally Posted by Hansr View Post
Mini displayport doesn't have an audio channel simple.

Use the 3,5" audio out with a jack or tos link.
Recent Macs can output HDMI with audio via an appropriate MDP->HDMI adapter.
robbieduncan is offline   0 Reply With Quote
Old Jul 7, 2011, 07:03 AM   #4
sudoash
macrumors member
 
Join Date: Jun 2011
Quote:
Originally Posted by Hansr View Post
Mini displayport doesn't have an audio channel simple.

Use the 3,5" audio out with a jack or tos link.
Quote:
Originally Posted by Wikipedia
On 13 April 2010, Apple added support for audio out using Mini DisplayPort in their MacBook Pro product line. This added feature allows users to easily connect their Macbook Pros to their HDTVs using a cable adapting Mini DisplayPort to HDMI with full audio and video functionality.
Source: Wikipedia

As for the problem, I will try this when I get home and post back.
__________________
MacBook Pro with Retina - 2.3GHz, 16GB RAM, 256GB SSD
iPhone 5 - 32GB
sudoash is offline   0 Reply With Quote
Old Jul 7, 2011, 07:55 AM   #5
Hansr
macrumors 6502a
 
Join Date: Apr 2007
Ah okay, seems like there isn't a cable from Apple for it though, but they point to third party ones: http://support.apple.com/kb/HT4241

I've been using MDP -> DVI -> HDMI. Didn't know about this change.
Hansr is offline   0 Reply With Quote
Old Jul 7, 2011, 08:33 AM   #6
Sean-B-89
Thread Starter
macrumors newbie
 
Join Date: Jul 2011
Yeah, well I am using an Minidisplay port-to-HDMI adaptor and, like I said earlier, with Mac OS 10.6 Snow Leopard it did work, but with Mac OS Lion is is not working anymore. I don't understand why it isn't working anymore

It's like the Thunderbolt driver has changed and doesn't support the audio anymore..
Sean-B-89 is offline   1 Reply With Quote
Old Jul 7, 2011, 09:09 AM   #7
Hansr
macrumors 6502a
 
Join Date: Apr 2007
Have you tried contacting the manufacturer? It might well be a hw/sw incompatibility given the OS update that hasn't been addressed by Apple yet so go for feedback with Apple if the manufacturer isn't able to help.
Hansr is offline   0 Reply With Quote
Old Jul 7, 2011, 05:00 PM   #8
runebinder
macrumors 6502a
 
runebinder's Avatar
 
Join Date: Apr 2009
Location: Nottingham, UK
Quote:
Originally Posted by Hansr View Post
Have you tried contacting the manufacturer? It might well be a hw/sw incompatibility given the OS update that hasn't been addressed by Apple yet so go for feedback with Apple if the manufacturer isn't able to help.
Shouldn't be an issue, audio was added when they updated MDP to Vesa 1.2 standard, and as long as the adapter follows that (which in the OP's case it does as they could get audio in SL), then incompatibility isn't going to happen.

Not a developer and waiting for the full release before installing Lion, hope this isn't an issue as I often hook my MBP up to our AV Receiver.
__________________
15" 2012 Retina MacBook Pro i7 2.3GHz/8GB/256GB 10.9.3

iPhone 5s 32GB Space Grey iOS 7.1.1
runebinder is offline   0 Reply With Quote
Old Jul 8, 2011, 06:19 AM   #9
Sean-B-89
Thread Starter
macrumors newbie
 
Join Date: Jul 2011
Quote:
Originally Posted by runebinder View Post
Shouldn't be an issue, audio was added when they updated MDP to Vesa 1.2 standard, and as long as the adapter follows that (which in the OP's case it does as they could get audio in SL), then incompatibility isn't going to happen.

Not a developer and waiting for the full release before installing Lion, hope this isn't an issue as I often hook my MBP up to our AV Receiver.
Yes, I guess the only thing I can do it wait for the full/final version of Lion and hope the problem solves, right?
Sean-B-89 is offline   0 Reply With Quote
Old Jul 8, 2011, 11:52 AM   #10
Heston
macrumors regular
 
Join Date: Feb 2007
Send a message via AIM to Heston
Quote:
Originally Posted by robbieduncan View Post
Recent Macs can output HDMI with audio via an appropriate MDP->HDMI adapter.
This is true. My girlfriend has the newest Macbook Pro 2011 and i have the 2010. Her's does the audio over the mini display port. Mine doesn't, at least not in Lion. The only reason why i know this is because i recently wanted to watch a movie with the cable she uses and i couldn't get the sound to come through. Is this because of Lion or because of the display port on my older computer?
Heston is offline   0 Reply With Quote
Old Jul 20, 2011, 06:33 PM   #11
Mudman1948
macrumors newbie
 
Join Date: Sep 2007
Location: Greenville, SC
Send a message via AIM to Mudman1948
I just downloaded OS X Lion (the retail $29.99 version) today from the Mac App Store, and guess what I found out…*no audio through HDMI. This stinks. I just wanted to post here to show that it wasn't fixed or patched between the GM and final release version.

WAIT WAIT WAIT

I just checked a 2nd time (after restarting) and now the HDMI option is showing up. Weird. Sorry for the incorrect statement.
__________________
Adam Ness
13" Macbook Air, 2.13GHz, 4GB RAM, 250 GB SSD
13" Macbook, white
12" Powerbook 1.5GHz, 1.25GB RAM, 80GB HDD

Last edited by Mudman1948; Jul 20, 2011 at 06:47 PM. Reason: wrong
Mudman1948 is offline   0 Reply With Quote
Old Jul 20, 2011, 07:06 PM   #12
wickedsteve
macrumors member
 
Join Date: Jan 2006
Same boat

I am in the same boat here. I upgraded to 10.7 and now sound over HDMI is not working anymore on my 2011 MBP 13".
wickedsteve is offline   1 Reply With Quote
Old Jul 21, 2011, 03:04 AM   #13
Sean-B-89
Thread Starter
macrumors newbie
 
Join Date: Jul 2011
Quote:
Originally Posted by Mudman1948 View Post
I just downloaded OS X Lion (the retail $29.99 version) today from the Mac App Store, and guess what I found outů*no audio through HDMI. This stinks. I just wanted to post here to show that it wasn't fixed or patched between the GM and final release version.

WAIT WAIT WAIT

I just checked a 2nd time (after restarting) and now the HDMI option is showing up. Weird. Sorry for the incorrect statement.
I heard that the GM was the same as the final. But I will also download OS X Lion and see if it indeed will work!
Sean-B-89 is offline   0 Reply With Quote
Old Jul 22, 2011, 04:54 AM   #14
Sean-B-89
Thread Starter
macrumors newbie
 
Join Date: Jul 2011
Nope.. Even after installing Lion from the Mac App Store the HDMI sound option still won't come up!
Sean-B-89 is offline   0 Reply With Quote
Old Jul 22, 2011, 07:41 AM   #15
Corre
macrumors newbie
 
Join Date: Jul 2011
Same problem right here, iMac mid 2011. Video and audio got sent just fine to my home theatre under Snow Leopard. Since Lion no such luck.
Have you tried SMC reset? I read that might help (may take 2-3 attempts), although it didn't for me.
So now, should I just cross my fingers and hope that Apple follows up on bug reports? Anything else I can try?
Corre is offline   0 Reply With Quote
Old Jul 22, 2011, 09:12 AM   #16
smlfri
macrumors newbie
 
Join Date: Sep 2008
same problem with my MBP 2011 but for me my monitor comes up under system preferences > sound (output tab) as type:HDMI and when i chose it there is still no audio anyone have a fix yet? also i am using the moshi adapter too could this be the problem?
smlfri is offline   0 Reply With Quote
Old Jul 22, 2011, 09:42 AM   #17
JTToft
macrumors 6502a
 
Join Date: Apr 2010
Location: Aarhus, Denmark
Everything works great here. Sound through mDP to HDMI cable and a beautiful FullHD picture on my Sony Bravia TV.

This is the cable I am using on my 2011 15" MacBook Pro.
__________________
2011 15" MacBook Pro, 2.2GHz Quad-core Intel Core i7, AMD Radeon 6750M 1GB, 256 GB Samsung 830 SSD, 10GB RAM, Hi-Res Antiglare;
iPhone 6 64 GB Space Grey;
iPad Air Wi-Fi 32 GB White
JTToft is offline   0 Reply With Quote
Old Jul 22, 2011, 10:49 AM   #18
Trigeeks
macrumors newbie
 
Join Date: Nov 2010
Mine is not working with Lion either. That's just weird!!!!
Trigeeks is offline   0 Reply With Quote
Old Jul 23, 2011, 03:25 AM   #19
Sean-B-89
Thread Starter
macrumors newbie
 
Join Date: Jul 2011
Quote:
Originally Posted by Corre View Post
Same problem right here, iMac mid 2011. Video and audio got sent just fine to my home theatre under Snow Leopard. Since Lion no such luck.
Have you tried SMC reset? I read that might help (may take 2-3 attempts), although it didn't for me.
So now, should I just cross my fingers and hope that Apple follows up on bug reports? Anything else I can try?
Yes I have tried that, but it didn't work. And I am not intended to buy another cable again..
I've also replied to a topic on the Apple Discussions forum. Maybe we need to complain there to get their attention?

https://discussions.apple.com/message/15693651#15693651
Sean-B-89 is offline   0 Reply With Quote
Old Jul 23, 2011, 08:04 AM   #20
Corre
macrumors newbie
 
Join Date: Jul 2011
Right, that's where I read it, thanks. Will keep my eye on that discussion. Sent a bug report as well, we'll see.
Let's be realistic, the problem seems to be rather widespread, so if Apple wants to be in our living rooms delivering our home entertainment, they'll want their devices to work with our tv's an other receivers, right? Meanwhile, though, I'l be watching some good old-fashioned broadcast tv :-)
Corre is offline   0 Reply With Quote
Old Jul 23, 2011, 08:31 AM   #21
pj-uk
macrumors member
 
Join Date: Mar 2011
Location: London
Have you tried holding down alt and clicking the volume icon to select another audio output? My 2010 Macbook pro works fine with 10.7 to both a TV and also to an amplifier using mini display port to HDMI adapter.
pj-uk is offline   0 Reply With Quote
Old Jul 23, 2011, 08:39 AM   #22
Corre
macrumors newbie
 
Join Date: Jul 2011
Quote:
Originally Posted by pj-uk View Post
Have you tried holding down alt and clicking the volume icon to select another audio output?
Is there another (quick) way to switch between audio devices? :-)
Corre is offline   0 Reply With Quote
Old Jul 26, 2011, 04:19 PM   #23
joshwright10
macrumors newbie
 
Join Date: Jul 2011
Quote:
Originally Posted by Corre View Post
Is there another (quick) way to switch between audio devices? :-)
When It finally does start working again (I'm having the same problem with 13"MBP 2011) Worked on Snow leopard,


Use Sound source - Its free and has a menu bar icon to easily switch between inputs and outputs
joshwright10 is offline   0 Reply With Quote
Old Jul 27, 2011, 04:58 PM   #24
Sean-B-89
Thread Starter
macrumors newbie
 
Join Date: Jul 2011
Did no one got hands on the 10.7.2 developer's update to test the audio through hdmi by accident?

Last edited by Sean-B-89; Jul 29, 2011 at 03:42 AM.
Sean-B-89 is offline   0 Reply With Quote
Old Jul 27, 2011, 05:24 PM   #25
Madd the Sane
macrumors 6502
 
Join Date: Nov 2010
Location: Utah
Wirelessly posted (Mozilla/5.0 (iPod; U; CPU iPhone OS 4_2_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C148 Safari/6533.18.5)

File a bug report and wait for 10.7.1.
__________________
Get out of my mind, idea! I already have an idea in here!
Madd the Sane is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > Mac OS X 10.7 Lion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
5.1 Surround Sound thru HDMI aj350z Mac mini 12 Sep 27, 2013 08:23 PM
No sound via HDMI? crizza0309 MacBook Pro 7 May 23, 2013 02:45 AM
Sound missing when HDMI out to TV xp0z3d MacBook Pro 3 Nov 28, 2012 04:00 PM
HDMI No Sound From Internet aCondor Mac Peripherals 4 Nov 13, 2012 01:19 AM
Sound via HDMI Virro MacBook Pro 4 Oct 30, 2012 01:27 PM

Forum Jump

All times are GMT -5. The time now is 03:45 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC