Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Notebooks > MacBook Pro

Reply
 
Thread Tools Search this Thread Display Modes
Old Jul 21, 2011, 11:17 AM   #1
PNayo92
macrumors member
 
Join Date: Jan 2011
Unhappy MDP to HDMI no audio!

I have a 32" Insignia TV (from about 3-4 years ago) and an early 2011 MBP that I have recently bought. I purchased a MDP to HDMI (with audio support) to connect my computer to my television.

This is the cable I bought:
http://store.apple.com/us/product/H4...co=MTY3ODQ5OTY

I was able to configure my television to HDMI. However, only video streams through my television. Right now I am using Mirror mode to display my computer on the external screen. I have already gone into sound settings and changed the output to HDMI, but to no avail. It also says that "the selected device has no output controls."

Does anybody have any advice for me? I'd really like this to work :/
PNayo92 is offline   0 Reply With Quote
Old Jul 21, 2011, 01:25 PM   #2
PNayo92
Thread Starter
macrumors member
 
Join Date: Jan 2011
anybody? I still can't find any solution :/
PNayo92 is offline   0 Reply With Quote
Old Jul 21, 2011, 01:33 PM   #3
xblyx
macrumors newbie
 
Join Date: Jul 2008
I had a similar situation but with a totally different set of cables (MDP to HDMI and MDP to HDMI adapter). At first I wasn't getting any sound to playback, but after a reboot everything got sync'd up and working again.

Are you playing back AC-3 or DTS video and you're TV can't handle it? Try playing a video from youtube or something.
xblyx is offline   0 Reply With Quote
Old Jul 21, 2011, 01:34 PM   #4
kfergiez
macrumors 6502
 
Join Date: Jul 2010
A 3-4 year old HDMI input might be the problem.
kfergiez is offline   0 Reply With Quote
Old Jul 21, 2011, 05:12 PM   #5
PNayo92
Thread Starter
macrumors member
 
Join Date: Jan 2011
nope, no luck with youtube videos. I don't think it's the type of audio that is the problem
PNayo92 is offline   0 Reply With Quote
Old Jul 21, 2011, 09:33 PM   #6
PNayo92
Thread Starter
macrumors member
 
Join Date: Jan 2011
bump
PNayo92 is offline   0 Reply With Quote
Old Jul 21, 2011, 09:35 PM   #7
Hook'Em2006
macrumors 6502
 
Join Date: Sep 2009
Location: Plano, TX
Did you look at your audio settings? When I first hooked mine up, I had to change the audio output to HDMI. Worked for me. Lemme know if it works for you.
__________________
15.4" 2011 MacBook Pro Quad Core i7 w/ 500gb, White iPhone 4S 32gb, TV x2
Hook'Em2006 is offline   0 Reply With Quote
Old Jul 22, 2011, 09:51 AM   #8
PNayo92
Thread Starter
macrumors member
 
Join Date: Jan 2011
These are my only audio setting on my TV:

-MTS: Stereo, SAP, or Mono
-SPDIF Type: Off, PCM, or Doby Digital
-Audio Language: English, French, Spanish
-Speaker: On, Off
-Audio Out: Fixed, Variable

I tried Right Clicking HDMI under the audio midi settings, and I was given the choice to configure speakers. Seems to not really do anything though.
PNayo92 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Notebooks > MacBook Pro

Tags
insignia mdp hdmi audio

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
XServe 2006: Supported Graphics Cards With HDMI or DVI with audio to hdmi iphone2g&3gfan iMac 3 May 30, 2014 04:42 PM
MDp or Thunderbolt? to HDMI Adapter fo iMac SKATE4LIFE iMac 5 Dec 11, 2013 12:07 PM
MDP-HDMI No Audio from Headphone Jack Leaping Tortois MacBook Pro 9 Sep 29, 2013 04:29 AM
HDMI to mdp need new driver? anotherpaul Mac mini 24 Jul 13, 2013 10:12 PM
MDP to HDMI issue. Pistachio Mac Peripherals 0 Jun 21, 2012 09:38 AM

Forum Jump

All times are GMT -5. The time now is 08:22 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC