Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iOS > Jailbreaks and iOS Hacks

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 27, 2012, 04:50 AM   #1
JoseIP
macrumors newbie
 
Join Date: Jan 2012
No Service on iPhone 4 after redsn0w jailbreak

I have updated my iPhone 4 (GSM) to iOS 5.0.1 with untethered jailbreak using redsn0w.

I didn't unlock because I'm still in contract with the original carrier (Vodafone, here in Spain). I had previously jailbroken (but not unlocked) my phone.

Now the phone is jailbroken in 5.0.1 but it says constantly No Service, the name of the carrier does not appear in "Settings", and "My Number" appears as "unknown".

So I can't use my phone! Please let me know what I should try. My modem firmware, if that's of any use, is 04.11.08.
JoseIP is offline   0 Reply With Quote
Old Jan 27, 2012, 05:27 AM   #2
eastercat
macrumors 68040
 
eastercat's Avatar
 
Join Date: Mar 2008
Location: PDX
First, make sure the sim works by trying it on another phone.
If it's not the sim, setup as new and redo the jb.
__________________
64 GB space grey iPhone 5S (AT&T); 16 GB space grey iPad retina mini (Verizon with T-Mobile sim); 2014 rMBP 2.8 GHz quad core i7, 16 GB RAM, 1TB SSD, Nvidia GeForce GT 750M

Last edited by eastercat; Jan 27, 2012 at 06:04 AM. Reason: Missing articles in a sentence do not lead to comprehension
eastercat is offline   0 Reply With Quote
Old Jan 27, 2012, 05:31 AM   #3
labman
macrumors 604
 
labman's Avatar
 
Join Date: Jun 2009
Location: Mich near Detroit
Also try popping the Sim back out and back in and resetting the Network. are you using redsn0w 0.9.10b4 the latest one?
__________________
IP4+Hackintosh Pro Joining AT&T PM me get $25 Dev-Teams Blog My TwitterCan I JB/UL my device Click here
labman is offline   0 Reply With Quote
Old Jan 27, 2012, 05:47 AM   #4
JoseIP
Thread Starter
macrumors newbie
 
Join Date: Jan 2012
Quote:
Originally Posted by eastercat View Post
First, make sure the sim works by trying it another phone.
I'm at home now, when my girlfriend gets back I'll try on her iPhone.

----------

Quote:
Originally Posted by labman View Post
Also try popping the Sim back out and back in and resetting the Network. are you using redsn0w 0.9.10b4 the latest one?
OK I've tried popped up the Sim out and back, and also resetting the Network... but it still says no service.

Yes I did use the latest redsn0w 0.9.10b4.
JoseIP is offline   0 Reply With Quote
Old Jan 27, 2012, 06:56 AM   #5
Ksizzle9
macrumors 6502a
 
Join Date: Apr 2011
Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A406 Safari/7534.48.3)

I've not fooled with a GSM iPhone in a couple of years, well I guess a year. But, I don't see how the jailbreak could affect the BB or make the phone day no service. I've still got my old 3Gs and I've jb'd it and flashed 100 different firmwares on it and never had that except for occasionally but that is due to the iPad baseband. I would take the above posters advice and restore the phone, then re-JB. I don't see why that wouldnt fix it.
Ksizzle9 is offline   0 Reply With Quote
Old Jan 27, 2012, 07:28 AM   #6
JoseIP
Thread Starter
macrumors newbie
 
Join Date: Jan 2012
Quote:
Originally Posted by Ksizzle9 View Post
Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A406 Safari/7534.48.3)

I've not fooled with a GSM iPhone in a couple of years, well I guess a year. But, I don't see how the jailbreak could affect the BB or make the phone day no service. I've still got my old 3Gs and I've jb'd it and flashed 100 different firmwares on it and never had that except for occasionally but that is due to the iPad baseband. I would take the above posters advice and restore the phone, then re-JB. I don't see why that wouldnt fix it.
Thanks to you all for the help. When you say restore the phone, what kind of restore do you have in mind: do I need to restore to 5.0.1 or to an earlier OS? I presume I would have to do that from iTunes (option + "restore"), manually selecting the ipsw, right?
JoseIP is offline   0 Reply With Quote
Old Jan 27, 2012, 07:32 AM   #7
robdam1001
macrumors 6502a
 
Join Date: Sep 2008
Quote:
Originally Posted by JoseIP View Post
Thanks to you all for the help. When you say restore the phone, what kind of restore do you have in mind: do I need to restore to 5.0.1 or to an earlier OS? I presume I would have to do that from iTunes (option + "restore"), manually selecting the ipsw, right?
Correct I'd recommend setting up as new using d/l'ed IPSW, jb if you want to or not, then restore from backup.
robdam1001 is offline   0 Reply With Quote
Old Jan 27, 2012, 08:19 AM   #8
JoseIP
Thread Starter
macrumors newbie
 
Join Date: Jan 2012
Quote:
Originally Posted by robdam1001 View Post
Correct I'd recommend setting up as new using d/l'ed IPSW, jb if you want to or not, then restore from backup.
OK I want to be sure I understand everything right. Let me know if this is what I should do:

1/ restore in iTunes using a downloaded 5.0.1 IPSW
2/ after it's restored: on the iPhone's "Set Up iPhone" page, check "Set up as new Iphone"
3/ after that, jailbreak using redsn0w

...is that correct so far?

And then how do I restore from backup? From the iPhone's "Set Up iPhone" page or from iTunes?
JoseIP is offline   0 Reply With Quote
Old Jan 27, 2012, 08:27 AM   #9
robdam1001
macrumors 6502a
 
Join Date: Sep 2008
Quote:
Originally Posted by JoseIP View Post
OK I want to be sure I understand everything right. Let me know if this is what I should do:

1/ restore in iTunes using a downloaded 5.0.1 IPSW
2/ after it's restored: on the iPhone's "Set Up iPhone" page, check "Set up as new Iphone"
3/ after that, jailbreak using redsn0w

...is that correct so far?

And then how do I restore from backup? From the iPhone's "Set Up iPhone" page or from iTunes?
1-3 are correct. After you jb, connect via iTunes, right click on your iPhone icon in left hand pane, restore from backup.
robdam1001 is offline   0 Reply With Quote
Old Jan 27, 2012, 10:19 AM   #10
JoseIP
Thread Starter
macrumors newbie
 
Join Date: Jan 2012
^^ Thanks! The only problem is that the "restore" button in iTunes doesn't appear highlighted, so I can't click on it. It's written "restore" in light gray whereas yesterday it was written in black (it was working yesterday when I jailbroke my phone). Does anyone know why that is?

By the way, I've been able to test my SIM card, it works fine on another phone, that's why I'm restoring.
JoseIP is offline   0 Reply With Quote
Old Jan 27, 2012, 10:36 AM   #11
TriJetHero
macrumors 601
 
TriJetHero's Avatar
 
Join Date: Oct 2010
Location: World
Probably because its sees the phone as completely new and up to date without any backups present.

That happens if you do restore and immediately jailbrak afterwards, somehow it chances the way itunes sees your phone.

A solution might be to restore, than select to put you backup back from itunes, this wil make it "your" phone again. After that JB with redsn0w.
__________________
iPhone 5 iOS 7.1.2 Pangu
iPad 4 3G iOS 7.1.2 Stock
iPad 2 WIFI iOS 8.0 GM
Mac Book Pro 15" mid 2010
TriJetHero is offline   0 Reply With Quote
Old Jan 27, 2012, 11:05 AM   #12
JoseIP
Thread Starter
macrumors newbie
 
Join Date: Jan 2012
I have just installed tinyumbrella and I've used it put the phone in recovery mode, this way the "restore" button reappears in iTunes.

So I tried to restore with a downloaded IPSW... but it won't restore, after a while I get a (21) error message. Any idea what I should do?
JoseIP is offline   0 Reply With Quote
Old Jan 27, 2012, 12:28 PM   #13
JoseIP
Thread Starter
macrumors newbie
 
Join Date: Jan 2012
Guys, I managed to make it work!!!!

I had to quit tinyumbrella to be able to restore.

So now it's jailbroken and working fine (as a phone). Thanks so much to all of you who helped! I thought I was never gonna see the end of it, but in the end I'm happy it turned out well.
JoseIP is offline   0 Reply With Quote
Old Feb 4, 2012, 05:57 AM   #14
Nepal
macrumors newbie
 
Join Date: Feb 2012
Quote:
Originally Posted by JoseIP View Post
Guys, I managed to make it work!!!!

I had to quit tinyumbrella to be able to restore.

So now it's jailbroken and working fine (as a phone). Thanks so much to all of you who helped! I thought I was never gonna see the end of it, but in the end I'm happy it turned out well.
i am facing same problem ...please share me how u fix ur iphone???
Nepal is offline   0 Reply With Quote
Old Oct 9, 2012, 04:40 PM   #15
ludragoon
macrumors newbie
 
Join Date: Oct 2012
how do i restore it to IPSW 5.0.1?
ludragoon is offline   0 Reply With Quote
Old Oct 9, 2012, 04:44 PM   #16
dhlizard
macrumors G3
 
dhlizard's Avatar
 
Join Date: Mar 2009
Location: The Jailbreak Community
Your only unlock is an IMEI unlock
You can only restore to 5.x.x if you saved the hashes
__________________
Two iPhone 5S
iPad 4 iPad Air AppleTV 2
MacBook Pro Two iMacs

Look for me here
dhlizard is offline   0 Reply With Quote
Old May 3, 2013, 03:58 PM   #17
stardemos
macrumors newbie
 
Join Date: May 2013
I have the same issue on ios 6.1.3, any known fix to it??
stardemos is offline   0 Reply With Quote
Old May 3, 2013, 04:09 PM   #18
darricksailo
macrumors 68040
 
darricksailo's Avatar
 
Join Date: Dec 2012
Quote:
Originally Posted by stardemos View Post
I have the same issue on ios 6.1.3, any known fix to it??
What's your problem? Please be more descriptive
darricksailo is offline   0 Reply With Quote
Old May 3, 2013, 04:39 PM   #19
stardemos
macrumors newbie
 
Join Date: May 2013
I just intall the 6.1.3 on iphone 4. Instaled cidya, ultrasnow and semitether. Put my sim in and no service. The pgone was locked to another contry... Unknown contry
I live in portugal
----------
Model mc603j/a

Baseband 04.12.05

Last edited by stardemos; May 3, 2013 at 04:57 PM.
stardemos is offline   0 Reply With Quote
Old May 3, 2013, 04:55 PM   #20
darricksailo
macrumors 68040
 
darricksailo's Avatar
 
Join Date: Dec 2012
Quote:
Originally Posted by stardemos View Post
I just intall the 6.1.3 on iphone 4. Instaled cidya, ultrasnow and semitether. Put my sim in and no service. The pgone was locked to another contry... Unknown contry

----------

Baseband 04.12.05
I'm not too sure what the thread is about but according to the ultrasn0w page, that baseband isn't supported

Did you restore your iphone 4 to iOS 6.1.3 using a no baseband custom firmware?
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	32
Size:	188.0 KB
ID:	410805  
darricksailo is offline   0 Reply With Quote
Old May 3, 2013, 05:00 PM   #21
stardemos
macrumors newbie
 
Join Date: May 2013
My bad... I'vr restored directly from apple.... It's possible to downgrade baseband?? How??
stardemos is offline   0 Reply With Quote
Old May 3, 2013, 05:01 PM   #22
darricksailo
macrumors 68040
 
darricksailo's Avatar
 
Join Date: Dec 2012
Quote:
Originally Posted by stardemos View Post
My bad... I'vr restored directly from apple.... It's possible to downgrade baseband?? How??
I don't think it's possible to downgrade the baseband but maybe things have changed that I don't know about since then
darricksailo is offline   0 Reply With Quote
Old May 3, 2013, 05:19 PM   #23
stardemos
macrumors newbie
 
Join Date: May 2013
Is there any other way to unlock this phone?
stardemos is offline   0 Reply With Quote
Old May 3, 2013, 05:50 PM   #24
darricksailo
macrumors 68040
 
darricksailo's Avatar
 
Join Date: Dec 2012
Quote:
Originally Posted by stardemos View Post
Is there any other way to unlock this phone?
You can try requesting for a carrier unlock by contacting the carrier that the phone is locked to
darricksailo is offline   0 Reply With Quote
Old May 3, 2013, 05:57 PM   #25
stardemos
macrumors newbie
 
Join Date: May 2013
ok...
I have an expensive and useless ipod with the shape of an iphone4....
will search for a way to downgrade baseband... if exists I will post it.
stardemos is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iOS > Jailbreaks and iOS Hacks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
iPhone: Redsn0w just boot doesn't work. I have an iPhone 3GS tethered jailbreak on 6.0.1.? Datguyyoudontwa Jailbreaks and iOS Hacks 9 Sep 3, 2013 12:36 PM
iPhone: HELP! iPhone 3GS No Service after Redsn0w jailbreak with ultrasn0w unlock CanucksFan15 Jailbreaks and iOS Hacks 3 Jul 13, 2013 03:30 PM
iPhone: iOS 6 Jailbreak Using Redsn0w ahsantasneem Jailbreaks and iOS Hacks 17 Nov 6, 2012 07:10 AM
5.1.1 Jailbreak no service ATT iPhone 4 Rbai63 Jailbreaks and iOS Hacks 13 Jul 5, 2012 10:08 AM

Forum Jump

All times are GMT -5. The time now is 03:35 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC