Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iOS > iOS 5 and earlier

Reply
 
Thread Tools Search this Thread Display Modes
Old May 28, 2012, 08:45 AM   #1
3bs
macrumors 603
 
3bs's Avatar
 
Join Date: May 2011
Location: Dublin, Ireland
Keep getting iMessage activation alert

I restored my phone and I'm on 5.1.1 and for some reason I keep getting he activation alert telling me my carrier might charge me for the SMS activation. The same happened for FaceTime, I kept getting an alert but I turned it off and I stopped getting it but somehow now it's back on but I'm getting alerts r iMessage instead.
3bs is offline   0 Reply With Quote
Old May 28, 2012, 03:14 PM   #2
3bs
Thread Starter
macrumors 603
 
3bs's Avatar
 
Join Date: May 2011
Location: Dublin, Ireland
I've also noticed that when people iMessage me on my number I get it and also if they send it to my Apple ID but when I iMessage them they receive it from my email although I have my caller ID set to my phone number
3bs is offline   0 Reply With Quote
Old Jun 2, 2012, 01:39 PM   #3
3bs
Thread Starter
macrumors 603
 
3bs's Avatar
 
Join Date: May 2011
Location: Dublin, Ireland
I've tried 5.1.1 twice now and it won't seem to activate iMessage or FaceTime. I went back to 5.0.1 and I don't have this problem. Any ideas why?
3bs is offline   0 Reply With Quote
Old Jun 2, 2012, 01:57 PM   #4
Daveoc64
macrumors 601
 
Join Date: Jan 2008
Location: Bristol, UK
Which network are you using the iPhone on?
__________________
Nexus 5 32GB Black (Three UK) | Nexus 7 (2012) | Kindle Paperwhite (2013)
iPhone 4 32GB
White MacBook (Late 2007)
Windows 8.1 | iCloud, Dropbox, Spotify Premium
Daveoc64 is offline   0 Reply With Quote
Old Jun 2, 2012, 08:44 PM   #5
3bs
Thread Starter
macrumors 603
 
3bs's Avatar
 
Join Date: May 2011
Location: Dublin, Ireland
Quote:
Originally Posted by Daveoc64 View Post
Which network are you using the iPhone on?
3 Ireland. This is really annoying. If I turn off FaceTime it starts doing it for iMessage. I notice I only get this when I'm not on wifi.
3bs is offline   0 Reply With Quote
Old Jun 2, 2012, 08:50 PM   #6
Carlanga
macrumors 601
 
Carlanga's Avatar
 
Join Date: Nov 2009
Location: PR
Something similar happened to me on 5.0 when I went for a trip and used another sim then replaced it w/ my orig carrier sim and the iCloud phone number activation go stuck without me even realizing it until people started telling me why I was not answering their imsjs back... I went to settings for each thing and for example in message settings I turn it off then on and that seemed to activate it properly; did the same w/ all the other apps.... If not maybe try resetting the network settings?
__________________
☻ "A dream you dream alone is only a dream...
... A dream you dream together is reality." ☻
Carlanga is offline   0 Reply With Quote
Old Jun 2, 2012, 09:08 PM   #7
3bs
Thread Starter
macrumors 603
 
3bs's Avatar
 
Join Date: May 2011
Location: Dublin, Ireland
Quote:
Originally Posted by Carlanga View Post
Something similar happened to me on 5.0 when I went for a trip and used another sim then replaced it w/ my orig carrier sim and the iCloud phone number activation go stuck without me even realizing it until people started telling me why I was not answering their imsjs back... I went to settings for each thing and for example in message settings I turn it off then on and that seemed to activate it properly; did the same w/ all the other apps.... If not maybe try resetting the network settings?
I tried turning off iMessage and FaceTime. Let me try resetting network settings. The weird thing is this is the 2nd time I restore and setup as new and it's happened both times.

edit: also something weird I've noticed is that in Settings > Phone > My Number isn't actually my number even though when I text or call someone, my number shows up.

Last edited by 3bs; Jun 2, 2012 at 09:26 PM.
3bs is offline   0 Reply With Quote
Old Jun 2, 2012, 09:49 PM   #8
Carlanga
macrumors 601
 
Carlanga's Avatar
 
Join Date: Nov 2009
Location: PR
Quote:
Originally Posted by 3bs View Post
I tried turning off iMessage and FaceTime. Let me try resetting network settings. The weird thing is this is the 2nd time I restore and setup as new and it's happened both times.

edit: also something weird I've noticed is that in Settings > Phone > My Number isn't actually my number even though when I text or call someone, my number shows up.
let me know if resetting fixed it for you.
Are you jb? do you use a sim interposer? which hacks are you running if jb? Are you using a number that was not the one registered w/ the iPhone? in iCloud do you have the sim card # or is it another one?
__________________
☻ "A dream you dream alone is only a dream...
... A dream you dream together is reality." ☻
Carlanga is offline   0 Reply With Quote
Old Jun 2, 2012, 09:58 PM   #9
3bs
Thread Starter
macrumors 603
 
3bs's Avatar
 
Join Date: May 2011
Location: Dublin, Ireland
So I've noticed that I get these activation messages whenever I restart my phone and it's fine until I restart again. My number in FaceTime and iMessage are correct but in Phone it's not my number. It's a temporary number which 3 was provides until my number is switched from my old carrier (Vodafone). I switched months ago so not sure why it's showing up now.

----------

Quote:
Originally Posted by Carlanga View Post
let me know if resetting fixed it for you.
Are you jb? do you use a sim interposer? which hacks are you running if jb? Are you using a number that was not the one registered w/ the iPhone? in iCloud do you have the sim card # or is it another one?
Nope. Doesn't seem to have fixed it but at least now I only get the activation method when I reboot. I am jailbroken but never had this issue on 5.0.1. My phone is factory unlocked. I'm using the same tweaks as I did on 5.0.1 so I doubt that's the issue. Not using iCloud at the moment.

Reading some posts from here and and it seems like I just need to get a new sim card. I'll try that tomorrow. I hope this fixes it. I'd rather stay on 5.1.1 than go back to 5.0.1 https://discussions.apple.com/thread...art=0&tstart=0
3bs is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iOS > iOS 5 and earlier

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:17 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC