Go Back   MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Reply
 
Thread Tools Search this Thread Display Modes
Old Jul 29, 2012, 06:50 PM   #1
milas90
macrumors newbie
 
Join Date: Sep 2010
TextEdit in Mountain Lion

When I open TextEdit in Mountain Lion, it brings up an "open" box. In previous versions, it opened straight up to a new document. That quick-start was the main reason I used TextEdit -- does anyone know if there's an option to open a new document on launch, rather than the "open" panel?
milas90 is offline   0 Reply With Quote
Old Jul 30, 2012, 08:56 AM   #2
luckylindy
macrumors newbie
 
Join Date: Sep 2007
Same disappointment here...

I tried a few different keyboard combos but that didn't work. Minor annoyance but, just as you say, the old way was a nice quick entry into the app. Let's hope we missed a trick.
luckylindy is offline   0 Reply With Quote
Old Jul 31, 2012, 12:22 AM   #3
pekingli
macrumors newbie
 
Join Date: Jul 2010
The same situation here. What I find, is that if you create a new account and launch Textedit there, you will have a new empty file to edit immediately.
So my guess is that some preference file should do the trick.
pekingli is offline   0 Reply With Quote
Old Jul 31, 2012, 12:40 AM   #4
kieMac
macrumors newbie
 
Join Date: Jun 2009
Great observation, pekingli!

I was also very annoyed by this new TextEdit "feature" and was about to switch to TextWrangler. After hearing that pekingli got a blank document under another account, I realized that being logged into iCloud must be the problem.

SOLUTION:

Go to System Preferences > iCloud > uncheck "Documents & Data" from the sync list.
kieMac is offline   3 Reply With Quote
Old Aug 4, 2012, 02:14 PM   #5
Rexgom
macrumors newbie
 
Join Date: Aug 2012
Thanks

Quote:
Originally Posted by kieMac View Post
Great observation, pekingli!

I was also very annoyed by this new TextEdit "feature" and was about to switch to TextWrangler. After hearing that pekingli got a blank document under another account, I realized that being logged into iCloud must be the problem.

SOLUTION:

Go to System Preferences > iCloud > uncheck "Documents & Data" from the sync list.
Worked beautifully but a bit of an intimidating message that anything cloud based gets wiped from your mac.
Rexgom is offline   0 Reply With Quote
Old Aug 10, 2012, 06:17 AM   #6
DCEFrance
macrumors newbie
 
Join Date: Nov 2008
Not a solution - Any other ideas???

Quote:
Originally Posted by kieMac View Post
SOLUTION:

Go to System Preferences > iCloud > uncheck "Documents & Data" from the sync list.
Actually that's not a solution. Many of us use iCloud synchronizing of Documents & Data for a lot more than TextEdit and therefore need to keep that running.

Is there really no other way to get TextEdit to open with a new document as previously???
DCEFrance is offline   1 Reply With Quote
Old Aug 10, 2012, 10:14 AM   #7
Fishrrman
macrumors 601
 
Join Date: Feb 2009
I found that I could just "copy over" an -older copy- of TexEdit (I'm using version 1.6) and use that instead of the latest version in Mountain Lion.

Version 1.6 still retains "the old ways" of saving files.

I prefer a -real- "Save As" that works "traditionally", rather than the new style.
Fishrrman is offline   0 Reply With Quote
Old Aug 10, 2012, 10:17 AM   #8
satcomer
macrumors 601
 
satcomer's Avatar
 
Join Date: Feb 2008
Location: Upstate NYS
Quote:
Originally Posted by Fishrrman View Post
I found that I could just "copy over" an -older copy- of TexEdit (I'm using version 1.6) and use that instead of the latest version in Mountain Lion.

Version 1.6 still retains "the old ways" of saving files.

I prefer a -real- "Save As" that works "traditionally", rather than the new style.
Get that back then and stop whining!

Just hold down the 'Alt/option' key while in a document and Duplicate will turn into Save-As.
__________________
Mac Pro Dual 2.8 Quad(Rev B.), 16 G RAM, OS X 10.9, 23'' LCD
Mac Book Pro Core 2 Duo 2.16Ghz, SuperDrive, 2G RAM, OS X 10.7.5
iPad 3, 32 black
satcomer is offline   0 Reply With Quote
Old Aug 10, 2012, 12:22 PM   #9
chown33
macrumors 603
 
Join Date: Aug 2009
Quote:
Originally Posted by DCEFrance View Post
Is there really no other way to get TextEdit to open with a new document as previously???
Have you looked in TextEdit > Preferences?

That's not a rhetorical question. I don't have Mtn Lion on anything here, so I can't look for you.
chown33 is offline   0 Reply With Quote
Old Aug 11, 2012, 11:44 AM   #10
thasan
macrumors 6502a
 
Join Date: Oct 2007
Location: uk
Quote:
Originally Posted by kieMac View Post
Great observation, pekingli!

I was also very annoyed by this new TextEdit "feature" and was about to switch to TextWrangler. After hearing that pekingli got a blank document under another account, I realized that being logged into iCloud must be the problem.

SOLUTION:

Go to System Preferences > iCloud > uncheck "Documents & Data" from the sync list.
thanks. it was also annoying with the preview! both gone now
thasan is offline   0 Reply With Quote
Old Aug 16, 2012, 03:32 PM   #11
skullduggery09
macrumors newbie
 
Join Date: Aug 2012
Being that we're unchecking Cloud, will that mess with my regular downloads of music? I don't use the cloud at all. Thanks in advance
skullduggery09 is offline   0 Reply With Quote
Old Aug 23, 2012, 04:22 AM   #12
teetotaler
macrumors newbie
 
Join Date: Aug 2012
I don't use iCloud but TextEdit on 10.8 has always opened with a blank 'Untitled' document for me.

The one issue I am encountering is, on Leopard (my previous OS) if you entered some text in this default 'Untitled' document and then if your laptop crashed or TextEdit is 'Force Quit' it would still remember your changes in an 'Untitled' document when you brought it up next time.

This is not the case on 10.8/ML - if I type anything into the default 'Untitled' document I lose my changes the next time TextEdit comes up, unless explicitly saved before the crash / force quit.

Has anyone come across this issue and a solution for it?
teetotaler is offline   1 Reply With Quote
Old Aug 23, 2012, 07:49 PM   #13
Phatpat
macrumors 6502a
 
Phatpat's Avatar
 
Join Date: Jun 2003
Location: Washington DC
Send a message via AIM to Phatpat
Wish there was a better solution to this than either disabling iCloud or using a different version of the app. For now I guess I will find myself an older version of textedit.
__________________
my flickr
Phatpat is offline   0 Reply With Quote
Old Aug 26, 2012, 08:47 PM   #14
Peva
macrumors newbie
 
Join Date: Jul 2007
TextEdit in Mountain Lion

Not a perfect solution (Btw, I too deselected "Documents & Data" in the iCloud prefs) but these approaches might help some folks irrespective of whether you use iCloud or not
Method 1. If you want to copy text (say from Safari) make sure the "New TextEdit Window Containing Selection" is active in the Services menu (In Safari, after selecting a block of text, click on the Safari menu, choose Services and search for "New TextEdit Window…") A new TextEdit window will open containing your copied selection. You can add Services in the System Preferences via the Keyboard pref. Click on the Keyboard Shortcuts tab and in the left pane choose Services and in the Text sub choose the above Service. Or alternatively click on the Finder menu > Services > Services prefs.
Method 2. Open a new TextEdit window and save the file as a blank (say in the Documents folder with the title Blank or whatever you like) and drag the Blank file to the Dock (to the right of the Application Divider) When you want to open TextEdit, instead of clicking the application icon in the Dock, just click the Blank document (in the Dock) and you're good to go (no intermediate window will pop up).
After a while the Blank document will show up in the Show Recents pop-up window when you right (control) click on the TextEdit application icon in the Dock and you can keep using it from there - unless you also suffer from the Show Recents bug that still hasn't been dealt with by Apple even in Mountain Lion.
Peva is offline   0 Reply With Quote
Old Oct 24, 2012, 07:44 AM   #15
hamcan
macrumors newbie
 
Join Date: Aug 2011
found a solution

here's what i found:

http://www.cultofmac.com/187553/chan...ion-os-x-tips/

works great for me!
hamcan is offline   0 Reply With Quote
Old Nov 28, 2012, 12:17 PM   #16
Kevin L.
macrumors member
 
Join Date: Jan 2008
Quote:
Originally Posted by hamcan View Post
here's what i found:

http://www.cultofmac.com/187553/chan...ion-os-x-tips/

works great for me!
Ya, but that still doesn't get rid of the new dialog box when you open TextEdit for the first time. Like everyone else complaining about this new "feature", I have always used TextEdit as a quick catch-all for jotting notes, pasting text, etc. I liked the idea someone else had of replacing 1.8 with an older version of TextEdit. I had just hoped there was a terminal command to make the preference for opening a new TextEdit document to be a blank doc instead of the dialog.

Wouldn't it be easy to also just write a script you could run which would open TextEdit with a new, blank doc? You could place the script in your dock instead of TextEdit. (I haven't messed with scripts very much so I'm not sure of the best way to go about writing it.)
Kevin L. is offline   0 Reply With Quote
Old Dec 8, 2012, 04:14 AM   #17
Let's Sekuhara!
macrumors 6502
 
Join Date: Jun 2008
Location: 日本
I have a copy of the most up-to-date Snow Leopard Text Edit if anyone wants it.
Just PM me.
Only stipulation is you gotta share with others. Pay it forward.
Help the world cope with the oppression imposed by 10.7 & 10.8

It seems to be working for me so far. I make no guarantees and am not liable for anything, like if your computer explodes as a result of using it, etc.

Steps to install:
1. Drop "Text Edit 10.6.app" into your Applications folder.
2. Get Info on any .txt file and change the Open With setting. Then Change All. (It will appear not to change, but it does)
3. Repeat Step 2 for .rtf and any other file types you want to be opened in Text Edit 10.6.
4. Remove the 10.8 Text Edit app shortcut from your Dock (if it's there) and replace with new and improved 10.6 version. ;-)

Here are some of the enhancements you'll find in Version 10.6:
Fully functional Save As feature
File > New (Cmd+N) promptly creates a new document for you without any nag screens
Does not Resume old clutter from a previous session upon launch

The auto-backup feature seems not to work though, as it would if run in Snow Leopard. Probably due to changes in the OS itself.
__________________
27" i7 iMac | 11" MacBook Air | Black MacBook | iPhone 5
Favorite Mac apps: Blender | Ableton Live | Reason
Let's Sekuhara! is offline   2 Reply With Quote
Old Dec 28, 2012, 12:22 AM   #18
Burkminipup
macrumors newbie
 
Join Date: Sep 2008
best of both worlds

i had this same annoyance, but after seeing that the snow leopard version of textedit was compatible with mountain lion, i figured if i wanted to keep my mountain lion with icloud version, id just keep both. i just grabbed the app off my other sl partition and i named the sl version "FastTextEdit" so it will open immediately. unfortunately the sl version of preview is not. i may end up disabling icloud with documents anyway since i dont use it. (not even sure if i can since im running mountain lion on an unsupported mac.. havent even tried)

hope this helps

burkminipup
Burkminipup is offline   1 Reply With Quote
Old Jan 3, 2013, 06:03 AM   #19
Grapefruit
macrumors newbie
 
Join Date: Jan 2013
I had the same problem. I have a little AppleScript that just opens a new window when TextEdit launches with no documents. To trigger my script application to run on launch, I use the preference pane "Do Something When" (http://www.azarhi.com/Projects/DSW/).
Attached Files
File Type: zip TextEditLauncher.zip (53.0 KB, 123 views)
Grapefruit is offline   0 Reply With Quote
Old Feb 14, 2013, 04:30 PM   #20
Rexgom
macrumors newbie
 
Join Date: Aug 2012
Thanks

Got it working sensibly. Just more useless features dreamt up by geeks.
Thanks
Rexgom is offline   0 Reply With Quote
Old Jun 17, 2013, 09:53 PM   #21
eviakhan
macrumors newbie
 
Join Date: Jun 2013
I hate this new "feature" in textEdit as well. I switched to Notepad in the app store, its free and fast, just like textEdit used to be =(
eviakhan is offline   0 Reply With Quote
Old Aug 9, 2013, 04:38 AM   #22
Cecco
macrumors member
 
Join Date: Jun 2008
Quote:
Originally Posted by Grapefruit View Post
I had the same problem. I have a little AppleScript that just opens a new window when TextEdit launches with no documents. To trigger my script application to run on launch, I use the preference pane "Do Something When" (http://www.azarhi.com/Projects/DSW/).
Great tip.

I've added

Code:
tell application "TextEdit"
	activate
end tell
at the end to make the Textedit menu bar active.

And in case you have a non English system, you have to customize the menu items in the line click menu item ...

So for my German system it looks like:

Code:
-- This script creates a new document instead of showing the "Open" window when the application TextEdit is launched. It should be used in conjunction with a tool like "Do Something When" (http://www.azarhi.com/Projects/DSW/), configured to run when TextEdit launches.

tell application "TextEdit"
	set document_count to (count documents)
	if (document_count is not equal to 0) then
		return
	end if
end tell

tell application "System Events"
	tell application process "TextEdit"
		-- Wait until the "Open" window comes up
		set max_poll_cycles to 100000
		set cur_cycle to 0
		repeat until ((count windows) is not 0) or (cur_cycle is equal to max_poll_cycles)
			increment cur_cycle
		end repeat
		
		click menu item "Neu" of menu "Ablage" of menu bar item "Ablage" of menu bar 1
		
	end tell
end tell

tell application "TextEdit"
	activate
end tell
Shame on Apple to force us to use such workarounds instead of simply adding a checkbox "Open with blank window" to the Textedit preferences.

Cheers
Cecco is offline   0 Reply With Quote
Old Aug 9, 2013, 04:57 AM   #23
835153
Guest
 
Join Date: Aug 2013
Create a blank file. Save it. Click on the icon, then 'Get info' and tick 'stationery pad'. This is now a template file. Everytime you want to open a new blank document quickly open this. It will create a copy of the blank file and the template file will remain untouched.

You can place the template file in your dock for quick opening of blank files.
835153 is offline   2 Reply With Quote
Old Jan 24, 2014, 08:24 PM   #24
elfurbe
macrumors newbie
 
Join Date: Dec 2004
Location: Tucson, AZ
Send a message via AIM to elfurbe
Threadcromancy, sorry.

This was the first Google result when I was trying to solve this problem, thought I'd share the literal magic solution.

defaults write -g NSShowAppCentricOpenPanelInsteadOfUntitledFile -bool false

Bam, back to normal.
elfurbe is offline   1 Reply With Quote
Old Mar 3, 2014, 10:25 AM   #25
tbell
macrumors newbie
 
Join Date: Jun 2009
Quote:
defaults write -g NSShowAppCentricOpenPanelInsteadOfUntitledFile -bool false
Amazing! Thank you! Seems to work for Preview as well
tbell is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Resolved: How to do a Clean install of Mountain Lion on Mountain Lion phr33k OS X 12 Feb 6, 2013 11:15 AM
Resolved: Help - How to do a clean install of Mountain Lion on Mountain Lion phr33k Mac Basics and Help 7 Nov 25, 2012 08:13 AM
TextEdit in mountain lion is ruined Z3B Mac Applications and Mac App Store 6 Oct 7, 2012 01:31 PM
if i uppgrade to mountain lion will both lion and mountain lion be installed? Popis1991 OS X 10.8 Mountain Lion 2 Sep 16, 2012 08:31 AM
Problem clean installing Mountain Lion over Mountain Lion! datsmabowl OS X 10.8 Mountain Lion 6 Aug 15, 2012 11:13 PM

Forum Jump

All times are GMT -5. The time now is 04:58 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC