Go Back   MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Reply
 
Thread Tools Search this Thread Display Modes
Old Oct 13, 2012, 06:42 PM   #1
jaardesign
macrumors newbie
 
Join Date: Aug 2010
Help me log into Apple Support Communities please!

Hi, I am trying to log into the support forum on Apple's website but I can't. It is prompting me to create a username but I already have one!

I go to apple.com, click on 'Support', click on 'Communities'. Then it takes me to a page that has me sign into my apple id. I click 'Sign in' and it brings me back to the same page but says, "Please sign in again. For added security, we need to reconfirm your Apple ID.". So, I fill out the ID and password and click 'Sign in' again. Now comes the problem part, it then takes me to a page titled, "Pick a username". I already have a user name, but if I enter it into the username field, it tells me, "This username is already taken, please choose another. Another has been provided." But, when I enter in another Username, it tells me, "An account utilizing this email address already exists. Only one account per email address is allowed on Apple Support Communities.

I have tried multiple browsers, IE, Safari, Firefox, Chrome and it does the same in all.
jaardesign is offline   1 Reply With Quote
Old Oct 26, 2012, 08:27 AM   #2
theonlyandyt
macrumors newbie
 
Join Date: Nov 2008
I'm getting this as well. If I log into my Apple ID from anywhere other that the support forum, I can log in fine. Only the forum refuses.
__________________
24" DELL LCD, Mac Pro Quad 2.8 GHz, 4GB RAM, 2TB HD, 16GB iPhone, 16GB iPod Touch, 80GB iPod, 2GB nano, IBM Thinkpad X40
theonlyandyt is offline   0 Reply With Quote
Old Oct 26, 2012, 08:29 AM   #3
needfx
macrumors 68030
 
needfx's Avatar
 
Join Date: Aug 2010
Location: macrumors apparently
Quote:
Originally Posted by jaardesign View Post
Hi, I am trying to log into the support forum on Apple's website but I can't. It is prompting me to create a username but I already have one!

I go to apple.com, click on 'Support', click on 'Communities'. Then it takes me to a page that has me sign into my apple id. I click 'Sign in' and it brings me back to the same page but says, "Please sign in again. For added security, we need to reconfirm your Apple ID.". So, I fill out the ID and password and click 'Sign in' again. Now comes the problem part, it then takes me to a page titled, "Pick a username". I already have a user name, but if I enter it into the username field, it tells me, "This username is already taken, please choose another. Another has been provided." But, when I enter in another Username, it tells me, "An account utilizing this email address already exists. Only one account per email address is allowed on Apple Support Communities.

I have tried multiple browsers, IE, Safari, Firefox, Chrome and it does the same in all.
Quote:
Originally Posted by theonlyandyt View Post
I'm getting this as well. If I log into my Apple ID from anywhere other that the support forum, I can log in fine. Only the forum refuses.
you have to be initiated first, then blazed for a few months, then your password will work
__________________
flickr, amphipolis
needfx is offline   0 Reply With Quote
Old Oct 29, 2012, 09:37 AM   #4
moulitsa
macrumors newbie
 
Join Date: Oct 2012
I have exactly the same problem!! It is really very annoying and obviously cannot seek support on the apple support site!
moulitsa is offline   1 Reply With Quote
Old Oct 31, 2012, 04:54 PM   #5
mickscrill
macrumors newbie
 
Join Date: Aug 2007
Same here.
log in everywhere else but discussions
mickscrill is offline   0 Reply With Quote
Old Nov 1, 2012, 12:01 PM   #6
dcb19
macrumors newbie
 
Join Date: Nov 2012
Help me log into Apple Support Communities please!

same problem here. anyone have the answer?
dcb19 is offline   0 Reply With Quote
Old Nov 1, 2012, 10:53 PM   #7
markinsd
macrumors newbie
 
Join Date: Nov 2012
Ditto!

I tried logging in with my account and with my wife's account. I just end up on a page that says "An unknown error has occurred". It's really frustrating because I can't inform Apple of bugs they have in both iOS6 and iTunes 10.7, neither of which seem to have been posted elsewhere :-( Is there anybody out there who is able to post to Apple who could help me out?
markinsd is offline   0 Reply With Quote
Old Nov 5, 2012, 09:17 AM   #8
wdog119
macrumors newbie
 
Join Date: Jun 2010
I am also unable to login to apple discussion. iTunes and App Store work just fine with my apple id. I get the "uknown error has occurred" message with discussion. This is really frustrating. Has anyone called apple? I'm going to when I get off work later tonight.
wdog119 is offline   0 Reply With Quote
Old Nov 6, 2012, 07:22 AM   #9
ConvertApple
macrumors newbie
 
Join Date: Oct 2012
Yes, I cannot log in either, it's been like this for weeks. I tried to create a new apple ID and even that wouldn't work. Given you need to use an apple id to use their products what on earth is going on?

Last edited by ConvertApple; Nov 6, 2012 at 07:58 AM.
ConvertApple is offline   0 Reply With Quote
Old Nov 25, 2012, 07:07 AM   #10
benjasmine
macrumors newbie
 
Join Date: Nov 2012
I just found a solution that worked for me.

When you are asked to login, instead of typing your e-mail address as your Apple ID, type your old username. If you don't remember having one, try guessing it.

Credit goes to Siobhanish in Apple Support Communities. I had to log out of Apple Support Communities in order to view the post...
https://discussions.apple.com/message/19410382#19410382

Update:
If the solution doesn't work, view post #15 and #16 here:
http://forums.macrumors.com/showthread.php?t=1307516

Last edited by benjasmine; Nov 25, 2012 at 07:31 AM.
benjasmine is offline   2 Reply With Quote
Old Dec 15, 2012, 08:30 AM   #11
manjuriana
macrumors newbie
 
Join Date: Dec 2012
Im having the exact same issue, it is fine for me to log into iTunes and buys stuff, I can log into my apple ID section to see my devices and my details, but when trying to access support area of the apple.com i get asked to enter my log in details again for added security and then get a message that an unknown error has occured. Called apple support and they first said that "apple.com does not require a log in" and after I pointed out where the log in is the guy said "I would not even know where to begin to look for a solution". That says it all.

I was a happy apple user for the last 6 years, but I am seriously getting fed up with the crap support, bad updates that bring a variety of bugs with them and hours spent trying to fix things that get messed up.

Now I cannot even access to boards to look for solutions, because as someone else mentioned here even when I click on the link to the topic in Google it still asks me to log in and then promptly says that an unknown error has occurred.

Rage.

Oh, and unfortunately none of the solutions listed here helped me. Glad they worked for some of you though.
manjuriana is offline   1 Reply With Quote
Old Feb 10, 2013, 05:05 PM   #12
politicaljules
macrumors newbie
 
Join Date: Feb 2013
Quote:
Originally Posted by benjasmine View Post
I just found a solution that worked for me.

When you are asked to login, instead of typing your e-mail address as your Apple ID, type your old username. If you don't remember having one, try guessing it.

Credit goes to Siobhanish in Apple Support Communities. I had to log out of Apple Support Communities in order to view the post...
https://discussions.apple.com/message/19410382#19410382

Update:
If the solution doesn't work, view post #15 and #16 here:
http://forums.macrumors.com/showthread.php?t=1307516
NONE of this is working for me. I am fixing to scream.
politicaljules is offline   0 Reply With Quote
Old May 20, 2013, 01:34 PM   #13
blatopilot
macrumors regular
 
Join Date: Sep 2011
Not sure if this will help, but have you tried deleting your browsers cookies, quitting the browser and trying again?

Or use a different browser? I've had this problem and I seem to recall cleaning the cache and cookies fixed the problem. Still a stupid work around, but...
blatopilot is offline   0 Reply With Quote
Old Jul 19, 2013, 12:19 PM   #14
brdeveloper
macrumors 68000
 
brdeveloper's Avatar
 
Join Date: Apr 2010
Location: Brasil
I was having the same issue. I was trying to log in through Chrome and Firefox. I tried a few times in Safari after cleaning its cache, then I could get into the community forums.
__________________
15" rMBP Early-2013, 2.4GHz. After 3 display replacements, I'm still seeing uniformity problems.
2009 Unibody White MacBook, 250GB 840 EVO SSD, 8GB
Mid-2010 MacMini, 480GB Crucial M500 SSD, 16GB
brdeveloper is offline   0 Reply With Quote
Old Sep 8, 2013, 07:32 PM   #15
Justin Stuart
macrumors newbie
 
Join Date: Mar 2013
I cannot access Apple Support Communities anymore.

If I enter my old username, I get this:

"This username "xxxxxxx" is already taken, please choose another. Another has been provided."

If I enter a random username, I get this:

"An account utilizing this email address already exists. Only one account per email address is allowed on Apple Support Communities."

Calling Apple Support on the phone has proven to be useless.

Any suggestions?
Justin Stuart is offline   0 Reply With Quote
Old Feb 5, 2014, 07:14 AM   #16
eyeangle
macrumors member
 
Join Date: Jan 2014
solved!

Quote:
Originally Posted by benjasmine View Post
I just found a solution that worked for me.

When you are asked to login, instead of typing your e-mail address as your Apple ID, type your old username. If you don't remember having one, try guessing it.

Credit goes to Siobhanish in Apple Support Communities. I had to log out of Apple Support Communities in order to view the post...
https://discussions.apple.com/message/19410382#19410382

Update:
If the solution doesn't work, view post #15 and #16 here:
http://forums.macrumors.com/showthread.php?t=1307516
Saved my life, thanks! Turns out I had another account from 8 years ago, so I took a lucky guess and bam! logged in. I wonder if I can merge the two accounts now?
eyeangle is offline   0 Reply With Quote
Old Mar 3, 2014, 07:33 AM   #17
Paul Henry
macrumors newbie
 
Join Date: Oct 2009
Crazy!

I know my Apple ID (though Apple have made me change it far too many times).

I know my Forums username.

But I still can't log in.

And as for trying to contact Apple...
Paul Henry is offline   0 Reply With Quote
Old Mar 5, 2014, 11:19 AM   #18
satcomer
macrumors 601
 
satcomer's Avatar
 
Join Date: Feb 2008
Location: Upstate NYS
Did you check your iCloud account at Apple - My Apple ID yet?
__________________
Mac Pro Dual 2.8 Quad(Rev B.), 16 G RAM, OS X 10.9, 23'' LCD
Mac Book Pro Core 2 Duo 2.16Ghz, SuperDrive, 2G RAM, OS X 10.7.5
iPad 3, 32 black
satcomer is online now   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Apple Support Communities. Really? GunnarC Apple, Industry and Internet Discussion 3 May 17, 2014 12:57 PM
Resolved: How I fixed my Apple Support Communities sign-in problems buzzmo Mac Basics and Help 0 Feb 10, 2014 12:35 PM
Can't log into Apple support forums LoneWolf121188 Mac Basics and Help 0 Dec 11, 2012 08:54 PM
Locked Out of Apple Communities jbarone Mac Basics and Help 1 Oct 27, 2012 07:15 PM
I can't log into Power Support site?? trlyka iPhone Accessories 1 Sep 25, 2012 12:23 AM

Forum Jump

All times are GMT -5. The time now is 05:14 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC