Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Applications > Mac Applications and Mac App Store

Reply
 
Thread Tools Search this Thread Display Modes
Old May 21, 2006, 09:00 PM   #1
cmm
macrumors 6502a
 
Join Date: Apr 2006
Location: Cambridge, MA
Can't add words to Microsoft Word

Any ideas? It's greyed out. I need to fix this!

SOLUTION:

Go to Preferences -> Spelling & Grammar.

Then click the checkbox.

Hope this helps!

Last edited by cmm; Dec 2, 2010 at 12:17 PM. Reason: [SOLVED]
cmm is offline   0 Reply With Quote
Old May 21, 2006, 09:18 PM   #2
ero87
macrumors 65816
 
ero87's Avatar
 
Join Date: Jan 2006
Location: New York City
funny i had the same issue the other day - a quick restart of the program fixed it.

But it could also be that your custom dictionary (i.e. words you add) is full. I'm not sure how to fix that though..
ero87 is offline   0 Reply With Quote
Old May 21, 2006, 09:58 PM   #3
cmm
Thread Starter
macrumors 6502a
 
Join Date: Apr 2006
Location: Cambridge, MA
Quote:
Originally Posted by ero87
funny i had the same issue the other day - a quick restart of the program fixed it.

But it could also be that your custom dictionary (i.e. words you add) is full. I'm not sure how to fix that though..
I tried a restart, but still, same problem. Could I delete the Microsoft User Data stuff in ~/Documents and then see if that fixes it?
cmm is offline   0 Reply With Quote
Old May 23, 2006, 04:11 PM   #4
cmm
Thread Starter
macrumors 6502a
 
Join Date: Apr 2006
Location: Cambridge, MA
Anyone!?! Please help. Deleting Microsoft User Data did nothing!
cmm is offline   0 Reply With Quote
Old May 23, 2006, 04:32 PM   #5
mkrishnan
Moderator emeritus
 
mkrishnan's Avatar
 
Join Date: Jan 2004
Location: Grand Rapids, MI, USA
For what it's worth, the custom dictionary isn't located there. The default custom dictionary is:

~/library/preferences/microsoft/custom dictionary

But now then... Go to Preferences -> Spelling & Grammar. Make sure that something is selected under Custom Dictionary. If not, click on the Dictionaries button and either try to find and add the file listed above, or make a new custom dictionary.
__________________
Mohan
mkrishnan is offline   0 Reply With Quote
Old May 23, 2006, 04:38 PM   #6
cmm
Thread Starter
macrumors 6502a
 
Join Date: Apr 2006
Location: Cambridge, MA
Aaah, thank you!
cmm is offline   0 Reply With Quote
Old May 23, 2006, 05:28 PM   #7
mkrishnan
Moderator emeritus
 
mkrishnan's Avatar
 
Join Date: Jan 2004
Location: Grand Rapids, MI, USA
Thank you, as in it worked?

If something I said fixed your problem, or if you otherwise solved your problem, can you please post what you did, so that other people can use it in the future if they have the same issue? Thank you!
__________________
Mohan
mkrishnan is offline   0 Reply With Quote
Old May 23, 2006, 05:52 PM   #8
cmm
Thread Starter
macrumors 6502a
 
Join Date: Apr 2006
Location: Cambridge, MA
Yup, it worked by this:

Go to Preferences -> Spelling & Grammar.

Then click the checkbox.

Hope this helps!
cmm is offline   0 Reply With Quote
Old May 23, 2006, 05:53 PM   #9
mkrishnan
Moderator emeritus
 
mkrishnan's Avatar
 
Join Date: Jan 2004
Location: Grand Rapids, MI, USA
Nice, now you can get back to blinding productivity!
__________________
Mohan
mkrishnan is offline   0 Reply With Quote
Old Jun 18, 2008, 06:17 PM   #10
macFan101
Banned
 
Join Date: May 2008
I also have the problem of adding words to Custom Dictionary. Mine is still greyed out, after creating a new one and adding it to the custom dictionaries list in Word prefs->Spelling & Grammar. I chose English (UK) for Custom Dictionary.

Anybody have any ideas?
macFan101 is offline   0 Reply With Quote
Old Aug 25, 2008, 06:27 PM   #11
macfanatic29
macrumors newbie
 
Join Date: Jan 2008
thanks

THANK YOU! i can't believe it worked for once. I usually come to this site for help and i'm disappointed when these remedies fail. But thanks for the help.
macfanatic29 is offline   0 Reply With Quote
Old Sep 2, 2008, 03:25 AM   #12
mikitukka
macrumors newbie
 
Join Date: Jun 2008
Try to make more sense

i wish this thread was more current. Cause CMM makes no sence
mikitukka is offline   0 Reply With Quote
Old Mar 23, 2009, 05:45 AM   #13
Sevenchild
macrumors newbie
 
Join Date: Mar 2009
Works like a charm!

Tools> Spelling and Grammar> Options>
1. Uncheck "Suggest from main dictionary only"
2. Click "Dictionaries" > check "custom dictionary" > click "ok".

Done!
Sevenchild is offline   0 Reply With Quote
Old Apr 13, 2009, 02:30 AM   #14
dramov
macrumors newbie
 
Join Date: Apr 2009
thank you for the answer - here works great !
dramov is offline   0 Reply With Quote
Old Jul 3, 2009, 12:38 AM   #15
shelleyfrank
macrumors newbie
 
Join Date: Apr 2008
Here's what I found: The Custom Dictionary needs to be checked as English(US) for the add option to work. I'm not sure why but I think it is because the native mac dictionary is US English by default. In the UK it is a constant problem among mac users. I had my custom dictionary set as English (UK) all the time and couldn't figure out why I can't add a simple word like colour to it. So I changed the cust dict language to English (US) and the add option came on. Alternatively you can set the custom dictionary language to (none) and it will work just the same.
shelleyfrank is offline   1 Reply With Quote
Old Sep 20, 2009, 03:00 AM   #16
riverteeth
macrumors newbie
 
Join Date: Apr 2008
I never had this problem until today, when I decided to try turning off the "check spelling as you type" feture. Now, as others have described, "add" is greyed out when I preform the spell check / also when I re-enable "check spelling as you type."

I made sure that Custom dictionary was checked, and that my language was US English. I can even open up my custom dictionary and see all the words I've added over the last year. But for some reason, when I run the spell check now, I get a message that reads: "The custom dictionary 'Custom Dictinoary' is not available." What gives?
riverteeth is offline   0 Reply With Quote
Old Dec 2, 2009, 04:19 PM   #17
jimcil
macrumors newbie
 
Join Date: Nov 2008
riverteeth, I had the same error. Change the language to "(none)" at the very top of the list. That fixed the error for me and I was able to add words.
jimcil is offline   0 Reply With Quote
Old May 17, 2010, 07:23 PM   #18
altomic
macrumors newbie
 
Join Date: Aug 2007
it worked

yes, the suggestion by mkrishan worked. thanks mohan.

that had been so incredibily fustrating.
altomic is offline   0 Reply With Quote
Old Dec 2, 2010, 05:10 AM   #19
grp57
macrumors newbie
 
Join Date: Dec 2010
Thanks for suggesting that fix....it worked for me

This bug of having the Add greyed out has been plaguing me off and on for some time. Thanks for taking the time to post that solution!!!
grp57 is offline   0 Reply With Quote
Old Dec 2, 2010, 12:17 PM   #20
cmm
Thread Starter
macrumors 6502a
 
Join Date: Apr 2006
Location: Cambridge, MA
Quote:
Originally Posted by grp57 View Post
This bug of having the Add greyed out has been plaguing me off and on for some time. Thanks for taking the time to post that solution!!!
Glad it helped.
cmm is offline   0 Reply With Quote
Old Jan 29, 2011, 07:57 AM   #21
ethanjrt
macrumors newbie
 
Join Date: Jan 2011
Thanks for the explanation, Sevenchild. Worked like a charm; "Mohism" is now officially a word as far as this computer's copy of Microsoft Office is concerned.

Speaking of which, I'm curious what words YOU all were trying to add... I think it would make a funny thread to get a list going.
ethanjrt is offline   0 Reply With Quote
Old Mar 16, 2011, 05:48 AM   #22
Flopsy007
macrumors newbie
 
Join Date: Mar 2011
It works like this (Word 2011):

1. You can place your custom dictionary anywhere (works great in Dropbox for use on several computers

2. Go to Spelling & Grammar > Dictionaries to get to the window called "custom Dictionaries". Here you can create a new dictionary anywhere on your computer and choose which custom dictionaries are active. The 'Language' option here associates that particular custom dictionary with a language of your choice. Select (none) to be able to use it with any language.

3. NOW THIS IS WHAT BUGS A FEW PEOPLE I THINK!
If you have associated your custom dictionary to fx 'English (UK)', then the document language must also be set to 'English (UK)', otherwise your custom dictionary is not active (and the Add button is grayed out). So in this case mark all your text (Cmd+a), go to Tools > Language and select 'English (UK)'.

4. To be able to edit/modify a custom dictionary e.g. add/remove words manually, that particular custom dictionary must not be in use by the document. So if your having problems modifying your custom dictionary you can close your document, create a New Blank Document and make sure the language are set to another language than your custom dictionary is associated to. Then you should be able to edit the custom dictionary.

This worked for me and I hope it helps a few people
Flopsy007 is offline   1 Reply With Quote
Old Mar 26, 2011, 06:41 PM   #23
Sourcherries
macrumors newbie
 
Join Date: Mar 2011
thank you!

Jimcil and Flopsy007, both of those suggestions worked.
Thank you so much, this issue has plagued me, too!!
Sourcherries is offline   0 Reply With Quote
Old Apr 27, 2011, 04:12 PM   #24
BSH01
macrumors newbie
 
Join Date: Apr 2011
Thanks

This has at last solved an ongoing frustration.
BSH01 is offline   0 Reply With Quote
Old May 16, 2011, 02:33 AM   #25
gumdrops
macrumors newbie
 
Join Date: May 2011
Finally a solution!

Quote:
Originally Posted by shelleyfrank View Post
Here's what I found: The Custom Dictionary needs to be checked as English(US) for the add option to work. I'm not sure why but I think it is because the native mac dictionary is US English by default. In the UK it is a constant problem among mac users. I had my custom dictionary set as English (UK) all the time and couldn't figure out why I can't add a simple word like colour to it. So I changed the cust dict language to English (US) and the add option came on. Alternatively you can set the custom dictionary language to (none) and it will work just the same.
I have been trying to figure out why my Word dictionary won't let me add words for over a year! And it turns out it was the simplest of things - I had changed my dictionary to English (AUS). Upon changing it back to English (US) I have been able to add words.

I can't begin to explain how relieved I am to have found an answer, it is so frustrating to constantly have to 'ignore all' Australian spelling of words because I couldn't add them to the dictionary! So thank you!
gumdrops is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Applications > Mac Applications and Mac App Store

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
New app: Go Word - for Microsoft Word Edition & Open Office Format txsoft Mac Applications and Mac App Store 0 Nov 20, 2013 11:36 PM
General: Quick way to add words to Shortcuts? 3bs Jailbreaks and iOS Hacks 4 Feb 23, 2013 04:53 PM
Superimpose words on a photo usimg word 2008 and snow leopard charlesquetta MacBook 2 Feb 17, 2013 08:21 PM
Tower of words (mix between Jenga and find a word) FREE jswiney iPhone and iPod touch Apps 0 Jan 25, 2013 08:55 PM
Road Words - (Type words while dodging traffic!) [FREE] jswiney iPhone and iPod touch Apps 0 Dec 12, 2012 04:15 PM

Forum Jump

All times are GMT -5. The time now is 02:00 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC