Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Reply
 
Thread Tools Search this Thread Display Modes
Old Jun 30, 2007, 07:37 PM   #1
longofest
Editor emeritus
 
longofest's Avatar
 
Join Date: Jul 2003
Location: Falls Church, VA
Send a message via AIM to longofest
iPhone Bugs

Use this thread for posting bugs that you believe you have found. Bugs only please. Save feature requests and usability issues for another thread, as well as other comments.

Also, when a bug is confirmed by multiple people, it will be marked as such by the moderators. There is no need to post "me too" comments to confirmed bugs.

We want to keep this thread readable for people looking to see if their issue has been identified as a bug.

NOTE: Developers of course should use Apple's BugReport system.

Last edited by longofest; Jul 12, 2007 at 01:35 AM.
longofest is offline   0 Reply With Quote
Old Jun 30, 2007, 07:45 PM   #2
longofest
Thread Starter
Editor emeritus
 
longofest's Avatar
 
Join Date: Jul 2003
Location: Falls Church, VA
Send a message via AIM to longofest
Bluetooth bug

bug #1: you have a bluetooth device paired and you elect to use the iphone's builtin sound source. if you go out of range and then back into range of the headset during the call, the sound will start playing from the bt headset automatically, even though you have selected the iphone as your sound device.
longofest is offline   0 Reply With Quote
Old Jun 30, 2007, 08:05 PM   #3
cp2222
macrumors member
 
Join Date: May 2006
Voicemail greeting problem

I clicked to record a voicemail greeting -- recorded one, but then left this screen by hitting home. When I came back later I could not record a greeting. Although the 'Record' button was active, upon click it would not start recording no matter what I did with the phone. In addition, if you clicked 'Play' it would say 'No greeting has been recorded'. I tried every function on this page and left and came back several times with no avail. Shutting down and turning back on iPhone allowed me to record again and it worked.
cp2222 is offline   0 Reply With Quote
Old Jun 30, 2007, 08:52 PM   #4
FreeState
macrumors 68000
 
FreeState's Avatar
 
Join Date: Jun 2004
Location: San Diego, CA
Can't change email reply to address

You cant change which email account you are using to send a reply email (i.e. forwarded email received via .mac can not be replied to using the original email address the sender used.)
FreeState is offline   0 Reply With Quote
Old Jun 30, 2007, 09:32 PM   #5
Pine-Tree
macrumors member
 
Join Date: Sep 2005
Location: Arizona, USA
Smart playlists not working??

It could just be me (cause I haven't seen anything yet), but it seems that smart playlists are all messed up and simply don't work. The only smart playlist that I have is 'top 25', so last night while I was listening to some music, I went to that playlist on my iphone but the songs are not the same at all. I thought maybe I changed something, but sure enough on my itunes 'top 25' is still the same. I couldn't figure out why it was showing up with random songs on my phone. So I created a new one with different settings, and again the songs on my laptop were not the same at all on my phone. Anyone else have the same issues??

Abe

Last edited by longofest; Jul 10, 2007 at 07:37 PM. Reason: maybe not confirmed.. needs more investigation
Pine-Tree is offline   1 Reply With Quote
Old Jun 30, 2007, 11:30 PM   #6
copland007
macrumors member
 
Join Date: Jun 2007
Quote:
Originally Posted by abi View Post
It could just be me (cause I haven't seen anything yet), but it seems that smart playlists are all messed up and simply don't work. The only smart playlist that I have is 'top 25', so last night while I was listening to some music, I went to that playlist on my iphone but the songs are not the same at all. I thought maybe I changed something, but sure enough on my itunes 'top 25' is still the same. I couldn't figure out why it was showing up with random songs on my phone. So I created a new one with different settings, and again the songs on my laptop were not the same at all on my phone. Anyone else have the same issues??

Abe
I noticed the same thing actually...
copland007 is offline   0 Reply With Quote
Old Jun 30, 2007, 11:36 PM   #7
cliffhopper
macrumors newbie
 
Join Date: Jun 2007
iPod and Safari Crashes

when ipod is playing and you browse the web, ipod stops playing after about a minute. does not matter if you are using wifi or edge.

Safari crashes randomly, happened twice while trying to acces this forum actually.

longofest edit: confirmed bug

Last edited by longofest; Jul 10, 2007 at 07:31 PM.
cliffhopper is offline   0 Reply With Quote
Old Jul 1, 2007, 03:52 AM   #8
voidptr
macrumors regular
 
Join Date: Jan 2007
A consistient mail crash with my IMAP account.

No way to reorder items in stocks or weather. Clocks you can drag and drop easily.

Last edited by longofest; Jul 10, 2007 at 07:31 PM. Reason: deletion of confirmed bug report
voidptr is offline   0 Reply With Quote
Old Jul 1, 2007, 11:52 AM   #9
Novataglio
macrumors newbie
 
Join Date: Apr 2007
I'm not sure if this is an iPhone mail bug or an issue with gmail but when I setup my gmail account and told it to download a preview of the latest 25 emails, two of them were ones I had sent and were not in my Inbox. I looked around for an option or something that would explain that behavior but couldn't find one. I thought maybe it has to do with how Gmail does emails "conversation" wise but am not sure.

Other than that my signal to the network seems to fluctuate quite a bit even while in the same room which never happened with my Razr. It might just be more sensitive and accurate or I might be in for more dropped calls than before!
Novataglio is offline   0 Reply With Quote
Old Jul 1, 2007, 12:16 PM   #10
kyRx
macrumors newbie
 
Join Date: Jun 2007
Wireless vs. Edge

Mine has problems connecting, or defaulting, to my home wireless network. Most of the browsing, actually all my web browsing to date has been over the Edge network. I set up the wireless correctly and it is "checked " as my preferred network, but the phone never defaults when browsing or checking e-mail.

The wireless router is D-link 802.11g/2.4 GHz. Next I'm gonna try my airport base station and see what happens.
kyRx is offline   0 Reply With Quote
Old Jul 1, 2007, 03:03 PM   #11
hueyproductions
macrumors member
 
Join Date: Jun 2007
my bugs

yahoo and gmail mail setups still have not worked
google maps crashing

Last edited by longofest; Jul 10, 2007 at 07:34 PM. Reason: deletion of confirmed bug reports
hueyproductions is offline   0 Reply With Quote
Old Jul 1, 2007, 03:57 PM   #12
Rolo22
macrumors newbie
 
Join Date: Jul 2007
Smart playlists

I have been having the same problem with smart playlists and called apple support- their answer was, and I quote, that iphone does not support smart playlists at this time, and I should created folders... Can't wait for the update
Rolo22 is offline   0 Reply With Quote
Old Jul 1, 2007, 04:38 PM   #13
Xero
macrumors 6502
 
Join Date: Dec 2002
Location: Los Angeles
I'm also having issues with mail. I have three gmail accounts set up, and they all go and load the 25 most recent messages or whatever ive specified. Problem is, they load up as being new emails. So i start out having 90 or so "new emails" all of which ive read, or already deleted in Mail (although they probably havent been deleted from the gmail archive)

This seems sort of odd, and the account options seem pretty limited in ways the app downloads mail.

I'm also having the same issue an above poster is having with emails sent from the phone showing up in that accounts inbox on the phone as well...
Xero is offline   0 Reply With Quote
Old Jul 1, 2007, 04:49 PM   #14
stomachdoc
macrumors member
 
Join Date: Jul 2004
Location: Outside of Boston
Bluetooth Issue

In my '07 BMW 5 series, during the first few moments of a call in BT through the BMW system, the audio cuts in and out, and then it stabilizes and is fine. Wasn't a problem with my Treo 650 and the BMW, which the iPhone replaced. Integration with menus, voice dialing is flawless.
stomachdoc is offline   0 Reply With Quote
Old Jul 1, 2007, 04:58 PM   #15
faustfire
macrumors 6502a
 
faustfire's Avatar
 
Join Date: Jul 2002
Location: California
Try powering down to fix the random app crashes.
faustfire is offline   0 Reply With Quote
Old Jul 1, 2007, 05:08 PM   #16
joekix
macrumors 6502
 
Join Date: Feb 2007
Location: earth, long beach CA to be exact
Quote:
Originally Posted by stomachdoc View Post
In my '07 BMW 5 series, during the first few moments of a call in BT through the BMW system, the audio cuts in and out, and then it stabilizes and is fine. Wasn't a problem with my Treo 650 and the BMW, which the iPhone replaced. Integration with menus, voice dialing is flawless.
noticed the same in my sister's '06, 3 series. didn't happen with her razr
__________________
11.6" MBA ultimate 1.6 ghz 4gb 128gb
17" iMac g4 1.25 ghz 1.25gb 80gb
27" iMac 2.7 ghz 16gb 1tb
13" MacBook 2.2 ghz 4gb 250gb
joekix is offline   0 Reply With Quote
Old Jul 1, 2007, 05:43 PM   #17
ctakim
macrumors 6502
 
Join Date: Oct 2006
Exchange access via internet

Safari can't log into Outlook Exchange Email via the internet. It asks for the login name and password, but then hangs up. Tried this on two separate accounts with the same result. Safari on my MBP does not have this problem.
ctakim is offline   0 Reply With Quote
Old Jul 1, 2007, 05:48 PM   #18
elistan
macrumors 6502a
 
Join Date: Jun 2007
Location: Denver/Boulder, CO
Wifi not working properly. If the phone has been in standby mode for a while, I can browse using my Airport Extreme without issue. However, after a short period (one or two minutes) I can no longer get data over wifi. If I then go to the Network Setup screen, I can't even list wireless networks (normally I see three or four.) I noticed that at the same time this happens, the phone gets noticeably hot. I'm wondering if this is a hardware bug - the wifi chip failing when it gets too hot. (I haven't attempted browsing from my fridge just yet. )
elistan is offline   0 Reply With Quote
Old Jul 1, 2007, 05:54 PM   #19
codyclark
macrumors newbie
 
Join Date: Jun 2007
Location: Center, TX
Send a message via AIM to codyclark Send a message via Skype™ to codyclark
Quote:
Originally Posted by elistan View Post
Wifi not working properly. If the phone has been in standby mode for a while, I can browse using my Airport Extreme without issue. However, after a short period (one or two minutes) I can no longer get data over wifi. If I then go to the Network Setup screen, I can't even list wireless networks (normally I see three or four.) I noticed that at the same time this happens, the phone gets noticeably hot. I'm wondering if this is a hardware bug - the wifi chip failing when it gets too hot. (I haven't attempted browsing from my fridge just yet. )
I am now experiencing the same problem you described. Any resolution??
__________________
iMac 2011 27" Quad i5 2.7GHz
32GB iPhone 4
Twitter.com/codyclark
http://www.codyclark.org
codyclark is offline   0 Reply With Quote
Old Jul 1, 2007, 05:56 PM   #20
Lionheart
macrumors regular
 
Join Date: Jun 2007
Location: Tampa, FL
HTML Email Rendering Issue

I noticed on two HTML mailing list emails that I received (Constant Contact) would not display properly. Only the left half of the email in the body displayed, and the right was blank, cutting off all graphics and text. The footer, however was displayed properly across the entire screen.

Strange.
Lionheart is offline   0 Reply With Quote
Old Jul 1, 2007, 08:10 PM   #21
Tommyg117
macrumors 6502a
 
Tommyg117's Avatar
 
Join Date: Sep 2005
Location: Philadelphia, PA
My battery life doesn't seem too good. Also, the talk volume coming out of the earpiece is pretty soft. Do you think all of the problems in this thread can be fixed with a software patch?
__________________
-15" Powerbook G4, 1.5ghz, 1.25 GB Ram, 80 gb HD, Superdrive, Airport Extreme.
-60 gig 5G iPod (black!)
-Airport Basestation
Tommyg117 is offline   1 Reply With Quote
Old Jul 1, 2007, 08:57 PM   #22
kyRx
macrumors newbie
 
Join Date: Jun 2007
My iPhone froze when using maps

Had to reset (sleep/wake + home). Everything OK now.
kyRx is offline   0 Reply With Quote
Old Jul 1, 2007, 09:07 PM   #23
appleii2mac
macrumors regular
 
Join Date: May 2007
Quote:
Originally Posted by Rolo22 View Post
I have been having the same problem with smart playlists and called apple support- their answer was, and I quote, that iphone does not support smart playlists at this time, and I should created folders... Can't wait for the update
I have smart playlists on my iPhone. Although they are very simple (rating >=4) . But they seem to work.
appleii2mac is offline   0 Reply With Quote
Old Jul 2, 2007, 12:13 AM   #24
runninmac
macrumors 65816
 
runninmac's Avatar
 
Join Date: Jan 2005
Location: Rockford MI
My Wi-Fi won't option is grayed out and wont even let me chose a network

ps: I was using my iPhone on this network earlier today
__________________
2.0 Ghz CoreDuo. 2 GB Ram. 80 Gig HDD.
Black MacBook
runninmac is offline   0 Reply With Quote
Old Jul 2, 2007, 12:42 AM   #25
Big Slick
macrumors newbie
 
Join Date: Jun 2007
Windows XP and its new-hardware installer try to recognize iPhone as a camera when there are photos in the Camera Roll. Then, Windows crashes into the blue screen of death with an error message 0x0000007e blahblahblah. When there are no photos in the Camera Roll, Windows doesn't crash, and iTunes opens the phone normally.
Big Slick is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
iPhone: Iphone 5 Evasi0n 7.0.4 Cydia Tweak issues/bugs briang1-2-3 Jailbreaks and iOS Hacks 1 Jan 5, 2014 08:34 PM
iPhone: Jailbreak Bugs for iPhone 5 NovemberWhiskey Jailbreaks and iOS Hacks 16 Mar 16, 2013 06:23 PM
iPhone 5 Group Text Won't Send or Receive (and various other bugs) Waflsk8s iPhone Tips, Help and Troubleshooting 2 Dec 22, 2012 01:07 PM
Possible iPhone 5 battery bugs? Ibtechsavvy iPhone 1 Dec 17, 2012 03:12 PM
10.8 Bugs Xcallibur OS X 10.8 Mountain Lion 5 Jul 28, 2012 10:55 AM

Forum Jump

All times are GMT -5. The time now is 10:02 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC