Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Special Interests > Visual Media > Design and Graphics

Reply
 
Thread Tools Search this Thread Display Modes
Old Dec 17, 2007, 06:52 AM   #1
::Lisa::
macrumors 6502a
 
::Lisa::'s Avatar
 
Join Date: Oct 2007
Location: Nottingham, UK
Fonts Missing (Installed but not displaying in Photoshop)

Hi all,

I'm having a problem with a font that I have installed. I installed it fine yesterday and it is showing absolutely fine in 'Font Book' and states it is installed but when I open Photoshop CS3 it is not there at all

I have taken a screen cap that shows Font Book displaying it, but CS3 doesn't. You can view that here: http://lisacleverley.com/temp/fontsmissing.jpg (310KB file size for 56k users)

As you can see by the screen cap I've installed custom fonts before and they've all been OK installing and viewing/using in CS3. Not sure why this is happening. Does anyone know how to fix it?

Thanks for reading,
-Lisa
__________________
Lisa likes to get nekkid! Meeting at Regent St Apple store sOOn
::Lisa:: is offline   0 Reply With Quote
Old Dec 17, 2007, 06:56 AM   #2
xUKHCx
Administrator emeritus
 
xUKHCx's Avatar
 
Join Date: Jan 2006
Location: The Kop
What happens when you go to Validate fonts in font book. To do this select all the fonts and go File - Validate Fonts.
xUKHCx is offline   0 Reply With Quote
Old Dec 17, 2007, 08:41 AM   #3
::Lisa::
Thread Starter
macrumors 6502a
 
::Lisa::'s Avatar
 
Join Date: Oct 2007
Location: Nottingham, UK
Quote:
Originally Posted by xUKHCx View Post
What happens when you go to Validate fonts in font book. To do this select all the fonts and go File - Validate Fonts.
Sorry I forgot to mention that I've already done that and it said they were all fine.

It states.. "No problems were found validating these fonts." I've tried restating the computer and all, re-installing them etc to no avail.
__________________
Lisa likes to get nekkid! Meeting at Regent St Apple store sOOn
::Lisa:: is offline   0 Reply With Quote
Old Dec 17, 2007, 09:08 AM   #4
iGav
macrumors G3
 
Join Date: Mar 2002
Have you tried... Photoshop>Preferences>Type>Show Asian Text Options?
iGav is offline   0 Reply With Quote
Old Dec 17, 2007, 11:02 AM   #5
::Lisa::
Thread Starter
macrumors 6502a
 
::Lisa::'s Avatar
 
Join Date: Oct 2007
Location: Nottingham, UK
Quote:
Originally Posted by iGav View Post
Have you tried... Photoshop>Preferences>Type>Show Asian Text Options?
Just tried that and they're still not showing. I quit Photoshop and restarted it. I'm really stumped. The font I'm trying to use is "Kosuka Gothic Pro". Maybe I could send it to see if anyone else has the same problem? *shrug*
__________________
Lisa likes to get nekkid! Meeting at Regent St Apple store sOOn
::Lisa:: is offline   0 Reply With Quote
Old Dec 17, 2007, 11:31 AM   #6
JasonElise1983
macrumors 6502a
 
JasonElise1983's Avatar
 
Join Date: Jun 2003
Location: Between a rock and a midget
sorry, i hate to ask this questions, but did you make sure that the font is activated in FontBook? Did you try deactivating it and then re-activating it? I really don't know either. You can send me whatever font you want and i can try.

-JE
JasonElise1983 is offline   0 Reply With Quote
Old Dec 17, 2007, 12:28 PM   #7
bluetooth
macrumors 6502a
 
bluetooth's Avatar
 
Join Date: May 2007
Location: Toronto
This has happened to me before with a couple fonts.

You could try opening up in AI and ID and see if they appear in those Apps as well. When I had issues, one of the fonts showed up in AI but not PS or ID. It could be a PC specific font...not sure what to suggest because I never figured it out myself and it has only happened twice with me.

Where did you download the font from and is it .ttf format?
__________________
"Design is my day-long obsession, joy and torment."
bluetooth is offline   0 Reply With Quote
Old Dec 17, 2007, 12:48 PM   #8
::Lisa::
Thread Starter
macrumors 6502a
 
::Lisa::'s Avatar
 
Join Date: Oct 2007
Location: Nottingham, UK
Quote:
Originally Posted by JasonElise1983 View Post
sorry, i hate to ask this questions, but did you make sure that the font is activated in FontBook? Did you try deactivating it and then re-activating it? I really don't know either. You can send me whatever font you want and i can try.

-JE
Thanks but iGav has helped me in email and show me, although it's appearing in the asian fonts at the bottom.. even though it's not an asian font hmm.

Quote:
Originally Posted by bluetooth View Post
This has happened to me before with a couple fonts.

You could try opening up in AI and ID and see if they appear in those Apps as well. When I had issues, one of the fonts showed up in AI but not PS or ID. It could be a PC specific font...not sure what to suggest because I never figured it out myself and it has only happened twice with me.

Where did you download the font from and is it .ttf format?
It's been fixed now but thanks for replying The font was an OpenType Font (.otf)

--
As I said above iGav has helped me fix this (thaks iGav) although when he sent me a screenshot of where the font was, which was at the bottom shown in the Asian area and even Asian text, but the font isn't Asian at all. There is nothing Asian in it what-so-ever

Is there a way to move it? I realise I'm asking too much now but I don't see why it's down there, strange. Have attached some pics.

First attachment shows what it looks like in photoshop with the weird Asian text symbol 'preview'
Second shows what the actual font style is.

Very strange to say the least!
Attached Thumbnails
Click image for larger version

Name:	kozuka.jpg
Views:	97
Size:	72.5 KB
ID:	94666   Click image for larger version

Name:	kozuka1.jpg
Views:	82
Size:	54.8 KB
ID:	94667  
__________________
Lisa likes to get nekkid! Meeting at Regent St Apple store sOOn
::Lisa:: is offline   0 Reply With Quote
Old Dec 17, 2007, 01:01 PM   #9
iGav
macrumors G3
 
Join Date: Mar 2002
Quote:
Originally Posted by ::Lisa:: View Post
even though it's not an asian font hmm.
Just checked... it is actually.

Go to System Preference>International>Input Menu and change the input method.

Then select the Language Input Menu and change it to Show Japanese Kana Pallette and hey presto...
iGav is offline   0 Reply With Quote

Reply
MacRumors Forums > Special Interests > Visual Media > Design and Graphics

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Photoshop fonts problem cool11 Design and Graphics 20 Mar 4, 2014 04:10 AM
Fonts displaying incorrectly jbardy2 OS X 2 Jan 23, 2013 10:31 AM
Fonts not installing/displaying correctly bluepigster Design and Graphics 9 Nov 30, 2012 04:44 AM
Photoshop Fonts Bennytsmithjr Design and Graphics 4 Oct 24, 2012 09:46 PM
Missing Fonts rauckr OS X 10.8 Mountain Lion 0 Sep 19, 2012 02:28 PM

Forum Jump

All times are GMT -5. The time now is 01:16 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC