Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Reply
 
Thread Tools Search this Thread Display Modes
Old Feb 5, 2008, 09:18 PM   #1
Ozman712
macrumors member
 
Join Date: Mar 2006
Safari/Facebook problems

I am having issues with Facebook on Safari. Over the past few months Facebook does not act correctly when I load it into Safari. The main issues are Safari no longer stores my FB password. I have cleared it from my keychain, but it will not give me a prompt to save it again. Second, when I am logged into my account, the search box's submit button on the top left will not work (it will not recognize it as a button) and this happens throughout various FB pages with other buttons. Lastly, it will log me out and I will relog in and it will not let me log in, it just keeps kicking back to the log in page.

I can open and operate FB in both Firefox and Camino without a problem. I don't know what is causing this. It just happens with FB and no other sites. I do have AdBlock, but this started to happen before I installed that. Any ideas or fixes would be greatly appreciated.

Thanks,
Oz
Ozman712 is offline   0 Reply With Quote
Old Feb 5, 2008, 09:21 PM   #2
kuebby
macrumors 68000
 
kuebby's Avatar
 
Join Date: Jan 2007
Location: Orange County
It's happening to me too, and I have absolutely no idea why. Restarting Safari seems to fix the problem though, at least until the next time.
__________________
Plus ça change, plus c'est la même chose.
2.3 i7 rMBP / 32GB iPhone 5 / 160GB 7G iPod classic / 2G Shuffle
kuebby is offline   0 Reply With Quote
Old Feb 5, 2008, 09:37 PM   #3
Ozman712
Thread Starter
macrumors member
 
Join Date: Mar 2006
Im glad to hear it isn't only me. I hate to restart Safari because I usually have a ton of stuff open and it is a hassle. Plus, it is only temporary at best. Wonder if there are any solutions?
Ozman712 is offline   0 Reply With Quote
Old Feb 5, 2008, 09:41 PM   #4
JML42691
macrumors 68020
 
JML42691's Avatar
 
Join Date: Oct 2007
I do not have a problem with it, are you using the click box to store your password, or having Safari save it.?
JML42691 is offline   0 Reply With Quote
Old Feb 5, 2008, 09:47 PM   #5
Ozman712
Thread Starter
macrumors member
 
Join Date: Mar 2006
I have Safari save it. I know this is probably a pretty isolated problem because I have friends that use Safari and FB with no trouble. I don't know what I could have done though to cause this.
Ozman712 is offline   0 Reply With Quote
Old Feb 5, 2008, 11:34 PM   #6
Ozman712
Thread Starter
macrumors member
 
Join Date: Mar 2006
Problem solved. It was AdBlock after all. Some weird problem with that plugin. I deleted it and it seems to have resolved the issues. Thanks again for all the great input.
Ozman712 is offline   0 Reply With Quote
Old Oct 2, 2008, 12:26 PM   #7
dolonj
macrumors newbie
 
Join Date: Oct 2008
problem using facebook

I have been having problems using FACEBOOK for the last three days. The submit buttons and many buttons for 'reply' etc don't work any more .. I can't leave messages or replies on walls or use the compose message feature because the addresses won't load .. the pages are not loading properly i guess.

I am not much knowledgable about macs .. or pcs in general .. but when I found others had probs with mac and FB I thought maybe I could get some help too.

What is ADBLOCK .. someone achieved some solution with that .. can someone help?

It's making me crazy .. cause I spend so much time at FB and now I have to swicth on my stupid compaq laptop and get onto Firefox to send replies and write messages and on walls .. CRAZY!! I hate all other machines after Mac but it's ditching me BAADD!!
dolonj is offline   0 Reply With Quote
Old Oct 8, 2008, 06:46 PM   #8
i11i1i
macrumors regular
 
Join Date: Jul 2008
I'm not quite sure why this is happening either. I'm having the same problems and I don't have the Adblock plug-in. Anyone else have suggestions?
i11i1i is offline   0 Reply With Quote
Old Dec 1, 2008, 05:49 AM   #9
angira
macrumors newbie
 
Join Date: Dec 2008
(apologies for replying to an old post but it still shows on google)

The problem seems to be Safari's Javascript implementation.

Solution: Use Firefox and be happy or wait for Apple to fix it.

Last edited by angira; Dec 1, 2008 at 05:50 AM. Reason: -
angira is offline   0 Reply With Quote
Old Dec 1, 2008, 11:04 PM   #10
monicapineda
macrumors newbie
 
Join Date: Dec 2008
Problems with facebook

I am having problems with facebook both with safari and firefox. When I log in into facebook, inmediately after my home page is loaded firefox or safari close unexpectedly. This has happened also with "myspace". I don´t know if someone knows what the problem might be and how to fix it.

I´ll appreciatte your help!!
Thanks a lot...
monicapineda is offline   0 Reply With Quote
Old Feb 1, 2009, 01:05 PM   #11
Mac Maniac 9
macrumors newbie
 
Join Date: Feb 2009
Location: Winnipeg, MB, Canada
you don't need to reset everytime, Hit safari preferences and show cookies, remove all the facebook cookies and hit done. This is a temporary fix, but you don't need to reset everything. i'm unsure which cookie(s) actually is the cause of the problem.
Mac Maniac 9 is offline   0 Reply With Quote
Old Feb 1, 2009, 01:27 PM   #12
ikermalli
macrumors 6502a
 
Join Date: Aug 2008
Quote:
Originally Posted by Ozman712 View Post
I am having issues with Facebook on Safari. Over the past few months Facebook does not act correctly when I load it into Safari. The main issues are Safari no longer stores my FB password. I have cleared it from my keychain, but it will not give me a prompt to save it again. Second, when I am logged into my account, the search box's submit button on the top left will not work (it will not recognize it as a button) and this happens throughout various FB pages with other buttons. Lastly, it will log me out and I will relog in and it will not let me log in, it just keeps kicking back to the log in page.

I can open and operate FB in both Firefox and Camino without a problem. I don't know what is causing this. It just happens with FB and no other sites. I do have AdBlock, but this started to happen before I installed that. Any ideas or fixes would be greatly appreciated.

Thanks,
Oz
No, the main issue is that you are not using firefox. Safari is much slower and has many more problems that firefox. I have been using firefox for a VERY long time, I couldn't be happier
__________________
iPhone 4 16 GB Telus Late 2009 MacBook Pro
Save on shipping
ikermalli is offline   0 Reply With Quote
Old Feb 8, 2009, 05:56 AM   #13
soulphonic
macrumors newbie
 
Join Date: Feb 2009
I am also using Safari on a Powerbook G4, 5 days ago problems started with facebook. I am still able to use facebook but each time when I want to invite friends to an event or group my Safari stops working. I also have this same problem using Firefox.

When i look at the graphic of my CPU i notice that everytime u try to invite friends on facebook my CPU goes in red. So it seems that my computer has become to slow from one day to the next day.

Its hard for mee to believe that a powerbook g4 isn't able to load a particular page on facebook ...

I already deleted the cookies but still have the same problem.

Hope someone can help me?

Thanks in advance!
soulphonic is offline   0 Reply With Quote
Old Feb 8, 2009, 08:42 AM   #14
CompactMacUser
macrumors newbie
 
Join Date: Feb 2009
I had similar problems - i just use the Camino browser now for facebook, also found that the chat functionality wasn't happening either.
CompactMacUser is offline   0 Reply With Quote
Old Feb 8, 2009, 09:00 AM   #15
soulphonic
macrumors newbie
 
Join Date: Feb 2009
Ok thanks for the tip, will try with the Camino browser and see what happens!
soulphonic is offline   0 Reply With Quote
Old Feb 27, 2009, 10:17 PM   #16
Anhdru
macrumors newbie
 
Join Date: Feb 2009
You might want to try Flock. It's a Mozilla-based browser that has special tools for Facebook. I've also used Firefox with success, and I'm running a PowerBook G4 too.

I just downloaded Safari 4.0 beta and so far the new rendering engine seems to be handling things pretty well. You might want to give that a try, too.

Camino is a fine browser but it has (documented ) screen rendering problems on 10.4.11. That should get fixed when they get to Camino 2.x.
Anhdru is offline   0 Reply With Quote
Old Jun 1, 2009, 10:00 AM   #17
isethx
macrumors regular
 
Join Date: Aug 2008
i just found this on google. i've been having major issues with facebook lately, it won't ever load or work it's driving me crazy.

actually since 10.5.7 i've been having a lot more issues with my mac, especially with safari and ichat
__________________
17" MBP Unibody 2.93GHz, 4 GB RAM 320GB 7200RPM HD
unboxing video - 17" MBP unibody http://www.youtube.com/watch?v=iNCihPgfkno
isethx is offline   0 Reply With Quote
Old Sep 28, 2009, 11:01 PM   #18
ChuckD1859
macrumors newbie
 
Join Date: Apr 2007
Wow, this is such an old thread...but still the problem persists. For the first time in the last month or so I have been having problems with Safari not clicking on certain links in Facebook. Firefox has no problem with any of them. The following things don't work that worked just fine.

- Inbox - Inbox doesn't load
- Chat - List of friends online doesn't open up (but does display how many are online)
- Accept/Reject friend invitation
- Reply to wall post
- Accept/Reject events

...all sorts of random things.

Am running Safari 4.0.3. on MacOS Snow Leopard 10.6.1

Anyone have a solution?
ChuckD1859 is offline   0 Reply With Quote
Old Sep 29, 2009, 12:02 AM   #19
JML42691
macrumors 68020
 
JML42691's Avatar
 
Join Date: Oct 2007
Quote:
Originally Posted by ChuckD1859 View Post
Wow, this is such an old thread...but still the problem persists. For the first time in the last month or so I have been having problems with Safari not clicking on certain links in Facebook. Firefox has no problem with any of them. The following things don't work that worked just fine.

- Inbox - Inbox doesn't load
- Chat - List of friends online doesn't open up (but does display how many are online)
- Accept/Reject friend invitation
- Reply to wall post
- Accept/Reject events

...all sorts of random things.

Am running Safari 4.0.3. on MacOS Snow Leopard 10.6.1

Anyone have a solution?
I believe almost all of the issues are on facebook's side of the problem.
JML42691 is offline   0 Reply With Quote
Old Sep 29, 2009, 12:55 AM   #20
beala
macrumors member
 
Join Date: Sep 2009
Safari's Saft extension seemed to be causing me problems. After installing Saft, I'd get logged out of FB after a minute or so. Once I removed Saft, everything worked again.
beala is offline   0 Reply With Quote
Old Sep 29, 2009, 01:29 AM   #21
Rampant.A.I.
macrumors 6502a
 
Join Date: Sep 2009
I fixed a lot of the problems I had accessing Facebook by switching to Firefox.
Rampant.A.I. is offline   0 Reply With Quote
Old Nov 3, 2009, 05:38 PM   #22
Kilamite
macrumors G3
 
Kilamite's Avatar
 
Join Date: Mar 2007
Location: Edinburgh, Scotland
I'm having problems - sometimes it'll just load the top bit of the new feed (the menu bar) and nothing else.

Facebook chat hardly ever works either..
__________________
15" MacBook Pro 2GHz i7 8GB 750GB Hybrid | Mac mini 2.3GHz i7 16GB 1TB Fusion | OS X 10.9.2
iPhone 5 64GB | Apple TV 3 1080p | iOS 7.1
Home Theatre Hackintosh i3 3.5GHz 4GB 3TB | OS X 10.9.2
Kilamite is offline   0 Reply With Quote
Old Nov 7, 2009, 10:36 AM   #23
JLB-UK
macrumors regular
 
Join Date: Oct 2009
Location: UK
Quote:
Originally Posted by Kilamite View Post
I'm having problems - sometimes it'll just load the top bit of the new feed (the menu bar) and nothing else.

Facebook chat hardly ever works either..
Have exactly the same problem :-(
__________________
11" MacBook Air | iPhone 4 32GB | 27" iMac | iPad WiFi 32GB
JLB-UK is offline   0 Reply With Quote
Old Nov 11, 2009, 06:11 PM   #24
Kilamite
macrumors G3
 
Kilamite's Avatar
 
Join Date: Mar 2007
Location: Edinburgh, Scotland
Well, the Safari 4.0.4 update released today has sorted all this, and Facebook appears to be working correctly now. Apple noted that there was some JavaScript enhancements/other fixes.
__________________
15" MacBook Pro 2GHz i7 8GB 750GB Hybrid | Mac mini 2.3GHz i7 16GB 1TB Fusion | OS X 10.9.2
iPhone 5 64GB | Apple TV 3 1080p | iOS 7.1
Home Theatre Hackintosh i3 3.5GHz 4GB 3TB | OS X 10.9.2
Kilamite is offline   0 Reply With Quote
Old Dec 7, 2009, 07:31 AM   #25
femmeaccident
macrumors newbie
 
Join Date: Dec 2009
Facebook Problems on Safari

I am having a similar problem. Over the past few weeks I can only sometimes access facebook on my Mac. My husband uses a PC and doesn't seem to have a problem, so I'm guessing it must be a Mac problem. It will shut down in the middle of a session or just block me out completely. When I do get onto the site, I sometimes cannot post comments or send messages. It's driving me NUTS!!
femmeaccident is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
thread Thread Starter Forum Replies Last Post
Safari + Facebook High CPU usage? eleven7 Mac Basics and Help 6 Jan 15, 2013 11:52 PM
Safari/Facebook issues with scrolling natekettles Mac Applications and Mac App Store 2 May 8, 2011 10:29 PM
Safari youtube problems chillined1212 Mac Applications and Mac App Store 3 Mar 16, 2011 06:05 PM
No Typing In Facebook CarsonGallo Mac OS X 10.7 Lion 1 Feb 27, 2011 01:26 AM
Safari/facebook problem mkaayyox Mac Basics and Help 11 Aug 19, 2008 07:58 PM


All times are GMT -5. The time now is 09:13 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC