Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Reply
 
Thread Tools Search this Thread Display Modes
Old Jun 29, 2008, 10:48 PM   #1
gtg941f
macrumors newbie
 
Join Date: Jun 2008
Removing ATV4Windows

I tried patching with ATV4Windows 2.4 and everything appeared to be going well, except on the final reboot (after patching with the minute countdown), it rebooted to the normal ATV home screen with no changes.

Now, everytime I reboot and try to use another patchstick, the modified boot sequence won't allow the patchstick to run.

Soooo, my actual request: does anybody know how to restore all the files to exactly as the ATV was purchased (2.02)? I want to get back to the factory defaults and all original files without the modified ATV4Windows boot so that I can attempt to use another Patchstick.

Thanks
gtg941f is offline   0 Reply With Quote
Old Jun 29, 2008, 11:16 PM   #2
tom1971
macrumors 6502a
 
Join Date: May 2007
AppleTV main menu:
Settings -> General -> Reset Settings -> Factory Restore -> Restore

Last edited by tom1971; Jun 29, 2008 at 11:32 PM.
tom1971 is offline   0 Reply With Quote
Old Jun 29, 2008, 11:34 PM   #3
gtg941f
Thread Starter
macrumors newbie
 
Join Date: Jun 2008
I certainly wish that would work. However, when using that method it restarts but still shows the atv4windows splash screen before the apple, and then just like the initial patching it goes to the "atv4windows initializing/patching..." screen, restarts and shows the normal unmodified atv home.

Basically if I restart/restore/yank the cord out and restart that way, it always reverts back to that dang "atv4windows initializing/patching..." screen like it should have done once successfully. Seems like an absolutely remote issue that couldn't have been predicted.
gtg941f is offline   0 Reply With Quote
Old Jun 30, 2008, 02:34 AM   #4
Gee
macrumors 65816
 
Join Date: Feb 2004
Location: London, UK
If you've got your appletv on a wireless network, it gets stuck like this I think. Did you try it with a wired connection? The patching process downloads some files, and if it can't find them, it can't finish.
Gee is offline   0 Reply With Quote
Old Jun 30, 2008, 05:17 AM   #5
911c4
macrumors newbie
 
Join Date: Jun 2008
I have exactly the same problem. Any help would be appreciated.
911c4 is offline   0 Reply With Quote
Old Jun 30, 2008, 11:52 AM   #6
gtg941f
Thread Starter
macrumors newbie
 
Join Date: Jun 2008
Just so that everybody is aware, it appears the two developers of atv4windows split ways and the person who is now doing atv patch (cisco) appears to have distribute a bum patchstick which deletes your recovery drive on the ATV.

To recover the entire drive, there is now a recovery patchstick so you don't have to follow those really long instructions. http://www.atvmod.com/forum/viewthre...=5&thread_id=8

That site is from one of the developers. He basically took everything and left Cisco (good!). So ATV Mod is essentially ATV4W 2.5 and it's distributed for free on his site!
gtg941f is offline   0 Reply With Quote
Old Jun 30, 2008, 11:23 PM   #7
911c4
macrumors newbie
 
Join Date: Jun 2008
Did you manage to get the patch. The site is currently closed?
911c4 is offline   0 Reply With Quote
Old Jun 30, 2008, 11:48 PM   #8
TuckBodi
macrumors 6502
 
Join Date: Jan 2007
http://rapidshare.com/files/12597038...part1.rar.html
http://rapidshare.com/files/12597399...part2.rar.html
http://rapidshare.com/files/12597792...part3.rar.html
http://rapidshare.com/files/12597996...part4.rar.html

Side: The new guy on atvmod seems much, much cooler than ciscotm.
TuckBodi is offline   0 Reply With Quote
Old Jul 1, 2008, 12:14 PM   #9
tom1971
macrumors 6502a
 
Join Date: May 2007
Are you sure this is the "recovery fix" or yet another hack that screws up your ATV - be careful, guys !
tom1971 is offline   0 Reply With Quote
Old Jul 1, 2008, 01:48 PM   #10
TuckBodi
macrumors 6502
 
Join Date: Jan 2007
Quote:
Originally Posted by tom1971 View Post
Are you sure this is the "recovery fix" or yet another hack that screws up your ATV - be careful, guys !
Geeesh, if your ATV is already so screwed up it's not booting what's not to hurt trying something?

I got the links from the atvmod.com forum site. Join up and see what people are saying about this patch helping them out when all things looked pretty bleak. I'm neither promoting nor condoning this patch, just merely passing on some hopefully useful info. In fact here's a couple of posts from the thread:
-----------
Posted on 30-06-2008 00:14
Fn AWESOME!!! monty432 thanks so much. My ATV is back to "normal"..ver 2.02... soon to get the "proper" upgrade. Not even a day went by from the time i made the request till a solution from the forum, thats great. Thanks to everyone that offered help. Obviously this forum / site is the place to go for ATV.

Thanks again...

----------
Posted on 30-06-2008 11:35
Yip thanks monty432. You've saved my bacon with the restore patchstick!!!

We're not worthy.

----------
Hey monty432....uuuuuuuuuuuuuuuuuuuuuuuuuu the mannnnnnnnnnnnnnnnnn!

Patchstick recovery...how sweet. Thank you members of atvmod.com.

Wanted to add that the patchstick worked perfectly for me. Completely got rid of that BrickTv crap.
TuckBodi is offline   0 Reply With Quote
Old Jul 1, 2008, 03:36 PM   #11
MikieMikie
macrumors 6502a
 
Join Date: Aug 2007
Location: Newton, MA
Quote:
Originally Posted by tom1971 View Post
Are you sure this is the "recovery fix" or yet another hack that screws up your ATV - be careful, guys !
I knew we should have ordered that patchstick from you.
MikieMikie is offline   0 Reply With Quote
Old Jul 1, 2008, 03:46 PM   #12
TuckBodi
macrumors 6502
 
Join Date: Jan 2007
Quote:
Originally Posted by MikieMikie View Post
I knew we should have ordered that patchstick from you.
And have you seen the YouTube video of the guy doing a sales job on how his patch works? Slimy and creepy and majorly unprofessional!
TuckBodi is offline   0 Reply With Quote
Old Jul 1, 2008, 04:52 PM   #13
MikieMikie
macrumors 6502a
 
Join Date: Aug 2007
Location: Newton, MA
Quote:
Originally Posted by TuckBodi View Post
And have you seen the YouTube video of the guy doing a sales job on how his patch works? Slimy and creepy and majorly unprofessional!
Are you referring to "tom" when you say "the guy?" I'd be interested to know. And I forgot to include the appropriate in my last post. Sorry.
MikieMikie is offline   0 Reply With Quote
Old Jul 1, 2008, 04:57 PM   #14
TuckBodi
macrumors 6502
 
Join Date: Jan 2007
Quote:
Originally Posted by MikieMikie View Post
Are you referring to "tom" when you say "the guy?" I'd be interested to know. And I forgot to include the appropriate in my last post. Sorry.
Nope -- CiscoTM. I thought you were cynically referencing Cisco.
TuckBodi is offline   0 Reply With Quote
Old Jul 1, 2008, 05:32 PM   #15
tom1971
macrumors 6502a
 
Join Date: May 2007
Quote:
Originally Posted by MikieMikie View Post
I knew we should have ordered that patchstick from you.
"Never argue with an idiot... for they will drag you down to their level and beat you with experience"

A nice quote that I found in someones signature on this forum.

All said and done.

Last edited by tom1971; Jul 1, 2008 at 05:40 PM.
tom1971 is offline   0 Reply With Quote
Old Jul 1, 2008, 07:43 PM   #16
911c4
macrumors newbie
 
Join Date: Jun 2008
Quote:
Originally Posted by tom1971 View Post
Are you sure this is the "recovery fix" or yet another hack that screws up your ATV - be careful, guys !
Hi all,

I just tried this and it doesn't appear to work (assuming I have done everything correcty). It loads up to the point of getting the following message :Cannot unmount/mnt/OSBoot: No such file or directory.

If anyone else has tried this, can they please provide some feedback. I have assumed that I make the patchstick the same way v2.4. I noted an extra file in the download recovery-fix.img.md5. which I didn't use.

Any help would be appreciated.
911c4 is offline   0 Reply With Quote
Old Jul 1, 2008, 08:54 PM   #17
911c4
macrumors newbie
 
Join Date: Jun 2008
Me again,

Was contacted by atvmod re my problem. Went back and tried restoring factory settings for a 3rd time and guess what, it worked!!!

There some sort of magic happening at atvmod.

Thanks everyone for helping get this resolved.
911c4 is offline   0 Reply With Quote
Old Jul 2, 2008, 12:32 AM   #18
gtg941f
Thread Starter
macrumors newbie
 
Join Date: Jun 2008
The links above do in fact work. They restored my recovery partition and allowed me to factory restore and start all over.

Thanks to the folks over at atvmod who are working to clean up this mess that the slimeball Cisco created.
gtg941f is offline   0 Reply With Quote
Old Jul 3, 2008, 12:26 PM   #19
CiscoTM
macrumors newbie
 
Join Date: Apr 2008
just so you know, i did nothing to this file, the code was injected threw the internet, this is y we removed it from our website, but some one leaked it onto bit torrent and now it can not be stopped.!

Last edited by CiscoTM; Jul 3, 2008 at 02:30 PM.
CiscoTM is offline   0 Reply With Quote
Old Jul 3, 2008, 03:50 PM   #20
brand
macrumors 68040
 
brand's Avatar
 
Join Date: Oct 2006
Location: 127.0.0.1
Quote:
Originally Posted by CiscoTM View Post
Just so you know it was not me but H3lbr0 the slimeball that created 2.4 and messed up your partitions. There is actually a class action lawsuit forming against h3lbr0 in the matter of injecting a virus code into the 2.4 image, and yet refuses to remove it. It is a ploy against ATVPatch.com so we get a bad rep! So before you call me a slimball, look in to the situation.
What he originally posted.
brand is online now   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Need help removing vocals... Please Orange Furball Digital Audio 20 Jun 21, 2013 02:46 PM
iPhone: Removing Jailbreak Matkar Jailbreaks and iOS Hacks 7 Mar 6, 2013 02:28 PM
Resolved: Removing Software chattahoochee MacBook 3 Mar 1, 2013 03:16 PM
Removing OS X Kirkle OS X 10.8 Mountain Lion 25 Jan 28, 2013 12:29 AM

Forum Jump

All times are GMT -5. The time now is 12:03 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC