Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Applications > Mac Applications and Mac App Store

Reply
 
Thread Tools Search this Thread Display Modes
Old Dec 22, 2008, 02:20 AM   #1
Bethany-Wings
macrumors member
 
Join Date: Apr 2008
Safari keeps logging me out of Facebook

It never did this with Netscape or Firefox, and from what I've heard, it doesn't do it with my friend, who uses Safari all the time. I have Safari set up so it automatically fills in forms AND accepts cookies from any site, and it STILL logs me out suddenly in about a minute. How can I keep myself logged in all the time, like it's SUPPOSED to? Help!?
Bethany-Wings is offline   0 Reply With Quote
Old Dec 22, 2008, 02:22 AM   #2
dalvin200
macrumors 68040
 
Join Date: Mar 2006
Location: Nottingham, UK
Quote:
Originally Posted by Bethany-Wings View Post
It never did this with Netscape or Firefox, and from what I've heard, it doesn't do it with my friend, who uses Safari all the time. I have Safari set up so it automatically fills in forms AND accepts cookies from any site, and it STILL logs me out suddenly in about a minute. How can I keep myself logged in all the time, like it's SUPPOSED to? Help!?
what version of safari are you using?

i used to get the same problem but for a few months now its been fine.. i'm all updated to the safari v3.2.1 and no problems here..

have you tried clearing your cache/cookies and starting again?
__________________
Search before you post: MRoogle
dalvin200 is offline   0 Reply With Quote
Old Dec 22, 2008, 04:24 AM   #3
Bethany-Wings
Thread Starter
macrumors member
 
Join Date: Apr 2008
Surprisingly, I'm using Safari 3.2.1. Also, I tried all that you told me to do, and it STILL won't keep me logged in. I even tried to restart Safari with all the changes, and nothing. Why is this not working for me? Why is it just Facebook? And...also, I'm even selecting the option of "remember me" just before I log in.
Bethany-Wings is offline   0 Reply With Quote
Old Dec 22, 2008, 04:26 AM   #4
.Andy
macrumors 68030
 
.Andy's Avatar
 
Join Date: Jul 2004
Location: The Mergui Archipelago
Do you have private browsing on? Facebook doesn't like that.
__________________
Each man's death diminishes me, for I am involved in mankind. Therefore, send not to know for whom the bell tolls, it tolls for thee.
.Andy is offline   0 Reply With Quote
Old Dec 22, 2008, 04:45 AM   #5
156457
macrumors 6502
 
Join Date: Jan 2008
Location: UK
I get this, except if I'm active I'm OK but then if like in 15 minutes I come back to it, it will ask me to login again even though I clicked 'Remember Me'. Bebo doesn't have any problems with the remember me function so I don't know what the problem is.
156457 is offline   0 Reply With Quote
Old Dec 22, 2008, 06:30 AM   #6
Kilamite
macrumors G3
 
Kilamite's Avatar
 
Join Date: Mar 2007
Location: Edinburgh, Scotland
Try resetting Safari (clear everything, cookies etc).

Although Facebook is really quite buggy. When I log in, I have to log in twice because the first time it says my password or email is incorrect (even though its an autofill). I have to just press enter and then it logs me in.

Seen other various glitches in Facebook, especially the home page.
__________________
15" MacBook Pro 2GHz i7 8GB 750GB Hybrid | Mac mini 2.3GHz i7 16GB 1TB Fusion | OS X 10.9.2
iPhone 5 64GB | Apple TV 3 1080p | iOS 7.1
Home Theatre Hackintosh i3 3.5GHz 4GB 3TB | OS X 10.9.2
Kilamite is online now   0 Reply With Quote
Old Dec 22, 2008, 08:39 PM   #7
kipsterdude
macrumors newbie
 
Join Date: Dec 2008
I was having this problem as well, and seem to have hopefully resolved it, at least for the time being. I followed the procedure they presented when there were sync issues with safari bookmarks and .Mac (at the time)

Resolution

1. Quit Safari 3.2.1

2. Open Terminal (in /Applications/Utilities).

3. Type or paste the following command in Terminal:
defaults delete com.apple.safari RegisteredSafariSyncClient

4. Open Safari 3.1 again.

EDIT
I spoke too soon. After more googling, it seems that there are login issues if you're also using 3rd party applications like Adium to connect to facebook chat, which I have also confirmed. If you cease connecting to facebook through Adium, the problem should cease.

Last edited by kipsterdude; Dec 22, 2008 at 08:53 PM.
kipsterdude is offline   0 Reply With Quote
Old Dec 22, 2008, 09:40 PM   #8
CristobalHuet
macrumors 65816
 
CristobalHuet's Avatar
 
Join Date: Jan 2008
Location: Montreal
Quote:
Originally Posted by kipsterdude View Post
I was having this problem as well, and seem to have hopefully resolved it, at least for the time being. I followed the procedure they presented when there were sync issues with safari bookmarks and .Mac (at the time)

Resolution

1. Quit Safari 3.2.1

2. Open Terminal (in /Applications/Utilities).

3. Type or paste the following command in Terminal:
defaults delete com.apple.safari RegisteredSafariSyncClient

4. Open Safari 3.1 again.

EDIT
I spoke too soon. After more googling, it seems that there are login issues if you're also using 3rd party applications like Adium to connect to facebook chat, which I have also confirmed. If you cease connecting to facebook through Adium, the problem should cease
.
I had the problem of Safari logging me out all the time too; until recently I reinstalled Safari, and it stopped.

I also use Adium lol.
__________________
13" MacBook Air 2.13Ghz Core 2 Duo/4GB RAM/256GB SSD (2010) + 24" Apple LED Cinema Display
32GB iPhone 5, Black
64GB Wi-Fi iPad mini, Black
CristobalHuet is offline   0 Reply With Quote
Old Dec 23, 2008, 03:04 AM   #9
156457
macrumors 6502
 
Join Date: Jan 2008
Location: UK
I've done the update to 10.5.6, and my Safari still says it's Safari 3.2, and Software update doesn't give me an option to download 3.2.1.
156457 is offline   0 Reply With Quote
Old Dec 26, 2008, 12:11 PM   #10
wakanomori
macrumors newbie
 
Join Date: Dec 2008
same problem -- big safari bug?

using OSX 10.5.6 and Safari 3.2.1 I found the browser was more or less randomly deleting and reviving cookies. So I'd be logged out of sites while on them, and then suddenly logged back in when I'd logged out. Very creepy. I reinstalled Safari, but same problem. Now I'm using Firefox, reluctantly, and investigating Camino. This Safari is just NOT SAFE.
wakanomori is offline   0 Reply With Quote
Old Dec 30, 2008, 11:28 AM   #11
tiny-e
macrumors newbie
 
Join Date: Dec 2008
It's Adium. I've been going through the same thing. When Safari and Adium are running at the same time, one logs the other out of Facebook. You can hear Aduim disconnect and then re-connect when you browse to Facebook in Safari.
tiny-e is offline   0 Reply With Quote
Old Dec 30, 2008, 05:36 PM   #12
bmonzing
macrumors newbie
 
Join Date: Sep 2007
Adium Says:

Quote:
Facebook logs out when Adium is signed in

status changed from new to closed.
resolution set to wontfix.
component changed from Adium Core to Facebook Chat.

I don't think this is the fault of Adium, but rather how Facebook handles sessions. That said, it should resolve itself when Facebook rolls out a supported way to hook into its chat -- hopefully soon.
http://trac.adiumx.com/ticket/11355
bmonzing is offline   0 Reply With Quote
Old Jan 14, 2009, 01:22 AM   #13
pendolino
macrumors member
 
Join Date: Feb 2007
Quote:
Originally Posted by wakanomori View Post
using OSX 10.5.6 and Safari 3.2.1 I found the browser was more or less randomly deleting and reviving cookies. So I'd be logged out of sites while on them, and then suddenly logged back in when I'd logged out. Very creepy. I reinstalled Safari, but same problem. Now I'm using Firefox, reluctantly, and investigating Camino. This Safari is just NOT SAFE.
I am having the same problem after updating to OSX 10.5.6. I am not sure what broke but facebook specifically logs me out within seconds of login. Its quite a pain.
pendolino is offline   0 Reply With Quote
Old Jan 14, 2009, 10:44 AM   #14
wawanarchist
macrumors regular
 
Join Date: Oct 2008
The same thing was happening to me, then I realized it was because I had adium running facebook messenger. When I closed out of adium it worked great... If you guys are running adium with facebook messenger thats probably it
wawanarchist is offline   0 Reply With Quote
Old Jan 24, 2009, 01:23 PM   #15
paulold
macrumors 6502
 
Join Date: Mar 2008
Location: Washington, DC
cookies deleting themselves?

I have been experiencing a similar problem, but it's not limited to just Facebook. I have the latest OSX and the latest Safari. I know how to reset Safari and I have attempted this. I frequent a number of websites where I have to login and I have the website remember who I am so I don't to type in my username and password everytime. I'm pretty sure this is accomplished via a cookie. So, I find it odd when all by itself it's as if Safari has cleared out the cookies cause all of my regular websites have forgotten who I am. I know this will happen whenever I reset, so with it occurs when I didn't ask for it, I find it rather odd. I would estimate that this has been happening in past couple of months. Previously I hadn't had such problems.

What should I do - get virus protection software and see if I've been infected with something?
__________________
MacBook Pro 2011 17" 2.2Ghz, iPad Wifi 32GB, iPhone 4S 64GB Verizon, iPod Classic 80GB, Apple TV 2, Time Capsule 1 TB
paulold is offline   0 Reply With Quote
Old Jan 24, 2009, 09:44 PM   #16
cuestakid
macrumors 68000
 
Join Date: Jun 2006
Location: San Fran
I concur with everyone who said it was Adium-happened to me for a while until i realized that I need to disable facebook chat in adium. I really dont think that the problem is with cookies or anything like that

To paulold-

make sure that you do not have Private Browsing enabled. Also, have you tried this in firefox?
__________________
15in 2.2ghz i7SB, 750GB HD,16GB RAM Apple TV Hockey PuckiPhone 5S 32GB Verizon iPad3 WiFi 32GB
cuestakid is offline   0 Reply With Quote
Old Jan 24, 2009, 11:42 PM   #17
dswoodley
macrumors 6502a
 
Join Date: Jul 2002
Quote:
Originally Posted by pendolino View Post
I am having the same problem after updating to OSX 10.5.6. I am not sure what broke but facebook specifically logs me out within seconds of login. Its quite a pain.
In case anyone is still having problems, I just figured it out yesterday. Macfixit reports the solution is disable webclip widgets and remake them. It should fix the cookie problem - it did for me.
dswoodley is offline   0 Reply With Quote
Old Jan 25, 2009, 03:20 AM   #18
pendolino
macrumors member
 
Join Date: Feb 2007
Quote:
Originally Posted by dswoodley View Post
In case anyone is still having problems, I just figured it out yesterday. Macfixit reports the solution is disable webclip widgets and remake them. It should fix the cookie problem - it did for me.
interesting. i assume you are referring to the Safari Dashboard widgets.
pendolino is offline   0 Reply With Quote
Old Jan 25, 2009, 03:34 AM   #19
Middling
macrumors regular
 
Join Date: Jan 2009
Quote:
Originally Posted by pendolino View Post
interesting. i assume you are referring to the Safari Dashboard widgets.
I think it's just ones you make yourself using the webclip facility in Safari.

I had a mixture of webclips and standard widgets in my Dashboard and would keep getting logged out of various websites (not Facebook, since i don't use it). After deleting the webclips but leaving the standard widgets i no longer get logged out.

10.5.6 definitely broke something in the way that cookies are handled.
Middling is offline   0 Reply With Quote
Old Jan 25, 2009, 06:18 AM   #20
paulold
macrumors 6502
 
Join Date: Mar 2008
Location: Washington, DC
I did not have private browsing turned on, but I do have a webclip widget. Come to think of it, I rarely use my widgets but lately I have been accidently hitting the F12 key, which opens my dashboard. I think it's definitely worth a try to delete the widget. The frequency of my problem seems to correspond with the number of times I've hit that key.
__________________
MacBook Pro 2011 17" 2.2Ghz, iPad Wifi 32GB, iPhone 4S 64GB Verizon, iPod Classic 80GB, Apple TV 2, Time Capsule 1 TB
paulold is offline   0 Reply With Quote
Old Jan 25, 2009, 01:46 PM   #21
dswoodley
macrumors 6502a
 
Join Date: Jul 2002
Quote:
Originally Posted by pendolino View Post
interesting. i assume you are referring to the Safari Dashboard widgets.
Correct. Seems to be a pretty big oversight on Apple's developers' part.
dswoodley is offline   0 Reply With Quote
Old Feb 1, 2009, 02:11 PM   #22
AlexisV
macrumors 65816
 
Join Date: Mar 2007
Location: Manchester, UK
This is driving me mad.

I have had to delete all my webclip widgets because they cause me to become logged out of all forums.

I've tried resetting Safari, but it makes no difference.


No webclips = everything works fine
Webclips = can't stay logged into forums


This is an obvious 10.5.6 bug.
AlexisV is offline   0 Reply With Quote
Old Feb 3, 2009, 08:57 PM   #23
littlemcbeast
macrumors newbie
 
Join Date: Jan 2009
Location: Montreal, Canada
I have this problem, and I don't have Adium or Dashboard widgets...

I never should have installed 10.5.6. This is just one out of a ridiculous amount of problems I've been having lately. It's like the Plagues of Egypt hitting my Mac over and over and over...
littlemcbeast is offline   0 Reply With Quote
Old Feb 3, 2009, 10:02 PM   #24
paulold
macrumors 6502
 
Join Date: Mar 2008
Location: Washington, DC
Just an update - I deleted my webclip (that was of the headlines of cnn.com) and haven't had a problem with my cookies since. So if that did the trick, thanks for helping me out!
__________________
MacBook Pro 2011 17" 2.2Ghz, iPad Wifi 32GB, iPhone 4S 64GB Verizon, iPod Classic 80GB, Apple TV 2, Time Capsule 1 TB
paulold is offline   0 Reply With Quote
Old Feb 5, 2009, 09:11 AM   #25
dronkert
macrumors newbie
 
Join Date: Jun 2007
Same problem here (OSX 10.5.6 Safari 3.2.1). It happens on Facebook and Flickr for me. I do not use Adium, webclips or any other non-standard dashboard widgets. Tried resetting Safari, didn't help.
dronkert is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Applications > Mac Applications and Mac App Store

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
thread Thread Starter Forum Replies Last Post
Safari logs me out of sites, didnt used to. twelve56 iPad 4 Oct 5, 2011 01:32 PM
Firefox keeps logging me out of everything? msw123307 Mac Applications and Mac App Store 0 Jan 17, 2010 12:12 PM
iPhone Safari keeps logging me out - RESOLVED tjpoch iPhone Tips, Help and Troubleshooting 1 May 30, 2008 10:33 PM
Touch keeps kicking me out of Safari sunchamp iPod touch 11 Sep 22, 2007 09:19 AM
MR keeps logging me out. Bobdude161 Site and Forum Feedback 6 Jul 27, 2006 10:57 AM


All times are GMT -5. The time now is 03:51 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC