Go Back   MacRumors Forums > Archive > Archives of Old Posts > Macintosh Computers

 
 
Thread Tools Search this Thread Display Modes
Old May 13, 2004, 10:33 PM   #1
mkrishnan
Moderator emeritus
 
mkrishnan's Avatar
 
Join Date: Jan 2004
Location: Grand Rapids, MI, USA
iBook G4 USB ports...identical?

When I first got my iBook (12" G4 800 MHz), a friend brought over his Digital Elph, and we tried to plug it into my iBook to see how iPhoto imports work. We found that one of the ports (the one nearer the FW port) didn't do anything when we inserted his camera, but it was automatically recognized on the other one (the one next to the display port) and worked fine.

Since I don't use USB much and I have a warranty, I kinda ignored it. But now I got my own camera (Powershot S50), and same deal.

Just to make sure I'm not crazy or ignorant, there isn't any difference between the two USB ports on the iBook is there, like one being powered and the other not? This should not be happening, right?
__________________
Mira C. Krishnan
mkrishnan is offline   0
Old May 13, 2004, 11:44 PM   #2
mactastic
macrumors 68040
 
mactastic's Avatar
 
Join Date: Apr 2003
Location: Colly-fornia
No that should not be happening. I'd contact Apple ASAP. Both USB ports on my TiBook (1Ghz) and my wife's iBook (800Mhz G4) work with our digicam.
__________________
I salute you Sean [Hannity]. I salute you for bravely standing by a man whose only crime, was breaking federal law.
- Stephen Colbert
mactastic is offline   0
Old May 14, 2004, 12:35 AM   #3
michaelrjohnson
macrumors 68020
 
Join Date: Aug 2000
Location: 54140
yep, its a flaw. get that fixed right away! hurry! go now!
__________________
Designer
michaelrjohnson.com
michaelrjohnson is offline   0
Old May 14, 2004, 05:34 AM   #4
mkrishnan
Thread Starter
Moderator emeritus
 
mkrishnan's Avatar
 
Join Date: Jan 2004
Location: Grand Rapids, MI, USA
Quote:
Originally Posted by michaelrjohnson
yep, its a flaw. get that fixed right away! hurry! go now!
I'm running, I'm running! Thanks for your help, Michael and Mactastic!
__________________
Mira C. Krishnan
mkrishnan is offline   0
Old May 14, 2004, 08:37 AM   #5
jxyama
macrumors 68040
 
jxyama's Avatar
 
Join Date: Apr 2003
is it just the camera? does the problem happen with other USB devices, like a mouse?

i agree that you should have it checked out. (and since you are in troy, there's an apple store right there!)

i was just curious...
jxyama is offline   0
Old May 14, 2004, 09:10 AM   #6
RBMaraman
macrumors 65816
 
RBMaraman's Avatar
 
Join Date: Jul 2002
Location: Prospect, KY
I have the same problem with my iBook G3 500!

If I plug my digital Elph into the front USB port, the iBook will not recognize it. But, if I plug it into the back USB port, it works.

BUT, every other perepherial works on both ports! I can use my printer on both, a USB hub on both, my Palm HotSync crable on both, just not my digital Elph. So, I think it's an issue with the camera or USB cable and not my iBook.
RBMaraman is offline   0
Old May 15, 2004, 10:11 AM   #7
mkrishnan
Thread Starter
Moderator emeritus
 
mkrishnan's Avatar
 
Join Date: Jan 2004
Location: Grand Rapids, MI, USA
Quote:
Originally Posted by RBMaraman
I have the same problem with my iBook G3 500!

If I plug my digital Elph into the front USB port, the iBook will not recognize it. But, if I plug it into the back USB port, it works.

BUT, every other perepherial works on both ports! I can use my printer on both, a USB hub on both, my Palm HotSync crable on both, just not my digital Elph. So, I think it's an issue with the camera or USB cable and not my iBook.
Hmmm...all Canon cameras...hmmm...very curious. Thanks -- I'm gonna look and see if I have any other Mac compatible USB devices. My mice are either PS2 or BT. I have a scanner and a USBCam but I'm pretty sure they're not macable. Well, maybe if I find drivers? Maybe I can ask at the Apple store too. I have to go back there today bc I bought something there a couple days ago and they gave me somebody else's receipt.

EDIT: ooh, ooh, my printer (duh)...BC its been on my AEBS the whole time I owned it, I forgot all about it.
__________________
Mira C. Krishnan

Last edited by mkrishnan; May 15, 2004 at 10:17 AM.
mkrishnan is offline   0
Old May 15, 2004, 10:32 AM   #8
mkrishnan
Thread Starter
Moderator emeritus
 
mkrishnan's Avatar
 
Join Date: Jan 2004
Location: Grand Rapids, MI, USA
Yeah...my printer at least DOES get *recognized* on both ports, which is more than I can say for my camera. VERY strange. I guess I will take my iBook with me to the Apple store this afternoon.
__________________
Mira C. Krishnan
mkrishnan is offline   0
Old May 15, 2004, 10:44 AM   #9
Mitthrawnuruodo
Moderator
 
Mitthrawnuruodo's Avatar
 
Join Date: Mar 2004
Location: Bergen, Norway
Both USB ports works fine on my iBook G4 when connecting my HP Photosmart 435...
__________________
Those who fail to learn history are doomed to repeat it; those who fail to learn history correctly... why, they are simply doomed.
Mitthrawnuruodo is offline   0
Old May 15, 2004, 05:06 PM   #10
mkrishnan
Thread Starter
Moderator emeritus
 
mkrishnan's Avatar
 
Join Date: Jan 2004
Location: Grand Rapids, MI, USA
Hmmm...I opened my iBook to make sure I knew which USB port was which (working & not working) just before going to the Apple store, and whaddya know...they both work. Tried putting it back to sleep and waking it and still works. Tried repeatedly swapping it (plugging it in, waiting for iPhoto to recognize it, unplugging it, waiting for iPhoto to drop it, repeat ad nauseum) and still no issue.

Tried it again now and it still works. Almost like plugging the printer in woke something up.

Major weirdness.

Now I just gotta keep an eye on it during my warranty period to make sure it doesn't recur....
__________________
Mira C. Krishnan
mkrishnan is offline   0
Old May 15, 2004, 05:44 PM   #11
7on
macrumors 601
 
7on's Avatar
 
Join Date: Nov 2003
Location: Punk Hazard
Yeah, my tibook was having a problem with the right USB (when looking at it from the rear) but a restart fixed it. Twas weird.
__________________
jonshipman.com
7on is offline   0
Old May 15, 2004, 08:06 PM   #12
Chip NoVaMac
macrumors G3
 
Chip NoVaMac's Avatar
 
Join Date: Dec 2003
Location: Northern Virginia
I have the same issue with my PB 12" and how the USB is recognized....
Chip NoVaMac is offline   0
Old May 16, 2004, 08:16 AM   #13
mkrishnan
Thread Starter
Moderator emeritus
 
mkrishnan's Avatar
 
Join Date: Jan 2004
Location: Grand Rapids, MI, USA
Quote:
Originally Posted by Chip NoVaMac
I have the same issue with my PB 12" and how the USB is recognized....
Same meaning it doesn't work; it didn't work, but does now; or it does work? It's a moving target!
__________________
Mira C. Krishnan
mkrishnan is offline   0
Old May 16, 2004, 09:28 AM   #14
Chip NoVaMac
macrumors G3
 
Chip NoVaMac's Avatar
 
Join Date: Dec 2003
Location: Northern Virginia
Quote:
Originally Posted by mkrishnan
Same meaning it doesn't work; it didn't work, but does now; or it does work? It's a moving target!
Should explain further.

The USB port closest to the FW400 port is the only port that I can get my USB hub to recognize and print from. The other one is fine for the keyboard and mouse.
Chip NoVaMac is offline   0
Old May 17, 2004, 12:52 AM   #15
mkrishnan
Thread Starter
Moderator emeritus
 
mkrishnan's Avatar
 
Join Date: Jan 2004
Location: Grand Rapids, MI, USA
Quote:
Originally Posted by Chip NoVaMac
Should explain further.

The USB port closest to the FW400 port is the only port that I can get my USB hub to recognize and print from. The other one is fine for the keyboard and mouse.
It almost sounds like a power (electrical) issue, doesn't it? Like the only devices we have trouble with are USB-powered devices that take a relatively larger amount of juice. Of course I can't explain why mine works now.
__________________
Mira C. Krishnan
mkrishnan is offline   0


 
MacRumors Forums > Archive > Archives of Old Posts > Macintosh Computers

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Mac Mini recording -- USB 2.0 interfaces with USB 3.0 ports RT81 Mac mini 16 Jun 1, 2014 11:30 AM
need more usb ports! mitchellm MacBook Pro 16 Sep 7, 2013 10:56 AM
Not enough USB ports... barrett14 iMac 17 Dec 18, 2012 11:41 AM
4 USB ports - 6 USB inputs Qwerty11 iMac 4 Oct 25, 2012 10:21 AM
Has anyone had any luck with USB audio interfaces with the new USB combo ports? soldierblue MacBook Pro 0 Jun 18, 2012 05:10 AM

Forum Jump

All times are GMT -5. The time now is 09:19 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC