Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Reply
 
Thread Tools Search this Thread Display Modes
Old Oct 28, 2009, 07:26 AM   #1
lisamel
macrumors regular
 
Join Date: Mar 2008
Location: Oslo, Norway
My iMac stopped working. Please help me :)

Hi!

Well, like the title says, my iMac has stopped working. I've been working on it all day and when I went to make some food, it must have died or something. When I got back after about 30 mins the screen was black and I couldnt turn it on. I tried to unplug it and check that the plug was working correctly (it was) and plugged the iMac back in. It still wont turn back on..

Has this happened to anyone else before? Is there something I can do?

The iMac was new in March 2008.

Thank you for any help
lisamel is offline   0 Reply With Quote
Old Oct 28, 2009, 07:30 AM   #2
BlueRevolution
macrumors 601
 
BlueRevolution's Avatar
 
Join Date: Jul 2004
Location: Montreal, QC
What happens when you press the power button? Do the fans start spinning?
__________________
PIRATE PARTY OF CANADA — Information leadership for the 21st century
BlueRevolution is offline   0 Reply With Quote
Old Oct 28, 2009, 07:36 AM   #3
lisamel
Thread Starter
macrumors regular
 
Join Date: Mar 2008
Location: Oslo, Norway
No nothing happens Its like is has no power or something.
lisamel is offline   0 Reply With Quote
Old Oct 28, 2009, 10:38 AM   #4
pmkoch
macrumors regular
 
Join Date: Oct 2009
Try plugging into a different outlet and see if it works.
pmkoch is offline   0 Reply With Quote
Old Oct 28, 2009, 10:40 AM   #5
BlueRevolution
macrumors 601
 
BlueRevolution's Avatar
 
Join Date: Jul 2004
Location: Montreal, QC
Could be a power supply issue, then. Take it in to the shop.

What model do you have? Is it still under warranty?
__________________
PIRATE PARTY OF CANADA — Information leadership for the 21st century
BlueRevolution is offline   0 Reply With Quote
Old Oct 29, 2009, 03:27 AM   #6
lisamel
Thread Starter
macrumors regular
 
Join Date: Mar 2008
Location: Oslo, Norway
I dont know which model it is, but I got it in march 2008 Its a 20".

I am going to take it to a retailer today, hopefully they will be able to fix it quick!
lisamel is offline   0 Reply With Quote
Old Oct 29, 2009, 06:38 AM   #7
toolbox
macrumors 68020
 
toolbox's Avatar
 
Join Date: Oct 2007
Location: Australia (WA)
How did you go at the store? Do you have another Power cord to try?
__________________
2009 iMac 27 inch | i7 2.8 | 1 TB | 16GB DDR3
iPhone 3gs | iPhone 4 | iPhone 4s | iPad 1 | iPad 2
toolbox is offline   0 Reply With Quote
Old Oct 29, 2009, 05:14 PM   #8
John Doe 57
macrumors 65816
 
John Doe 57's Avatar
 
Join Date: Jan 2008
Location: Binghamton, NY
To OP:
Might me an Logic Board failure.
__________________
17" MacBook Pro 3,1 | 6GB RAM | 240GB SSD ||| Lumix GH2 | Voigtländer 17.5mm F/0.95 | SLR Magic 12mm T/1.6 Wide ||| Vimeo | Soundcloud | Tumblr
John Doe 57 is offline   0 Reply With Quote
Old Oct 30, 2009, 05:27 AM   #9
lisamel
Thread Starter
macrumors regular
 
Join Date: Mar 2008
Location: Oslo, Norway
I took it to the Apple Retail store (we dont have an Apple Store in Norway) and they tried with a different plug and nothing happened. So they took it in and will have a look at it. They thought that it might be failed logic board. So I'm waiting to hear from them. I'm not under the Apple Warranty but we have a longer warranty type thing in Norway so it will be fixed for free
lisamel is offline   0 Reply With Quote
Old Oct 30, 2009, 09:53 AM   #10
John Doe 57
macrumors 65816
 
John Doe 57's Avatar
 
Join Date: Jan 2008
Location: Binghamton, NY
Quote:
Originally Posted by lisamel View Post
I'm not under the Apple Warranty but we have a longer warranty type thing in Norway so it will be fixed for free
Nice! When I had my Logic Board replaced in my iMac, it would have costed $900 or about 5,140 Kroner.
__________________
17" MacBook Pro 3,1 | 6GB RAM | 240GB SSD ||| Lumix GH2 | Voigtländer 17.5mm F/0.95 | SLR Magic 12mm T/1.6 Wide ||| Vimeo | Soundcloud | Tumblr
John Doe 57 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
iMac Stopped Working Under Guest Account Phil Carter iMac 1 Feb 21, 2014 07:00 AM
Safari, App Store, and iTunes Stopped Working on iMac -iKris- OS X 2 Jan 12, 2014 01:55 PM
iMac ethernet port stopped working wmcyr iMac 4 Dec 4, 2013 08:32 AM
iMac iSight stopped working Dor Levy iMac 0 Aug 1, 2013 01:36 AM
iMac-TV Connection Suddenly Stopped Working TennMike iMac 5 Jul 28, 2012 10:24 AM

Forum Jump

All times are GMT -5. The time now is 11:32 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC