Go Back   MacRumors Forums > iPhone, iPod and iPad > iPad > iPad Tips, Help and Troubleshooting

Reply
 
Thread Tools Search this Thread Display Modes
Old Jun 1, 2010, 04:27 PM   #1
crazycat
macrumors 65816
 
crazycat's Avatar
 
Join Date: Dec 2005
YouTube is slow on the iPad

When I watch a YouTube video on my iPad I would have to wait for it to buffer up and sometimes takes 6 mins to view a 3 min clip.

On my laptop i would just open the video and watch it without any load time, it seems the loading of the video is anywhere from x2 to x5 times faster on a laptop. Is there any king of fix for this problem.

Thanks
__________________
"I don't take kindly to insults"
"Funny, with a face like yours, I'd have thought you'd be used to it by now."
crazycat is offline   0 Reply With Quote
Old Jun 1, 2010, 04:58 PM   #2
BergerFan
macrumors 68020
 
BergerFan's Avatar
 
Join Date: Mar 2008
Location: London, UK.
I'm having exactly the same problem. I tested the YouTube app and the mobile site, and the same thing happens. I found that it's not only YouTube, but any site that streams very high-res video, where I have the same issues.

Again, there's no issue on my mid-range laptop, and hi-def videos work with no buffering issues, on the same Wi-Fi network.
__________________
iPhone 6 Plus: (64GB Space Grey)
iPad Air: (32GB Wi-Fi Space Grey)
Retina MacBook Pro(2012): (2.7GHz i7 - 16GB RAM - 512GB SSD)
BergerFan is online now   0 Reply With Quote
Old Jun 1, 2010, 04:59 PM   #3
Brookzy
macrumors regular
 
Join Date: May 2010
Location: Most definitely not in your back garden. (UK)
Quote:
Originally Posted by crazycat View Post
When I watch a YouTube video on my iPad I would have to wait for it to buffer up and sometimes takes 6 mins to view a 3 min clip.

On my laptop i would just open the video and watch it without any load time, it seems the loading of the video is anywhere from x2 to x5 times faster on a laptop. Is there any king of fix for this problem.

Thanks
I'm having the same issue, albeit sporadically. Sometimes the video loads fine, other times it takes years. Really strange. I do have a fairly slow connection but YouTube's fine on my desktop.

Annoying.
__________________
iMac G5 | iMac (Mid 2011) | MacBook Air (Early 2014) | Time Capsule | Express x4 | random iPods | iPad Air 2 | iPhone 6
Brookzy is offline   0 Reply With Quote
Old Jun 1, 2010, 05:12 PM   #4
martynmc7
macrumors regular
 
Join Date: Dec 2008
Yeah, this is something I've been experiencing, though nothing like 6 minutes of waiting for a 3 minute video. I wonder why this is considering the iPhone app is very quick for me on the same network, and on my laptop. Hopefully this is simply a software issue that can be resolved in a point update, or in OS 4.0.
__________________
13" MacBook Pro, 2.26 GHz, 4GB RAM 250GB HDD; iPhone 3GS, 16GB, White; iPad 16GB, Wi-fi only
martynmc7 is offline   0 Reply With Quote
Old Jun 1, 2010, 06:06 PM   #5
BATTLE BORN
macrumors newbie
 
Join Date: May 2009
my 32g wifi model was delivered today with the same problem
BATTLE BORN is offline   0 Reply With Quote
Old Jun 1, 2010, 06:11 PM   #6
DenniZ
macrumors 6502a
 
Join Date: Oct 2007
Location: Liverpool, UK
Are you guys using the youtube app or using the website.

I have had better luck using the website compared to the app.
DenniZ is offline   0 Reply With Quote
Old Jun 1, 2010, 06:12 PM   #7
Macpowered
macrumors member
 
Join Date: Feb 2009
No problems here.
Macpowered is offline   0 Reply With Quote
Old Jun 1, 2010, 06:16 PM   #8
Arran
macrumors 68000
 
Join Date: Mar 2008
Location: Atlanta, USA
Try turning bluetooth off.

Worked for me - although it might've been coincidence?
Arran is offline   -1 Reply With Quote
Old Jun 1, 2010, 07:03 PM   #9
BergerFan
macrumors 68020
 
BergerFan's Avatar
 
Join Date: Mar 2008
Location: London, UK.
Quote:
Originally Posted by DenniZ View Post
Are you guys using the youtube app or using the website.

I have had better luck using the website compared to the app.
Ive tried both and the problem occurs whenever I try to stream high def video.
__________________
iPhone 6 Plus: (64GB Space Grey)
iPad Air: (32GB Wi-Fi Space Grey)
Retina MacBook Pro(2012): (2.7GHz i7 - 16GB RAM - 512GB SSD)
BergerFan is online now   1 Reply With Quote
Old Jun 1, 2010, 11:36 PM   #10
Maaz
macrumors 6502a
 
Join Date: Mar 2010
It's so annoying.
Maaz is offline   0 Reply With Quote
Old Jun 1, 2010, 11:39 PM   #11
sheppy1
macrumors 6502a
 
Join Date: Sep 2008
I've had this problem once so far and I've watches a tone of YouTube videosmon my iPad, all I did to fix it was to reboot my modem and router and voilą they started working properly again with no waiting for them to buffer
sheppy1 is offline   0 Reply With Quote
Old Jun 1, 2010, 11:42 PM   #12
Star56
macrumors member
 
Join Date: Sep 2007
No problem with my two ipads playing youtube 720p videos.
Star56 is offline   0 Reply With Quote
Old Jun 2, 2010, 01:39 AM   #13
VladM
macrumors regular
 
Join Date: Oct 2008
Same problem here. It's most annoying, because it makes youtube useless to me. I hope a fix for this comes out soon.
VladM is offline   0 Reply With Quote
Old Jun 4, 2010, 12:44 PM   #14
MacRy
macrumors Demi-God
 
MacRy's Avatar
 
Join Date: Apr 2004
Location: England
I'm getting annoyed with this problem too. Constantly having to wait for a video to buffer really takes the "magic" out of the iPad experience. Weirdly I watched an hour long streamed program from the BBC iPlayer site with no buffeting at all and in pretty high quality. Hopefully we will see a fix for this in a future update.
MacRy is offline   0 Reply With Quote
Old Jun 4, 2010, 01:10 PM   #15
jimHdk
macrumors regular
 
Join Date: May 2010
Quote:
Originally Posted by crazycat View Post
When I watch a YouTube video on my iPad I would have to wait for it to buffer up and sometimes takes 6 mins to view a 3 min clip.

On my laptop i would just open the video and watch it without any load time, it seems the loading of the video is anywhere from x2 to x5 times faster on a laptop. Is there any king of fix for this problem.

Thanks
I've had no problems with Youtube on a 64G WiFi iPad through an 802.11g router and a cable modem as well as with an 802.11g router and DSL service.

Check your network speeds with the Speedtest app.
jimHdk is offline   0 Reply With Quote
Old Jun 4, 2010, 01:42 PM   #16
BergerFan
macrumors 68020
 
BergerFan's Avatar
 
Join Date: Mar 2008
Location: London, UK.
Quote:
Originally Posted by MacRy View Post
I'm getting annoyed with this problem too. Constantly having to wait for a video to buffer really takes the "magic" out of the iPad experience. Weirdly I watched an hour long streamed program from the BBC iPlayer site with no buffeting at all and in pretty high quality. Hopefully we will see a fix for this in a future update.
Agreed. The iPlayer interface is attrocious and you can't make a widescreen video fullscreen, but the videos play with high quality and zero buffering - the complete opposite of YouTube(native app or mobile site) on the iPad.
__________________
iPhone 6 Plus: (64GB Space Grey)
iPad Air: (32GB Wi-Fi Space Grey)
Retina MacBook Pro(2012): (2.7GHz i7 - 16GB RAM - 512GB SSD)
BergerFan is online now   0 Reply With Quote
Old Jun 4, 2010, 02:04 PM   #17
ajohnson253
macrumors 68000
 
ajohnson253's Avatar
 
Join Date: Jun 2008
It's usually YouTubes problem, not the iPad.
__________________
Apple & Snapple for Lunch.
iPhone 4S, 13" 1.8GHZ 256GB i7 MBA
ajohnson253 is offline   0 Reply With Quote
Old Jun 4, 2010, 02:48 PM   #18
advan031
macrumors 6502
 
Join Date: Aug 2008
Same here over wifi but it loads quickly over 3G but the quality is s#ht.
advan031 is offline   0 Reply With Quote
Old Jun 4, 2010, 02:49 PM   #19
LordOBoogie
Banned
 
Join Date: Jun 2009
Can't say I've had this issue.
LordOBoogie is offline   0 Reply With Quote
Old Jun 4, 2010, 03:08 PM   #20
hsotnicam8002
macrumors 6502
 
Join Date: Mar 2008
Location: United Kingdom
I have this problem too. I appreciate that my BT extended reach broadband speed is crap (even though I pay the top rate for which others can receive up to 8x faster!). However, YouTube plays OK on my iMac and MacBook. If I remember rightly, when I first received my iPad just over 6 weeks ago YouTube played fine, but over the past few weeks it has become jerky and slow to buffer. Sometimes it doesn't buffer at all and I have to keep pressing play until buffering is complete - what a way to watch a movie - it's like having a stammer in my brain!

I've tried resetting my modem and I've tied turning off bluetooth but neither of these change things. Anyway I want to use my bluetooth earphones so that is not helpful.

The ipad has bee out a while now and though I appreciate that some issues and improvements will take a while, for some IMPORTANT problems Apple need to pull their finger out and get an interim update to solve them!
__________________
iMac 27" Core i7 3.4GHz 16GB 2Tb 10.9.4 | 16GB iPod Nano 7G | 16GB iPhone 5 8B4 | 128GB iPad Mini Retina WiFi 8B4

Last edited by hsotnicam8002; Jun 4, 2010 at 03:09 PM. Reason: Corrections to English
hsotnicam8002 is offline   0 Reply With Quote
Old Jun 4, 2010, 03:15 PM   #21
Streethawk
macrumors 6502
 
Join Date: Feb 2010
Location: Manchester, UK
Me too, it's very slow, I don't think it's a youtube problem, maybe the app has some issues, hopefully it'll be fixed in the next update.
__________________
32gb iPhone 4, 32gb iPad 3G, 8gb iPhone 3G
Streethawk is offline   0 Reply With Quote
Old Jun 4, 2010, 04:48 PM   #22
Treebark
macrumors member
 
Join Date: May 2010
Same problem here, and I think my 3GS has the same issue but don't use it much for youtube.

For those that say to reboot modem/router or test network speed, remember that on other devices (mac desktop, windows computer, macbook) the speed is just fine and videos play right away, yet on the iPad 6 minutes download for a 3 minute video when another device plays it right away is the problem.

And I haven't noticed it on other sites/videos (ABC Player, Netflix, etc.), only youtube.

As far as connection speed, desktop speedtest shows over 10 Mbps, though the test on the iPad only shows 2-3. But even 2-3 shouldn't increase youtube videos only by 1000%.

And it appears to be a somewhat common problem, just google "youtube slow on ipad" to see lots of complaints.

Last edited by Treebark; Jun 4, 2010 at 04:58 PM.
Treebark is offline   0 Reply With Quote
Old Jun 4, 2010, 05:04 PM   #23
Loves2spoon
macrumors 65816
 
Loves2spoon's Avatar
 
Join Date: Jun 2010
Location: California
Quote:
Originally Posted by crazycat View Post
When I watch a YouTube video on my iPad I would have to wait for it to buffer up and sometimes takes 6 mins to view a 3 min clip.

On my laptop i would just open the video and watch it without any load time, it seems the loading of the video is anywhere from x2 to x5 times faster on a laptop. Is there any king of fix for this problem.

Thanks

Sorry to hear your troubles, I've had a wonderful youtube experience. Videos buffer for 2-3 seconds and plays very quickly. Have you tried resetting your modem/router?
Loves2spoon is offline   0 Reply With Quote
Old Jun 4, 2010, 05:11 PM   #24
mcdj
macrumors 604
 
mcdj's Avatar
 
Join Date: Jul 2007
Location: NYC
There has been discussion of YouTube throttling speeds in major traffic areas. I live in NYC and even on my MacBook I get buffering issues regularly. So it could be partially a regional problem.
mcdj is offline   0 Reply With Quote
Old Jun 4, 2010, 07:50 PM   #25
Grilloman
macrumors newbie
 
Join Date: Jan 2010
Quote:
Originally Posted by crazycat;
When I watch a YouTube video on my iPad I would have to wait for it to buffer up and sometimes takes 6 mins to view a 3 min clip.

On my laptop i would just open the video and watch it without any load time, it seems the loading of the video is anywhere from x2 to x5 times faster on a laptop. Is there any king of fix for this problem.

Thanks
same here I thought I was the only one. I stil dont know why it only happen with youtube other streaming works like a charm, for example Air video.
Grilloman is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPad > iPad Tips, Help and Troubleshooting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Posting slow mo to YouTube ? /dev/toaster iPhone 3 Sep 24, 2013 08:43 PM
YouTube very slow on iPhone 5 Sixpack446 iPhone and iPod touch Apps 92 Jul 10, 2013 09:12 AM
YouTube loads slow WesRocks360 iMac 12 Apr 15, 2013 10:41 AM
Slow loading YouTube videos RYE-RYE MacBook Pro 1 Apr 3, 2013 02:37 PM
Slow loading Youtube videos RYE-RYE Mac Pro 1 Apr 3, 2013 01:35 PM

Forum Jump

All times are GMT -5. The time now is 06:22 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC