Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone

Reply
 
Thread Tools Search this Thread Display Modes
Old Jul 7, 2010, 01:12 PM   #1
Zorn
macrumors 6502
 
Join Date: Feb 2006
Location: Ohio
Gmail Exchange account always sends mail using my full name

I have my Gmail account set up on my iPhone as Exchange, to get push email. The issue I am having:

In my Gmail account settings, I have it set to send mail using only my initials, so that when I send a message to someone they will only see (A J) for example. When sending emails from my browser in gmail, this works fine. If I go to my iPhone, and send a response to an email thread, it will send from my full name. Any emails that I send from my iPhone automatically show my full name. Is there some type of account setting for this? I don't want it to use my full name when I send email from the phone. I have looked everywhere and don't see any setting for this. I have also called Apple support and they have no idea.

Anyone able to help?

Update: Problem is solved and here is the fix:

Quote:
Originally Posted by poose22 View Post
Ok, I just figured out how to correct this problem. You have to log into the gmail website to do this.

-Log into gmail.com
-click on settings on the top
-click on the 'Accounts and Imports' tab
-scroll down and click on 'Google Account settings'
-towards the top left, click on 'edit your personal info'
-here you can change your first and last name. You will need to put something into the Last Name field. You can put in just an initial if you want
-make sure to click SAVE at the bottom

I myself changed the last name to just an initial, and when I sent an email from my iPhone, it now shows just the initial instead of the full last name.

My gmail on my iPhone is set up through gmail's exchange server too, just so everyone knows.

Last edited by Zorn; Jul 7, 2010 at 03:59 PM.
Zorn is offline   0 Reply With Quote
Old Jul 7, 2010, 01:57 PM   #2
asdff
macrumors member
 
Join Date: Jun 2010
Location: california
i'm new to iphones so my apologies if this isn't the answer you're looking for as i'm not sure what 'exchange' is

for mine, when you go into settings -> mail -> gmail -> account info

there is a slot for "name" where it should read your full name. change this to what you want (ie. your initials) and it should send using that... test by sending to a different account you have...
__________________
iphone 6+ - 64gb gold - tmo - ordered 9/15 - order status: backordered - no shipping info - no cc charge
current: 2012 mb air | ipad 3 | iphone 5
retired: 12" powerbook g4 | mac mini | iphone4
asdff is offline   0 Reply With Quote
Old Jul 7, 2010, 02:00 PM   #3
IndustrialSpace
macrumors 6502a
 
Join Date: Dec 2009
Location: somewhere
You can definitely change this. I know I had the same issue.
IndustrialSpace is offline   0 Reply With Quote
Old Jul 7, 2010, 02:02 PM   #4
zacharace
macrumors member
 
Join Date: Jan 2009
Location: Bexley, OH, USA
Quote:
Originally Posted by asdff View Post

settings -> mail -> gmail -> account info

there is a slot for "name" where it should read your full name. change this to what you want (ie. your initials) and it should send using that... test by sending to a different account you have...
Just verified that same path. There's probably just a discrepancy between that field on the iPhone and the one in your (Web-based) Gmail settings.
zacharace is offline   0 Reply With Quote
Old Jul 7, 2010, 02:06 PM   #5
vincenz
macrumors 601
 
vincenz's Avatar
 
Join Date: Oct 2008
Location: New York
Been having the same problem myself. However, there's no slot for "name" when you go into Account Info.

Anyone else have suggestions?
vincenz is offline   0 Reply With Quote
Old Jul 7, 2010, 02:28 PM   #6
nebo1ss
macrumors 68000
 
Join Date: Jun 2010
Quote:
Originally Posted by Zorn View Post
I have my Gmail account set up on my iPhone as Exchange, to get push email. The issue I am having:

In my Gmail account settings, I have it set to send mail using only my initials, so that when I send a message to someone they will only see (A J) for example. When sending emails from my browser in gmail, this works fine. If I go to my iPhone, and send a response to an email thread, it will send from my full name. Any emails that I send from my iPhone automatically show my full name. Is there some type of account setting for this? I don't want it to use my full name when I send email from the phone. I have looked everywhere and don't see any setting for this. I have also called Apple support and they have no idea.

Anyone able to help?
The name that is sent with your email is the one you have set up in Contacts. Since you also have your email address held there it associates the name. You can change the name in Contacts or delete the email address from contacts.
nebo1ss is offline   0 Reply With Quote
Old Jul 7, 2010, 02:40 PM   #7
poose22
macrumors member
 
Join Date: Jan 2010
Quote:
Originally Posted by nebo1ss View Post
The name that is sent with your email is the one you have set up in Contacts. Since you also have your email address held there it associates the name. You can change the name in Contacts or delete the email address from contacts.
where is this "contacts" you speak of? I checked on gmails website and my phone and if you're referring to my own contact....I dont have one set up
poose22 is offline   0 Reply With Quote
Old Jul 7, 2010, 02:40 PM   #8
hazeydavey
macrumors member
 
Join Date: Jun 2010
Can someone explain this to me?

I have to accounts set up as push. My Work acct and a gmail account.

I have the gmail account set as the default.

But, no matter what I do, if someone write my gmail account, and I reply, even with gmail as reply to...it still goes through with my work email as the 'reply to' address.
hazeydavey is offline   0 Reply With Quote
Old Jul 7, 2010, 02:41 PM   #9
maximus96
macrumors 6502a
 
maximus96's Avatar
 
Join Date: Sep 2007
Log into Gmail.com and change your name there. Your phone will use whatever you put there as your name.
maximus96 is offline   0 Reply With Quote
Old Jul 7, 2010, 02:53 PM   #10
Zorn
Thread Starter
macrumors 6502
 
Join Date: Feb 2006
Location: Ohio
Quote:
Originally Posted by nebo1ss View Post
The name that is sent with your email is the one you have set up in Contacts. Since you also have your email address held there it associates the name. You can change the name in Contacts or delete the email address from contacts.
There is no name field for me showing up in Contacts or under gmail account info on the iPhone.

Quote:
Originally Posted by maximus96 View Post
Log into Gmail.com and change your name there. Your phone will use whatever you put there as your name.
On Gmail this is already changed to only be my initials.
Zorn is offline   0 Reply With Quote
Old Jul 7, 2010, 02:53 PM   #11
nebo1ss
macrumors 68000
 
Join Date: Jun 2010
Quote:
Originally Posted by poose22 View Post
where is this "contacts" you speak of? I checked on gmails website and my phone and if you're referring to my own contact....I dont have one set up
I just tried this three times. I have my own name and email address set up on my iphone in the iphone contact list. I changed my name three times by mis-spelling or changing full name to initial. Each email which was sent to a spare email account Gmail picked up the name as spelt in the contact list every time.
If you have not set up your own name in the contact list then I have no idea what Gmail on the iphone does.
nebo1ss is offline   0 Reply With Quote
Old Jul 7, 2010, 03:06 PM   #12
poose22
macrumors member
 
Join Date: Jan 2010
Ok, I just figured out how to correct this problem. You have to log into the gmail website to do this.

-Log into gmail.com
-click on settings on the top
-click on the 'Accounts and Imports' tab
-scroll down and click on 'Google Account settings'
-towards the top left, click on 'edit your personal info'
-here you can change your first and last name. You will need to put something into the Last Name field. You can put in just an initial if you want
-make sure to click SAVE at the bottom

I myself changed the last name to just an initial, and when I sent an email from my iPhone, it now shows just the initial instead of the full last name.

My gmail on my iPhone is set up through gmail's exchange server too, just so everyone knows.
poose22 is offline   0 Reply With Quote
Old Jul 7, 2010, 03:56 PM   #13
vincenz
macrumors 601
 
vincenz's Avatar
 
Join Date: Oct 2008
Location: New York
Quote:
Originally Posted by poose22 View Post
Ok, I just figured out how to correct this problem. You have to log into the gmail website to do this.

-Log into gmail.com
-click on settings on the top
-click on the 'Accounts and Imports' tab
-scroll down and click on 'Google Account settings'
-towards the top left, click on 'edit your personal info'
-here you can change your first and last name. You will need to put something into the Last Name field. You can put in just an initial if you want
-make sure to click SAVE at the bottom

I myself changed the last name to just an initial, and when I sent an email from my iPhone, it now shows just the initial instead of the full last name.

My gmail on my iPhone is set up through gmail's exchange server too, just so everyone knows.
I thought it might have something to do with Google Accounts, but didn't think to look there. Thanks a lot for figuring it out! Worked perfectly.
vincenz is offline   0 Reply With Quote
Old Jul 7, 2010, 03:59 PM   #14
Zorn
Thread Starter
macrumors 6502
 
Join Date: Feb 2006
Location: Ohio
Quote:
Originally Posted by poose22 View Post
Ok, I just figured out how to correct this problem. You have to log into the gmail website to do this.

-Log into gmail.com
-click on settings on the top
-click on the 'Accounts and Imports' tab
-scroll down and click on 'Google Account settings'
-towards the top left, click on 'edit your personal info'
-here you can change your first and last name. You will need to put something into the Last Name field. You can put in just an initial if you want
-make sure to click SAVE at the bottom

I myself changed the last name to just an initial, and when I sent an email from my iPhone, it now shows just the initial instead of the full last name.

My gmail on my iPhone is set up through gmail's exchange server too, just so everyone knows.
This solution definitely works. Thank you!
Zorn is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Mail doesn't automatically receive mail from Exchange Account swiftaw OS X Mavericks (10.9) 2 Oct 26, 2013 12:01 AM
Gmail in Mail.app as exchange? e-r-a-n OS X 10.8 Mountain Lion 15 Jan 9, 2013 02:41 PM
Mail.app, iOS Mail, and Gmail Account Archive Feature kepardue OS X 10.8 Mountain Lion 2 Nov 13, 2012 11:19 AM
Flagging gmail messages using an Exchange account setup j-a-x iOS 6 0 Sep 22, 2012 10:05 PM
How many Google Sync (Exchange) Gmail account on one iPhone? Xystence iPhone 0 Jun 29, 2012 12:02 AM

Forum Jump

All times are GMT -5. The time now is 07:54 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC