Access Denied

Discussion in 'Web Design and Development' started by kjdenison, Feb 18, 2006.

  1. macrumors 6502

    Joined:
    Jul 14, 2003
    Location:
    Chicago, IL
    #1
    I have been sending files to netfirms for about 2 years now the same exact way. All of a sudden, as I put my whole site up, many images now are empty on the remote server. I can test the site locally and it works perfect, but when i put it to the remote server it no longer works. This is the error i get on some files (when transferring from dreamweaver 8):

    error occurred - An FTP error occurred - cannot put 1.jpg. Access Denied. The file may not exist, or there could be a permission problem.

    I may get this error only on 1/20 files, but when I go to check my site live, none of the images are actually uploaded. My url is http://www.kurtdenison.com some pages have images still, and others don't, even though i put the entire site up like i normally do. I have no idea what to do!!

    Netfirms says - the format of the image tag code must be correct
    - the path to the image file must be correct
    - the image file name must be correct (file names are case sensitive)
    - the image file must be uploaded to the appropriate folder/directory on the Netfirms server

    but I am not doing anything differently then i have been in the last 2 years where everything uploaded and has worked perfectly. Any help would be extremely appreciated.

    Here is a log:
    Started: 2/17/06 4:11 PM

    DecemberSite_Index_01.gif - Put operation successful
    DecemberSite_Index_02.gif - error occurred - An FTP error occurred - cannot put DecemberSite_Index_02.gif. Access Denied. The file may not exist, or there could be a permission problem.
    DecemberSite_Index_03.jpg - error occurred - An FTP error occurred - cannot put DecemberSite_Index_03.jpg. Access Denied. The file may not exist, or there could be a permission problem.
    DecemberSite_Index_04.gif - error occurred - An FTP error occurred - cannot put DecemberSite_Index_04.gif. Access Denied. The file may not exist, or there could be a permission problem.
    DecemberSite_Index_05.gif - Put operation successful
    DecemberSite_Index_06-over.gif - Put operation successful
    DecemberSite_Index_06.gif - Put operation successful
    DecemberSite_Index_07-over.gif - Put operation successful
    DecemberSite_Index_07.gif - Put operation successful
    DecemberSite_Index_08-over.gif - Put operation successful
    DecemberSite_Index_08.gif - Put operation successful
    DecemberSite_Index_09-over.gif - Put operation successful
    DecemberSite_Index_09.gif - Put operation successful
    DecemberSite_Index_10-over.gif - Put operation successful
    DecemberSite_Index_10.gif - Put operation successful
    DecemberSite_Index_11-over.gif - Put operation successful
    DecemberSite_Index_11.gif - Put operation successful
    DecemberSite_Index_12-over.gif - Put operation successful
    DecemberSite_Index_12.gif - Put operation successful

    File activity incomplete. 3 file(s) or folder(s) were not completed.
    Files updated: 16

    Files with errors: 3
    DecemberSite_Index_02.gif
    DecemberSite_Index_03.jpg
    DecemberSite_Index_04.gif

    Finished: 2/17/06 4:12 PM
     
  2. macrumors 6502a

    Joined:
    Oct 13, 2004
    Location:
    UK
    #2
    Are you using Dreamweaver to transfer your files?
     
  3. thread starter macrumors 6502

    Joined:
    Jul 14, 2003
    Location:
    Chicago, IL
    #3
    yes i am. dreamweaver 8 actually.
     
  4. macrumors 6502a

    Joined:
    Oct 13, 2004
    Location:
    UK
    #4
    I've had more than a few problems using DW to upload - not helped by the fact that I've only just got back into sorting out a website after a 2 year break, so I'm very rusty. I assumed it was me at fault.
    After reading of a few problems here and elsewhere I downloaded Cyberduck - far more reliable, always connects. DW justs sits there saying 'connection refused' - bloody useless.
     
  5. thread starter macrumors 6502

    Joined:
    Jul 14, 2003
    Location:
    Chicago, IL
    #5
    dreamweaver connects just fine for me, somewhere in the process though something is screwing up. I'm not sure how to use cyberduck, but i will check it out
     
  6. macrumors 6502a

    Joined:
    Oct 13, 2004
    Location:
    UK
    #6
    Just had a look at your site and decided that I'm not at all qualified to help you! Very nice work.
    If its any consolation I've just had a quick play with Cyberduck on a couple of updates and the same thing has happened to me - works locally, all the files uploaded and in the right locations, and yet one image refuses to show. I had to delete the page and the image from the server, rebuild the page in DW with a new image name and then put them back. And I don't know why it worked 2nd time round, or failed to work first time round.

    ps that is a beautiful log cabin - are you able to tell me where it is?
     
  7. macrumors 601

    zimv20

    Joined:
    Jul 18, 2002
    Location:
    chicago
    #7
    the first thing to do is take DW out of the equation. if you know how, run the command line ftp and put the file manually. that'll let you know if the problem is actually with permissions or just a DW cockup.

    oh, if you don't know command line ftp, i guess now's a good time to learn :)
     
  8. thread starter macrumors 6502

    Joined:
    Jul 14, 2003
    Location:
    Chicago, IL
    #8
    could you enlighten me a bit? I tried using cyber duck to put the files and it locked up on me. Something so simple has become a huge confusing mess, i don't understand
     
  9. macrumors 68030

    superbovine

    Joined:
    Nov 7, 2003
    #9
  10. thread starter macrumors 6502

    Joined:
    Jul 14, 2003
    Location:
    Chicago, IL
    #10
    the web server is unix. Thanks im gonna look these over now.
     
  11. thread starter macrumors 6502

    Joined:
    Jul 14, 2003
    Location:
    Chicago, IL
    #11
    index.htm - Put operation successful
    index.html - Put operation successful
    index_02.jpg - Put operation successful
    index_03.jpg - Put operation successful
    index_04.jpg - error occurred - An FTP error occurred - cannot put index_04.jpg. Access Denied. The file may not exist, or there could be a permission problem.
    index_06-over.gif - Put operation successful
    index_06.gif - Put operation successful
    index_07-over.gif - Put operation successful
    index_07.gif - Put operation successful
    index_08-over.gif - Put operation successful
    index_08.gif - Put operation successful
    index_09-over.gif - Put operation successful
    index_09.gif - Put operation successful
    index_10-over.gif - Put operation successful
    index_10.gif - Put operation successful
    index_11-over.gif - Put operation successful
    index_11.gif - Put operation successful
    index_12-over.gif - Put operation successful
    index_12.gif - Put operation successful

    File activity incomplete. 1 file(s) or folder(s) were not completed.
    Files updated: 18

    Files with errors: 1
    index_04.jpg

    No matter how i rename the files, the image 4 will is always the one that says it has the permission problem. It is the largest of the files, at 35k. Yet when i check online, none of the images are up, even though it said successful for them all.
     
  12. macrumors 6502a

    Joined:
    Jun 17, 2003
    #12
    Looks like either a file named "index_04.jpg" already exists on the server and the file on the server does not have write permissions for you, or the account on the server has a file quota set and the "index_04.jpg" file would push your account over the quota. But, the subsequent files are all smaller than index_04.jpg and so they fit within the quota.

    A file quota limits the amount of space that can be used by a particular account on the system... effectively limiting the amount of disk space you can consume on the server.
     
  13. thread starter macrumors 6502

    Joined:
    Jul 14, 2003
    Location:
    Chicago, IL
    #13
    When i check on netfirms, my account says i am only using 500/6000MB, and monthly bandwidth is 554/307200 MB. The file is brand new, and there isn't another one named that either. Should i maybe remove some stuff from my account or what?
     
  14. macrumors 601

    zimv20

    Joined:
    Jul 18, 2002
    Location:
    chicago
    #14
    we're really all over the map here. is it a file problem? a permissions problem? a diskspace problem? a dreamweaver problem? an ftp problem? a bandwidth problem?

    variables must be eliminated. get your symptom down to a single, repeatable example. your best bet, imo, is to learn command line ftp and try to put the problem file, all by itself, to the server. trying to put a bunch of files all at once, presumably from DW, doesn't seem to be getting you anywhere.
     

Share This Page