Accessing Linux Samba Share?

Discussion in 'Mac Apps and Mac App Store' started by elbirth, Sep 3, 2006.

  1. elbirth macrumors 65816

    Joined:
    Jan 19, 2006
    Location:
    North Carolina, US
    #1
    After quite a bit of pain with getting a RAID 5 array setup in SuSE (eventually had to go back to SuSE 10.0 instead of 10.1 due to driver support in the kernel) I have a SuSE 10.0 machine running on my home network with a Samba share pointing to the RAID.

    Now I can't seem to figure out how to access it as any user other than "root". I can get into the share both in the Finder and smbclient in the terminal if I login as root, but if I try logging in as one of the users I setup on the Linux box, I get errors.
    If using the Finder, I get an error saying the alias could not be opened because the original item cannot be found. It gives the option to delete the alias, fix it, or just say OK.
    In the terminal, I get an error saying:

    Domain=[LINUX] OS=[Unix] Server=[Samba 3.0.20-4-SUSE]
    tree connect failed: NT_STATUS_ACCESS_DENIED

    While logging in and accessing it via root would be fine, I'd rather log in as a normal user just for security purposes, among other things.

    Has anyone encountered this before and/or know how I can get it working properly?
     
  2. iTwitch macrumors 6502a

    iTwitch

    Joined:
    Mar 30, 2006
    Location:
    East of the Mississippi
    #2
    In your smb.conf file do you have a user section set up?

    [user]
    path=/home/user

    Also, did use set the password?

    #smbpasswd -a user
     
  3. elbirth thread starter macrumors 65816

    Joined:
    Jan 19, 2006
    Location:
    North Carolina, US
    #3
    I kept thinking I probably had to enable each user somehow, but I wasn't seeing it anywhere in the Samba portion of the YaST control center in SuSE...
    doing it via the terminal worked, thanks a lot!
     
  4. elbirth thread starter macrumors 65816

    Joined:
    Jan 19, 2006
    Location:
    North Carolina, US
    #4
    rather than starting a new thread, I'll try posting here again first... though this may be more appropriate on a Linux forum


    the way I'm trying to set this up is that on the raid array there are 4 top-level folders- 3 of those are individual user folders that I want only 1 person to have read/write access to each. This works just fine...
    The other folder I want all 3 users to be able to to read/write from. While all 3 users can do this (generally), whenever a given user puts a file in this "public" folder, the other users don't have write access to it. I can change the permissions for that file, but I'd rather it give full access to all users by default rather than requiring user intervention.

    Is there a simple option I'm missing again, or is there more to this?
     
  5. iTwitch macrumors 6502a

    iTwitch

    Joined:
    Mar 30, 2006
    Location:
    East of the Mississippi
    #5
    Check and see if the 'create mask' option suites your needs, I do remember having a similar problem but I'm not sure of the fix I implemented.

    Anything to help a Apple along is cool in my book. :)
     
  6. elbirth thread starter macrumors 65816

    Joined:
    Jan 19, 2006
    Location:
    North Carolina, US
    #6
    hehe, thanks :)

    I have this in the smb.conf file for the shared folder

    read only = No
    force group = users
    inherit acls = Yes
    create mask = 0777
    directory mask = 0777

    I actually just added the 2 mask entries after I made that last post, but whenever I add a file, it gets a 0766 permission... but folders do seem to get 0777.

    While I suppose I don't *have* to allow other uses to execute a given file, I'd still like to know why it doesn't seem to be following what I tell it to do.
     
  7. iTwitch macrumors 6502a

    iTwitch

    Joined:
    Mar 30, 2006
    Location:
    East of the Mississippi
    #7
    It's probably a security precaution? Something else you might try is creating a sym link in folders 1,2 and 3 pointing to folder 4.
     

Share This Page