1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Ad-Hoc App Installation Problem

Discussion in 'iPhone/iPad Programming' started by Futhark, Aug 24, 2013.

  1. macrumors 6502a


    I have created an app that is used by a few work mates and myself, it isn't going to be submitted in the App Store, I have it uploaded onto my server and use the ad-hoc procedure to allow my friends to click on a web link which installs the app onto their devices but this procedure has problems under iOS 7 which i have reported to apple but i'm wondering if someone knows of a fix in the mean time?

    When you click the link to install, the app installing icons appears and after a short time a second icon appears with the proper app icon but the install one does not disappear (see image below) even if i delete the app the installing icon stays. Any ideas on how to fix this would be much appreciated.

  2. macrumors member

    The bug doesn't happen for me, ad-hoc deployment has been working perfectly for all our iOS 7 test devices.
  3. macrumors demi-god

    Try reinstalling your provision certificate.

    I had this problem with Test Flight when messing with it a while back in iOS 6.

    The problem I had seemed to be a mismatch between the provision certificate installed on the device and the one used to do the ad-hoc deployment.

    Probably not a helpful answer
  4. macrumors 6502a


    I'm still having this issue even out of Beta, Can anyone suggest a fix?
  5. macrumors 68040


    Purge all the existing profiles (relevant to this distro) from the device and try again. We had the same problem provisioning internal builds of our app to iOS7 devices (we actually use testFlight, but the underlying process is the same).

    Cleared out the existing profiles (Settings >> General >> Profiles) and everything worked again, just perfect. I'm assuming the profiles that were migrated from iOS6 aren't compatible, so purging and reinstalling corrects this (allows iOS7 to sign/install them correctly).
  6. macrumors 6502a


    I've deleted the app off my device leaving the blank icon still on screen because i can't remove it as no x there, I've deleted all profiles from my device then created a brand new ad-hoc profile and archived the app with this new profile and then uploaded it to my server and when downloading i still have 2 icons, my device has the proper icon which is a proper working app while the other icon is an installing icon?

    This is very strange and annoying :confused:
  7. macrumors newbie

    Same problem....

    We're experiencing the same problem too. I've done what you have suggested on my iPhone and removed the profile but it still has the icon there. I have had to 'Erase content and settings' on my iPhone many times to test out various different things to try and get this 'Installing...' icon to disappear. Doing the erase also removes the profiles.

    Is there anything to do with provisioning certificates in XCode? Is it something that could have been missed off when rebuilding the app? The profile I'm using has a start date of Feb 2013 on it which would suggest that it's not created a new one for iOS 7.

    Any help would be greatly appreciated. This is delaying a release to a customer :-(
  8. RitaColim, Oct 8, 2013
    Last edited: Oct 9, 2013

    macrumors newbie

    Have de same problem!! :(
    I created a ticket in Apple ... awaiting for solution!
  9. macrumors 68040


    Hi folks!

    I'm not encountering anything like a lingering, incomplete install. I've had those when an app doesn't have a correct profile (when distributing internally), but they can be cancelled/deleted.

    In fact, we're starting to "white label" our app into vertical and I'm going to build a custom version for TestFlight deployment this morning - if I run into any issues (and more importantly, solve them), I'll post back. Like I mentioned above, when I had distribution issues, simply deleting all the profiles on my iOS7 device fixed it up.

    I don't have a ton of time, but if someone wanted me to download/test, I'd be willing to give it a shot :)
  10. macrumors newbie


    Please post your solution if you ever solve this issue, because I have the same problem and can't solve it.
  11. macrumors newbie

    I am having this same problem. Has anybody figured out consistently what causes it?
  12. macrumors 6502a

    had the same problem, installing our app by OTA (which we get the IPA by Ad-Hoc)

    but i believe its an Ad-Hoc problem, ive sent requests to apple to fix this problem, but i think we need to send a volume of these type of bug reports for them to actually take notice.

    yeah its pissing me off.
  13. macrumors newbie

    Hi Guys,

    I've had the same problem, for me the problem was that I used a different bundle-identifier in the app than I specified in the plist.
    The solution was obviously to make them the same.
    Hope it helps some of you.
  14. macrumors newbie

    Me too: we've got this same problem. Tried deleting profiles on device, ensured signing with same distribution provisioning profile, checked bundle identifiers, and other suggestions on web. No luck. Filed bug report #15473961.

    Found crude, manual workaround to remove the "dead" installation icon: restart the download and, once it begins, quickly delete the icon. That is to say that it seems to be deletable when it is downloading but dies after installation.
  15. macrumors regular

    LOL, that crude manual way works great!!!
  16. macrumors newbie

    We fixed this!!! The plist file was referring the the wrong thing! It had been updated with a new app name and that hadn't been sorted in the plist file!
  17. macrumors 6502a


    which is the best solution?

    because we constantly update, so the names won't be same so the dead icons are App1.2 but now ill only be able to download App1.5, i technically can Download 1.2 again if i manually change it on the website.

    but i want to avoid that tedious task, any other way to delete these dead icons?

Share This Page