After SSD Install, default apps revert on restart

Discussion in 'OS X Mountain Lion (10.8)' started by M. Malone, May 30, 2013.

  1. M. Malone macrumors 6502a

    M. Malone

    Mar 11, 2004
    Hello Everyone.

    I'm on the latest update of Mountain Lion.

    So I installed an SSD Samsung 840, and Enabled Trim.

    Now the problem is, I have a default set of apps I always use.

    Chrome for browsing
    Quicktime to play all MP3s

    When I restart my computer, everything goes back.


    Safari becomes the default browser
    iTunes becomes the default MP3 player

    What's going on?

    I do not have FileVault enabled.

  2. MarcBook macrumors 6502a


    Jul 13, 2008
    Jersey, Channel Islands
    Have you tried the usual? Permissions Repair.
  3. M. Malone thread starter macrumors 6502a

    M. Malone

    Mar 11, 2004
    I am reviving this thread to explain to others my issue.

    The hard drive was faulty. It was a Samsung 840 500GB

    So I installed the SSD and start up times improved, it was snappier, quieter.

    But I was faced with the above issue.

    I verified disk permissions which had so many issues and corruptions.

    This was surprising because I didn't clone my older drive. It was a totally clean install.

    I went ahead and repaired, but I still had the same issue of default apps not staying default after a restart.

    I formatted the hard drive and started fresh again, it worked fine after that for about a week. Then the stutters and slow downs happened.

    My computer would crash right when I woke it from sleep and it forced me to hold down the power button.

    This happened up until yesterday. When I restarted, I got the folder with question mark.

    I verified the hard drive was dead. I have switched back to the old hard drive and await a replacement from Samsung.

    Good luck!

    PS, I had trim enabled from day 1

Share This Page