1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

AirDrop not working

Discussion in 'OS X Mountain Lion (10.8)' started by DianeK, Jun 12, 2013.

  1. macrumors regular

    So far my "up"grade to ML has been a huge disappointment (dropped wi-fi, squirrelly desktop, hidden menus, etc)

    One of the reasons my husband urged me to change from SL was so we could use airdrop, but we cannot see each other in airdrop:mad:
    We both have ML, a 2010 Macbook Pro and and 2011 iMac
    We are both on the same wifi network
    We are both using AFP protocol for sharing
    We both have AirDrop open
    We have both reset our Apple ID's as suggested
    We have both force quit Finder as suggested.

    Anything else to try???

  2. macrumors regular

    Hmmm, over 200 views but no replies.
    Does this mean there is no fix?
    Did I not provide sufficient details?
  3. macrumors regular

    Today I did research on how to do a fresh install of OSX ML because Airdrop was still not working and I thought this may be the route we have to go. We left the house having done nothing to either of our computers. When we came home this afternoon, Airdrop decided to work. I stress we did nothing except the "fixes" a couple of days ago that made no difference when we did them. Perhaps our computers felt the impending doom of wiped drives (cue spooky music) and decided to smarten up. Who knows. I will post back if it goes sideways again.
  4. macrumors regular

    Well, that was a short-lived triumph. We both exited Airdrop then tried 30 minutes later...now we can't see each other again. The only thing that I think was different half an hour ago is that we tried it right after we both woke our computers out of sleep mode and this was the first thing we did with them. Makes me want to resurrect my Windows laptop.
  5. macrumors regular

    More info for anyone who cares to help.
    When I right-click on Airdrop in the Finder panel and select "Get Info", I get the spinning dial with the word "fetching" but that never stops and more info does not appear. This is happening on both computers. Could this be diagnostic of something? Please?
  6. macrumors 6502

    Hi, I see you said you have an imac connected to your wifi network. Is it also connected with a Lan cable. If so remove the Lan cable from the back of the iMac as this could be causing your problem, Open terminal type "Killall Finder" (Without Quotes) and hit the return key, quit teminal and reopen aidrop in finder. another thing to try would be enabling file sharing from the sharing preferences pane on both the Imac and MBP. Let me Know how you get on.

  7. macrumors regular

    Thanks for chiming in.
    1. No, the iMac is not cable connected, it is totally wi-fi. The only thing ethernet connect to the ISP's wi-fi modem/router are the Time Capsule and the :apple:Tv. My husband is in the same room as the modem and TC, I am in the next room.

    2. We spent two hours with Apple Support yesterday with no resolution and all your above suggestions were done plus many more others. However, despite no resolution, we did learn more about the problem:

    (a) Disconnecting the TC to only use the ISP's wifi modem did not help so as far as we are concerned, this eliminated the idea of interference due to having two networks (modem and TC) causing the problem since using a single one didn't solve the problem. Despite this :apple: Support suggested we get the wifi modem bridged.

    (b) Rebooting both computers and immediately going to AirDrop causes it to work....for awhile. If we shut down AirDrop and open it again, it won't work without reboots.

    (c) After the reboot with AirDrop still working, we just left it open and after about 5 minutes my iMac icon disappeared from my husband's MBP but I could continue to see him. And even though he couldn't see me, I could drop a file on his icon and my icon would momentarily re-appear on his screen long enough for him to accept the file and then I disappeared again, never to spontaneously re-appear.

    (d) If we leave his MBP running, but reboot my iMac, AirDrop will work again...for awhile, then I disappear. However, leaving my iMac running and rebooting his MBP does not make AirDrop work again. This tells us the problem lies with my computer solely. And this does not surprise me because since the upgrade to ML last week my iMac is doing a whole bunch of squirrelly things.:(

    This is still an open case with :apple: Support so I will post back here if we get any resolution.

  8. macrumors 65816


    Have you tried making a new user account on your iMac and seeing if it works for a new user? If that's the case then the problems is a wonky setting on your account.
  9. macrumors regular

    Thanks for that suggestion. I will try that tomorrow...just got back from the symphony and I don't like to tackle computer problems when it's late and I am tired. Interesting that :apple: tech support didn't suggest trying that - they had us doing a bizillion other things!
  10. macrumors regular

    Well, I set up a new user account and got the same symptoms --> AirDrop worked for awhile after the reboot, but stopped working after that for the new user :(
  11. macrumors 65816


    Hmmmm very odd indeed. Since you complained about other things not working in your first post and it seems like you've tried most things my next suggestion would be to re run the 10.8.4 update using the combo update, it's possible that your upgrade to 10.8.4 was just a bad install.

  12. macrumors regular

    I moved my iMac to the same desk that my husband's MBP, Cisco, Time Capsule sit on. Same symptoms --> AirDrop worked for a brief period after the reboot but would not work after that. I assume this eliminates a signal strength issue. :( Also, sitting right next to everthing didn't improve internet connectivity speed and stability either. Running out of ideas.
  13. madmacfan, Jun 17, 2013
    Last edited: Jun 17, 2013

    macrumors 6502

    Hi, I noticed you said you have a time capsule next to the iMac. Is the iMac connected to the time capsule wirelessly or via a cable. Try removing the time capsule temporarily from your entire wifi network if wireless (or pull the cable if you're using a wired connection) reboot both macs and open airdrop again to see if it has made any difference.

    If that fails then it could be an issue with the ip address of both macs on the network. Is your Cisco a cable modem, and if so, is this also supplying you with wifi, or do you use a separate router for wireless access. Check the technical settings of your router, as it may be blocking access to peer 2 peer (p2p) connections. Let me know how you get on.
  14. DianeK, Jun 17, 2013
    Last edited: Jun 17, 2013

    macrumors regular

    I have been avoiding this because I assume I have to wipe my drive to redo the ML install and being a newbie....well, I just don't know how to do this to be honest. If I can just do the combo install overtop of my current install I might be more comfortable...is that possible?
    Just as an aside I upgraded from SL to ML 10.8.3 just a few days before 10.8.4 was released and the issues started right away with 10.8.3. I didn't do a combo install of 10.8.3 - didn't even notice the option. I waited several days before upgrading to 10.8.4 to give the computer time to "settle down" before subjecting it to another upgrade and again did not use the combo option. I know, I know you are probably thinking what a "ditz" :eek:


    Suggestion #1: Removing the TC...tried that 2 days ago without resolution of the problem.
    Suggestion #2: Cisco is a cable modem that also supplies us with wifi so we have two wifi's in the house - Cisco and TC. Cisco is 2.4Ghz on channel 6, TC is 2.4Ghz on channel 1 and 5 Ghz on channel 149.
    Can you give me some detailed instructions on how to check the technical settings of the Cisco and TC and how to identify if either one is blocking p2p connections?
    Just to let you know, we are planning on putting our Cisco in bridge mode next week when I husband gets back home...I don't want to do that myself.
    And AirDrop always works for about 5 minutes right after I reboot my computer, then stops working - my iMac disappears from the MBP's AirDrop window. Then if we close AirDrop and re-open it, I simply won't show up at all, not even for a nanosecond.
    Thank you.
  15. macrumors 6502

    For checking the p2p status, you need to look at the back or base of your router. There should be an ip listed which you put into your browser to access the settings along with a default username and login password. I'm not sure if the ip for cable modems where you are is the same as it is here in the uk, but it's normally either or Type the ip into your address bar in safari or whichever web browser you're using. Once logged in with the details supplied on your router click on the advanced settings tab and look at the incoming and outgoing connections log. If something's blocked, it will show up as blocked, denied access or unsuccessful connection. If all is well then maybe setting up the TC so it automatically connects to your existing wifi network, thus creating a single wifi connection rather than 2 separate connections to choose from may help. That way airdrop won't get confused when searching for and connecting to computers nearby, and this may help remedying the dropouts.
  16. macrumors regular

    Did as instructed above. Under advanced setting there was no connections log to be found. Looked in all the other tabs - nope, no log.:confused:
    But while I was there I changed the channel from 6 to 11 because the neighbor has a strong wi-fi that shows up and they are on 6.


    The wifi signal from the TC seems to be stronger than the Cisco (unless changing to channel 11 improves things) so I think we would rather bridge the Cisco and use the TC as the sole router and wifi source if we have to go that route to clean things up.
    I have no way to test AirDrop though until my husband returns with his MBP at the end of the week.
  17. macrumors regular

    I am still waiting to hear back from Apple Support about the AirDrop problem. So have been continuing to research the problem on my own. Just learned about Console. So this morning I had the Console window open, opened Finder, clicked on AirDrop and this is what appeared in Console":
    NetworkBrowserAgent: Terminate AirDrop P2P link

    Could this be the source of the problem and if so any ideas how to fix it? I typed Network Browser Agent in spotlight and nothing came up so I don't even know how to find it on my iMac.
  18. macrumors 6502a


    I'm having this problem to. I've come to the conclusion that AirDrop is just a half-assed product that doesn't work half the time and isn't a serious option when needing to communicate with other devices.
  19. macrumors regular

    Thanks for letting me know I am not alone.
    Could you post a screen shot or type in the details of your Card Type and Firmware Version under the Interfaces of the Wi-Fi system report.
    I want to see if it is the same as mine.
    Here is mine:
    And to others, if you have the same card and firmware as mine and AirDrop is working, please let me know.

    Attached Files:

  20. macrumors 68020

    I would suggest running this command in the Terminal:

    defaults write com.apple.NetworkBrowser BrowseAllInterfaces 1
    which allows greater latitude in connecting to other Macs. Run it on both machines.

    You'll need to restart the Finder. You can use "killall Finder" in the Terminal, or just Force Quit it. Or just restart.
  21. macrumors regular

    Thank you very much for replying. I hope you don't regret responding because I have many questions and you are dealing with a nervous newbie :eek:

    1. Below I have attached two screen shots while trying to engage AirDrop. The first is my husband's MBP, the second is my iMac. As you can see, the first string that appears on both computers is: NetworkBrowserAgent: Terminate AirDrop P2P link. Then follows several strings on each computer when AirDrop is actually working. However, in the screen shot of my iMac when AirDrop is not working, no strings follow the Terminate AirDrop P2P link string - the process stops there whereas on the MBP the additional strings always appear leading me to believe the problem resides in my iMac - is this a logical assumption?

    2. About the command you suggested I type into Terminal I have two questions:
    (a) You have NetworkBrowser, not NetworkBrowserAgent - I don't need to use the Agent word?
    (b) I have never used Terminal. I opened it and was confused as to what to do. There was a grey box at the end of the last command but it was not blinking and my cursor was not visible. Is this normal and do I just start typing regardless or is there something amiss when I open Terminal?
    (c) Will entering your code in Terminal make our computers visible outside of our internal network?

    3. Just as an aside, we have reconfigured our network as recommended by others by bridging the ISP's modem/router to just modem and have made our Time Capsule the router and wi-fi provider. It was suggested that maybe the cross-talk between the two were causing the problem, but sadly I must report that doing this has not resolved the AirDrop issue.
    4. I have not yet tried installing 10.8.4 combo over top of my current 10.8.4

    Thanks again for jumping in.

    Attached Files:

  22. macrumors 68020

    a) Yes, the command is correct.
    b) Terminal is where you can type in good-old-fashioned text commands. It is very powerful -- but with great power comes great error. ;)

    The command simply sets a preference parameter with a value. All preferences in OS X are stored in files which hold a "key" and a value. In this case "BrowseAllInterfaces" is the key, and "1" (true) is the value. The key is held in the file com.apple.NetworkBrowser.plist (.plist not necessary in the command), which is in your user Library's Preferences folder.

    Your Terminal sounds normal. You can configure it in the Preferences to have a different style of display.

    c) No.
    The command is mainly used for getting AirDrop to work on some older machines which Apple claim are unsupported. But it generally instructs AirDrop to trawl its net wider when looking for Macs. It may help your situation; it may do nothing at all.

    One problem I have noticed with AirDrop and laptops is that the laptops can be a bit funny about reconnecting to the network after sleeping/closing the lid. It seems (to me) that the connection may not be dropped properly and/or not picked up again properly.
  23. macrumors regular

    Thank you. Now, if I summon the courage to do this and it does not fix the problem, what command would I use to put it back to "normal"?
  24. macrumors 68020

    You can either change the value from "1" to "0", or use defaults delete instead of write, which will delete that key from the plist file.

    defaults write com.apple.NetworkBrowser BrowseAllInterfaces 0
    defaults delete com.apple.NetworkBrowser BrowseAllInterfaces
  25. macrumors regular

    Thank you. You have been very helpful and patient. I will post back here if the problem gets fixed.

Share This Page