Alert: No Internet Connection

Discussion in 'MacBook Air' started by scottness, Oct 21, 2012.

  1. macrumors 65816

    scottness

    Joined:
    Mar 18, 2009
    Location:
    Room 101
    #1
    I'm getting a strange wifi icon in my menu bar (see screen shot). My internet connection sometimes works, sometimes doesn't, but either way I keep seeing the wifi icon with the message "Alert: No Internet Connection…" Odd, because I'm able to post this right now, and right now, it says I have no connection.

    When it doesn't connect, it says it can't get an IP address. Then I try a manual address, then I can connect for a while, but then it drops the connection. Problem resolves temporarily when I go back to using DHCP, but keeps dropping.

    I've tried to reinstall the OS, but when I do, it also says I have no internet connection, so I can't reinstall. (I miss using the dang DVD).

    Our 2 iPhones and a friend's MBA connect to the same network with no problem, all bars lit.

    Running MLion 10.8.2 on a mid 2011 11" MBA.

    Anyone know what's up?
     

    Attached Files:

  2. macrumors 65816

    kylera

    Joined:
    Dec 5, 2010
    Location:
    Seoul
    #2
    I had the near-exact issue with you just this morning - same wifi icon on top. I restarted my Air and it was back to business, as if this never happened...try giving that a shot.
     
  3. thread starter macrumors 65816

    scottness

    Joined:
    Mar 18, 2009
    Location:
    Room 101
    #3
    Thanks! Tried it, though, and I'm getting the same issue.
     
  4. macrumors regular

    Joined:
    Feb 17, 2012
    #4
    Last friday I had this a few times. Everytime it was fine again when i restarted my air. Then on saturday i had it one time en never since. Strange.
     
  5. macrumors 603

    justperry

    #5
    What happens if you turn off IPv6 in TCP/IP, might help, there are sometimes issues with it.
     
  6. macrumors 6502a

    Joined:
    Jun 23, 2010
    #6
    Does this happen everywhere or just at home. Could be a bad wifi router? I would try deleting all your previous networks and starting from scratch. Also reset cable modem and wifi router.

    One time I did have apple replace a bad wifi chip in a MBP though so if all the steps above doesn't work it's time for a genius bar appointment.
     
  7. macrumors 603

    justperry

    #7
    He could also delete or move to desktop this: /Library/Preferences/SystemConfiguration Folder and restart.

    If you are on Airport and switch IPv6 off it will be off on all wireless networks you connect to.
    I said this because I read stories that got solved by disabling IPv6.
    Easy to switch it back on.
    Bad router could also be a problem, He could try to reset the router or update the firmware if there is one.
     
  8. thread starter macrumors 65816

    scottness

    Joined:
    Mar 18, 2009
    Location:
    Room 101
    #8
    Thanks for your help!

    Quick question: How is this done in MLion? Screenshot of what I'm looking at:

    (notice I still have that stupid icon)
     

    Attached Files:

  9. thread starter macrumors 65816

    scottness

    Joined:
    Mar 18, 2009
    Location:
    Room 101
    #9
    It happens on occasion in other places. I was really hoping it was some simple software thing…

    Yeah, I would have gone to the Genius bar already, except I'm in Japan and my Japanese sucks. I'll go if I really have to, but I'd like to exhaust all options first.

    I'll try deleting previous networks when I get home later. Thanks.
     
  10. macrumors 6502

    skitzogreg

    Joined:
    Oct 31, 2007
    Location:
    Arkansas
  11. thread starter macrumors 65816

    scottness

    Joined:
    Mar 18, 2009
    Location:
    Room 101
    #11
    This seemed to make it work better. Thanks!

    I still get the icon for ~10-20 seconds when I wake from sleep, but it goes away.

    I seem to recall my old MB being on the network immediately after wake and not having to wait for it. Or am I just crazy?


    Haven't tried it yet (forgot how to do it—have to look it up). Will try it if this thing persists. Thanks!
     
  12. hfg
    macrumors 68030

    hfg

    Joined:
    Dec 1, 2006
    Location:
    Cedar Rapids, IA. USA
    #12
    On the network WiFi preferences pane, click the "Advanced" button and look at the list of WiFi locations you have connected to. Move your home WiFi to the top of the list (and remove any you won't be visiting again). This may help with maintaining your connection.
     
  13. macrumors 603

    justperry

    #13
    Click on Manually and Apply.

    That could also be done but since He already deleted/moved the Systemconfiguration Folder those are already gone, see his quote below.

    10.8.2 seems to have quite a few bugs.
     
  14. Nicknaik, Mar 24, 2013
    Last edited: Mar 24, 2013

    macrumors newbie

    Joined:
    Mar 24, 2013
    #14
    Solved!

    Hi,

    "After trying every method from this post, I couldn’t able solve it and found out there is another alternative method to solve this issue!"

    Solution for this issue is, deleting your Wifi router password, since in case you have recently updated your new wifi password.

    So to do this, please follow these below steps,

    Go to --> Finder / Applications / Utilities / Keychain Access / (in “Search box”, Type your Wifi router name example, "Dlink")

    You will see your wifi router name below, in the kind section you can see “Airport network password” holding “Dlink” please delete the wifi router name, also delete if there are multiple names,

    Once you have completely deleted this, you can try conneting to your wifi router. here, wifi asks to enter your password again, and then it connects with out any issues!

    I hope it works for you!

    Thanks
    Nick
     
  15. macrumors newbie

    Joined:
    Apr 3, 2013
    #15
    Hi! I'm having the same issue but this solution isn't working. I just changed the password to my router so I was sure this was going to fix it :( When I went into the keychain access, it would only let me delete 2/3 of my routers. When I tried to delete the last one it said "An error occurred while deleting belkin.c38. An invalid record was encountered." Any ideas?

    Thanks.

     
  16. macrumors newbie

    ashcairo

    Joined:
    Jul 2, 2013
    Location:
    London, UK
    #16
    Thanks so much! Just experienced this issue, and after deleting my router from Keychain and re-logging in, it was fixed!


     
  17. macrumors 65816

    Joined:
    Sep 18, 2007
    Location:
    Ohio
    #17
    Thanks, my keychain had two of each of my dual band Belkin. Eliminated all and now it picks up the 5GHz instead of the 2.6.
     

Share This Page