Alias cannot be opened?

Discussion in 'General Mac Discussion' started by mcs37, Nov 15, 2004.

  1. macrumors regular

    Joined:
    Mar 2, 2003
    Location:
    Washington, DC
    #1
    I give up. I've spent the better part of the last hour trying to get my PowerBook to talk to my Linux box, but it just doesn't want to play ball.

    I installed a new hard disk onto my Linux machine and intend to use it to backup my big files on my Mac. So I wrote an entry for the mount point in the Linux smb.conf file and it shows up happily.

    When I connect to it through my Mac, I head over to the network and double-click on the icon for the machine. So far so good. It prompts me with a list of mounts to choose and I pick the only one there, which is called "storage" (as it should be called!). A window pops up with the workgroup, user, and password, and I fill in the password, click OK, and boom: "The alias 'machinename' could not be opened, because the original item cannot be found."

    And I've tried everything since then to get it to mount but it just won't work. I even clicked Authenticate before clicking the drive, and that seems to work, but whenever I try to mount the drive I get the exact same error. I inspected /var/log/samba files on the Linux box, and all I see (after clearing out the logs and restarting smb) are log.smbd, log.nmbd, smbd.log, and silverado.log. Silverado.log only appeared after I first tried to connect, but both silverado.log and smbd.log are 0-byte files.

    So what's going on? You win this round, Apple. I give up trying to guess what it is you want me to do. Anyone have any tips?

    Thanks,

    Mike
     
  2. macrumors 601

    stoid

    Joined:
    Feb 17, 2002
    Location:
    So long, and thanks for all the fish!
    #2
    This isn't just a Mac-Linux issue. I have had it many times in all sorts of configurations including Mac-Mac and Mac-Windows. I don't understand it at all either. Any network gurus out there have any advice?
     
  3. thread starter macrumors regular

    Joined:
    Mar 2, 2003
    Location:
    Washington, DC
    #3
    There has GOT to be a solution. It's really bizarre to: when I click the Connect button the error springs up IMMEDIATELY. There is no 10 second delay as it tries again and again to connect. It just gives up. I cleared the caches and made sure windows sharing was enabled, but no deal!
     
  4. macrumors G4

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    I strongly suspect that something's wrong in Directory Access on the Mac OS X machine. Have a look in there and make sure what should be on is turned on and that everything's configured properly. Incorrect Directory Access settings have caused similar problems for me, such as total inability to communicate with pre-Mac OS X machines (turning AppleTalk back on fixed this one).
     
  5. macrumors 68030

    superbovine

    Joined:
    Nov 7, 2003
    #5
    did you try using ip addresses? what about the firewall on the linux box? what about in /etc/host.deny?
     
  6. thread starter macrumors regular

    Joined:
    Mar 2, 2003
    Location:
    Washington, DC
    #6
    I went into Directory Access and the following services are ENABLED:

    AppleTalk
    LDAPv3
    Rendezvous
    SLP
    SMB

    I tried going directly to the IP, and that did not work. I looked in hosts.deny and had no problem. Again, it DID recognize the shares available but when I tried to enter my user/pass it just immediately fails. No messages reported in the samba log files. I turned off the firewall on the Linux box just to be sure. Still no deal. /etc/hosts.deny has no entries.

    Furthermore, I am in the same workgroup as the Linux machine, if that helps.
     
  7. thread starter macrumors regular

    Joined:
    Mar 2, 2003
    Location:
    Washington, DC
    #7
    CASE CLOSED

    SOLUTION: I was playing around with the smb.conf settings on the Linux box, and the solution was something I had considered but figured it wasn't a real problem.

    Make sure security setting is user and not share!

    It's working fine now, yahoo!

    Thanks!

    Mike
     
  8. macrumors newbie

    Joined:
    May 26, 2006
    #8
    Hey guys,

    I still have this problem in a Windows network. Everything is like described above. Do you also know a way to fix this on a Windows server?

    Cheers
    - little
     
  9. macrumors 601

    mjstew33

    Joined:
    May 29, 2005
    Location:
    Illinois
    #9
    Try and see if this is any better.

    Go to the finder.

    See Go, the menu? Press Connect To Server. Type in the IP address of the Linux box. Connect.

    I always do it that way when I have problems like your describing.. works, too.
     

Share This Page