Alt keys don't work!

Discussion in 'macOS' started by GrandMan, Jun 6, 2006.

  1. GrandMan macrumors newbie

    Joined:
    Jan 6, 2004
    #1
    For some reason both of the alt keys no longer work on my keyboard. Everything else works fine. Is it possible it is software related?
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Open up TextEdit. When you hold OPTION and start typing you should get some funky characters. If you now press SHIFT as well, you should get some different funky characters. If OPTION really is screwed, then you'll just get uppercase characters. This is a good way to check if it's software related. :)
     
  3. GrandMan thread starter macrumors newbie

    Joined:
    Jan 6, 2004
    #3
    I only get uppercase :( I've tried restarting the computer to no luck. Any ideas anyone?
     
  4. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #4
    Could there be anything stuck under the keys? If you open up a new user account, do they still not work? :)
     
  5. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #5
    Are you using any third party utilities or kernel extensions related to the keyboard? And are you using Tiger?

    Assuming the answers are no & yes, respectively...

    Check: System Preferences -> Keyboard & Mouse pane -> Keyboard tab -> Modifier Keys (bottom left). Make sure that the blank next to the Option key reads "Option."
     
  6. GrandMan thread starter macrumors newbie

    Joined:
    Jan 6, 2004
    #6
    Doesn't work on another user. I'm using Tiger. Modifiers are set to default. :(
     
  7. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
  8. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #8
    Yeah, plug in a different keyboard if possible, and see if the problem carries over. :)
     

Share This Page