Annoying beachball in XCode - normal?

Discussion in 'Mac Programming' started by MCS, Mar 31, 2007.

  1. MCS
    macrumors newbie

    MCS

    #1
    Hi,

    I'm having a really weird problem, or should I rather say annoyance, with XCode (2.4.1). Whenever I start it up for the first time I get a beachball for over a minute before I can actually do anything.
    The beachball appears whenever I try to open any window in XCode after startup (preferences, a project etc.). After the first window is there and the ball is gone I never see it again.
    I tried reinstalling XCode, same problem. Reinstalling OS X (not because of this problem) same annoying beachball in XCode. As I said it's not really a problem because everything works fine after the beachball has vanished but it is a major nuisance if I want to get started and have to sit there watching the ball spinning (I cant even quit XCode while it's in that state but all other programs work fine while XCode is starting up). Any suggestions on what this could be? Or is this normal behaviour?
    Someone suggested to me, that it could be the indexing for 'code sense' which is bogging the startup down but I tried deactivating that with no change and anyway why would it index anything without a single project open and me just trying to open up the preferences?

    Any advice would be welcome,

    Mark

    Btw the system I'm running XCode on is a new MacBook Pro, 2.33GHz and 2GB RAM
     
  2. macrumors G4

    Eraserhead

    #2
    It doesn't do that for me, I have a MB 2Ghz with 2GB RAM, I was gonna say "hardware problem" but your hardware is highly speced.
     
  3. macrumors regular

    #3
    I get this problem as well. What version of Mac OS X are you using? I noticed mine started happening around the time I upgraded to 10.4.8, and also Unity (the 3D game engine) also stoped working when I upgraded. I know there is a problem with very few Intel macs on 10.4.8+ (I believe it has something to do with prebinding). I don't know how to fix though :(
     
  4. MCS
    macrumors newbie

    MCS

    #4
    I'm currently using a fully patched 10.4.9 system.
     
  5. macrumors 6502

    #5
    The most useful thing to do in this case would be to actually run Shark or Sampler on Xcode and find out what the heck it's doing that is taking up so much time. If it happens every time this shouldn't be too hard to do. Then you could submit a bug to Apple and they can fix it.
     
  6. macrumors 6502a

    #6
    Xcode has slowed down for me since 10.4.9.

    b e n
     
  7. macrumors 6502a

    Legolamb

    #7
    Since 10.4.9, the only thing I've noticed that my InterfaceBuilder window sometimes "lost" First Responder when setting up a Carbon application project, but that's working now. No other slow down or problems.
     
  8. macrumors G5

    gnasher729

    #8
    Is it trying to access anything on a server that isn't mounted, like having projects in the "Recent Items" menu that are not available? Or maybe it is checking for updates when your Internet connection is down?

    Start Activity Monitor first and check what is going on.
     
  9. macrumors 68000

    GeeYouEye

    #9
    Make sure distributed build is turned off unless you're actually using it.
     
  10. MCS
    macrumors newbie

    MCS

    #10
    Well distributed building is turned off and all my projects are stored on my internal harddrive. And updates and such things shouldn't be a problem as I'm connected to the net permanently and the connection shouldn't be a bottleneck either as it's a dedicated 10MBit line.
    I filed a bug report with Apple so I'll just have to wait and see if something changes.
     
  11. MCS
    macrumors newbie

    MCS

    #11
    OK, as there were other people in this thread that seemed to have the same problem I thought I should post the solution to the problem. It seems that the culprit was distributed building after all which is odd as I have completely deactivated it. Here's what I did to resolve the issue:

    - In the preference window of XCode go to the 'Distributed Builds' option
    - Make sure that there are no ticks in any of the option boxes (as was already the case with me)
    - Unlock the preferences to be able to make changes (click on the padlock)
    - In the first option ('Share my computer for shared workgroup builds (distcc)') make sure the CPU priority is set to 'low priority' (With me it was on high by default)

    After that change XCode should not freeze when opening it for the first time. As I said I find this weird as I have all options for distributed builds deactivated so I don't see how this option should affect performance in the first place.
     
  12. macrumors regular

    #12
    mm not for me, i have newest version and its fast, also i have only 512MB RAM
     
  13. macrumors newbie

    #13
    Waking an old thread I know but I have this problem with a 2gb ram IMAC (new style) running leopard. Xcode does run but only after a minute or so of beach ball.

    Ray
     
  14. Moderator emeritus

    kainjow

    #14
    I'm assuming Xcode 3? Did you do a clean install of Leopard or an Archive and Install?

    You could always install Xcode 2.5 (works alongside 3.0).
     

Share This Page