app quits on launch

Discussion in 'iOS Programming' started by itepuy, Dec 2, 2009.

  1. macrumors newbie

    Dec 2, 2009

    I just posted an update of my app to AppStore. It was approved by Apple. It has been tested on 2 iphone devices (3G - 3GS with 3.1.2). It worked fine but when downloaded from AppStore it doesn't launch, just displayed the default screen and returned to iphone menu. I have no idea where to look. Any help will be greatly appreciated.
  2. macrumors 6502a


    Aug 21, 2007
    Rochester, NY
    I had a similar problem, about 11 months ago. We changed some preserved user settings, so an existing user would have the app exit, but new users had no problem.

    If you have a large installed base, this will start showing up in reviews, emails, etc. Update your description to tell old users to DELETE the old app (or the new app if they already updated) THEN reinstall the new version as a clean install. They will lose any settings, of course, but it should work. And remind users that Apple will NOT charge them twice for the same app.

    In the meantime, try to fix the settings issue and submit an update to the update. Apple might give you a fast track approval if you ask nicely, at
  3. macrumors 68030


    Sep 2, 2008
    What gets written to the console when it quits? Do you get a crash log?
  4. thread starter macrumors newbie

    Dec 2, 2009
    No log displayed.
    But I found the error: an outlet in my NIB was improperly connected.
  5. macrumors 68030


    Sep 2, 2008
    The crash log and console are visible in the Xcode organizer window. If it's really crashing then there will be info there.
  6. thread starter macrumors newbie

    Dec 2, 2009
    The app test on device with Xcode was OK no crash, no log but in prodution it quits.
    I suspected a problem in the appDelegate (applicationDidFinishLaunching) or in my ViewController (ViewDidLoad) so I recreated my XIB and properly connected the outlets, made an ad hoc testing and all is fine.
    What is weird is that initially while testing with Xcode on device the app worked perfectly.

Share This Page