1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Application not showing its main window [Resolved]

Discussion in 'Mac Programming' started by McBgnr, Jun 8, 2009.

  1. macrumors regular


    I wanted to share my application with my friend, so I have emailed it to him. But after downloading it (Safari), he is not able to open the application.

    When trying to launch the application, a message is displayed that "You have downloaded this application from internet, are you sure you want to open it."
    But clicking on open just causes a blinking effect on the Dock and the application does not start at all.

    What could be the cause for this?
  2. Moderator emeritus


    Sounds like it's crashing. Look at the crash logs, located in ~/Library/Logs/CrashReporter/
  3. macrumors regular

    I have checked the crash logs, there's none.

    One point I would like to mention is that I had zipped the app from windows machine and sent and it was downloaded on a mac machine. So could there be a compatibility issue, because after downloading the size is also different from the actual size of the .app.
  4. Moderator emeritus


    I'm pretty sure the permissions on the actual executable in the Contents/MacOS folder has to be set right, or else it won't run (I could be wrong though). That could be the problem since Windows wouldn't be aware of this when compressing it.

    Try dragging the executable into Terminal and run it there, and see if any messages are displayed.
  5. macrumors regular

    Permissions could go wrong ... this did not come to me...
    I checked using terminal and it shows all permissions for the app.
    and I tried running the app using open and it showed the following error
    open Test.app
    LSOpenFromURLSpec() failed with error -10810 for the file /private/var/root/Desktop/Test.app.
    Then I checked for permisssions for each of the subfolders of Test.app and found that there was no execute permission on the Contents/MacOS/Test file. Thus it was not running I guess.

    Then I updated the permissions using chmod -R 777 and it worked. Thus I think the permissions were not set correctly. Thanks a bunch for the quick help.

    By the way should I be compressing files from Mac if these have to be used on Mac to avoid such permissions issue?
  6. Moderator emeritus


    If you're compressing an executable, yes I would do it only on the Mac since it should retain the permissions in the zip file.
  7. macrumors regular

    Thanks kainjow, I will keep it in mind going ahead.

Share This Page