Resolved AT&T 3gs->4s Visual voicemail not working

Discussion in 'iPhone' started by mikepro, Oct 14, 2011.

  1. mikepro, Oct 14, 2011
    Last edited: Oct 14, 2011

    macrumors 6502

    Sep 3, 2010
    Just did the upgrade and restore from my 3gs -> 4s. Went pretty smoothly, except when I go to the voicemail, it says "Cannot Connect to Voicemail".

    Anyone else have this issue? Is it just a problem with busy AT&T servers, or what? I noticed I had to re-enter my password for all my email accounts after the restore. I thought this could be the problem, but in the phone settings, there is no password reset option.
  2. macrumors demi-god

    Apr 20, 2009
    You have to put in your voicemail password. It's in Settings, Phone, change voicemail password.
  3. thread starter macrumors 6502

    Sep 3, 2010
    I would... but I don't get that field on the 4s!

    It is still there on the old 3gs. Wonder if I should try it there. It says "Visual Voicemail is currently unavailable" and has No Service, but I could try over wifi...
  4. macrumors member

    Jun 18, 2008
    my visual voicemail is not working either. It says call at&t. :confused:
  5. paj
    macrumors regular

    Jun 14, 2003
    Call your voicemail access number manually and do the initial setup.
    Then go into the voicemail tab and it will show up correctly.

    The problem is finding the voicemail access number for your location.

    My access number in NC is 678-761-9969
  6. macrumors 6502a

    Jul 12, 2004
    I had the same problem and this is how I fixed it:

    1) go to the phone app and dial your own phone number. Run the call about 20-30 seconds.
    2) end the call and close the phone app
    3) the enter voice mail password prompt will show up. enter the password and then visual voicemail is back up!
  7. thread starter macrumors 6502

    Sep 3, 2010
    OK - I think the key here is to just wait a bit. I just received a text from AT&T welcoming me to my new service, blah blah blah. So, I checked my voicemail, and this time it asked me for my password and visual voicemail now works!

    So - for those who it is not working, sit tight a bit and wait for the text, then try it.
  8. macrumors 68040


    Jun 23, 2010
    Worked like a charm! Thank you!!
  9. macrumors newbie

    Jun 8, 2009
    Solved for Verizon

    I had same problem. I called apple and verizon. Verizon had to turn off visual voice mail on their end. Then restarted my iphone. Then they turned it one again and I had to restart my iphone again and it started working. Also backing up from itunes also started the problem all over again. So, next time I had the problem, I set the setting to "Set as a new iphone" and it has been working perfectly ever since. I do not use itunes to backup my iphone anymore, I use iCloud.

Share This Page