Broken "Welcome to Xcode" window...

Discussion in 'Mac Programming' started by phjo, Mar 25, 2008.

  1. macrumors regular

    Joined:
    Jan 8, 2008
    #1
    Not a big problem per se, but I'm curious as to why the Welcome to Xcode window that opens when you launch Xcode shows garbage, with the What's new view in Getting started tab staying (and refreshing) in other tabs such as this :
    [​IMG]

    I didn't remember seeing this before... Quitting xcode and running it again and the bug doesn't go away... Any idea ?

    phjo
     
  2. Moderator emeritus

    kainjow

    Joined:
    Jun 15, 2000
    #2
    It this in Xcode 3.0 or 3.1? Maybe try deleting some preference files? I just made my Xcode never show that startup window though.
     
  3. thread starter macrumors regular

    Joined:
    Jan 8, 2008
    #3
    This is Xcode 3.0.

    Btw, for someone who is not into iPhone/Touch development, is the upgrade to Xcode 3.1 worthwhile ?

    phjo
     
  4. thread starter macrumors regular

    Joined:
    Jan 8, 2008
    #4
    Btw, I thrashed the com.apple.Xcode.plist under ~/Library/Preferences to no avail, the bug is still there...

    phjo
     
  5. Moderator emeritus

    kainjow

    Joined:
    Jun 15, 2000
    #5
    Well I can confirm the same behavior in Xcode 3.0, but I just checked in Xcode 3.1 and it is working normally :)
     
  6. thread starter macrumors regular

    Joined:
    Jan 8, 2008
    #6
    So it just means I guess some upgrade (10.5.2 maybe) triggered this bug...

    When there is a separate download for xcode 3.1, I guess I'll upgrade to that version (but this bug is not enough to do it right now...)

    phjo
     

Share This Page