Caller ID - Iphone setting

Discussion in 'iPhone Tips, Help and Troubleshooting' started by westernmass, Jan 4, 2008.

  1. macrumors 6502

    westernmass

    Joined:
    Dec 30, 2007
    Location:
    Western Mass.
    #1
    First post :) I got the iphone for xmas from the wife :) I was in shock as it was out of the blue. Anyway, been enjoying this forum and a few others. One thing I wanted to pass on that I found interesting today that I have not seen anywhere else. Actually I was going crazy and even chatted with AT&T to figure out what was up with it. My wife and a friend noticed when I called they got "private caller" or "Blocked number" when I called them. The At&T person could not figure it out. I went to AT&T site and searched Caller ID and found some other phone had setting to turn it on or off. HMMM.. I quick check of the settings and sure enough there is a setting that you can turn on or off your id when calling someone. Go to Settings, Phone (scroll down a little) - Show My Caller ID. You can turn it on or off. Turn it on and it shows the person you call the ID, turn it off and you get the caller blocked or Private number.

    So my helpful hint and first post all in one. Hope it helps someone. It would have helped me while looking for it :)

    Great bunch of people here by the way. Look forward to learning more and more about the phone.
     
  2. macrumors 68040

    tobefirst

    Joined:
    Jan 24, 2005
    Location:
    St. Louis, MO
    #2
    It's a fairly common feature for a phone to have these days, for when you want to call the girl you're stalking. (;

    Welcome to the forums, westernmass!
     
  3. thread starter macrumors 6502

    westernmass

    Joined:
    Dec 30, 2007
    Location:
    Western Mass.
    #3
    LOLOLOLOLOLOL :cool:
     
  4. Administrator/Editor

    r6girl

    Staff Member

    Joined:
    Sep 6, 2003
    Location:
    Massachusetts
    #4
    you can also leave the show caller ID setting on and *selectively* not show your caller ID by dialing *67 before the full phone number of the person you're calling. i prefer this method since my husband and most of my friends would never answer the phone if they didn't see my caller ID come up if i left that setting off...

    enjoy your iphone and welcome! :)
     
  5. macrumors newbie

    Joined:
    Dec 30, 2007
    #5
    isn't it *68?
     
  6. Administrator/Editor

    r6girl

    Staff Member

    Joined:
    Sep 6, 2003
    Location:
    Massachusetts
    #6
    why don't you try it and let us know? ;) *67 works on my iphone with at&t, not sure if it's different for other carriers...
     
  7. macrumors 68040

    tdhurst

    Joined:
    Dec 27, 2003
    Location:
    Portland, OR
    #7
    hmm...

    You people are way too paranoid. I never, EVER answer blocked or private calls and it infuriates me when people call that have them.

    You're calling ME, should you let me know who you ARE?
     
  8. Administrator/Editor

    r6girl

    Staff Member

    Joined:
    Sep 6, 2003
    Location:
    Massachusetts
    #8
    paranoid? YES! :D trust no one! i never answer blocked/private calls either.

    my pet peeve is when someone calls you and then asks who you are! that is the quickest route to getting hung up on in my book.
     
  9. thread starter macrumors 6502

    westernmass

    Joined:
    Dec 30, 2007
    Location:
    Western Mass.
    #9
    is there a charge for the *6(7/8) feature use?
     
  10. macrumors newbie

    Joined:
    Nov 20, 2007
    #10
    The GSM standard for selectively blocked your number on one call is #31#
    I know this certainly works for me on O2 in the UK.
     
  11. macrumors 68040

    tobefirst

    Joined:
    Jan 24, 2005
    Location:
    St. Louis, MO
    #11
    ...followed closely in my book by calling me and then immediately asking if I can hold. Grrrrrr...
     
  12. macrumors 65816

    Joined:
    Oct 18, 2007
    #12

    That's one of my biggest pet peeves as well. Ring. "Hello?" "Who is this?"

    Yeah, right. I handle it this way.

    "No, I don't think you get how this works. You called me. If you don't know who I am why should I tell you?"
     
  13. macrumors newbie

    Joined:
    Sep 15, 2003
    Location:
    New London, CT
    #13
    thanks westernmass. i just got a new iphone and was having the same problem. don't know how it got turned on, but it was driving all my friends crazy.
     
  14. macrumors newbie

    claidheamdanns

    Joined:
    Feb 6, 2008
    Location:
    Memphis, TN
    #14
    Exactly, same here. I am also on the "Do Not Call" list for that same reason. I didn't buy my phone, and pay for minutes, for you to call and advertise to me.
     
  15. macrumors regular

    Joined:
    Jun 11, 2010
    #15
    Apparently not with Verizon

    Have a Verizon iphone - under Settings, Phone, there is nothing for Caller ID or Call Forwarding. I guess that is an ATT only setting.
     

Share This Page