Camera Not Working

Discussion in 'MacBook Air' started by TeeRom, Oct 12, 2012.

  1. macrumors member

    Joined:
    Aug 1, 2012
    #1
    I have the 2012 Macbook Air 13 inch base model. Bought it refurbished directly from Apple. There seems to be an issue with the camera. After a reboot the camera will work fine for a certain amount of time (a few hours to a day or two) then it will not be recognized. Programs say "There is no connected camera." I have already tried doing an SMC reset. What else should I do? Take it in to Apple to have them look at it?
     
  2. macrumors 65816

    Joined:
    May 7, 2009
    Location:
    Hamilton Island, Whitsundays, QLD Australia
    #2
    a single thread for your issue is sufficient - you really don't need to post 3.
    just be patient and someone will eventually answer you. :rolleyes:
    suggest you delete the other 2.

    call Apple - you have 90 days free telephone support and they will assist you directly as to the best course of action.
     
  3. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #3
    Yes.
     
  4. macrumors member

    PerformaGuy

    Joined:
    Oct 5, 2012
  5. thread starter macrumors member

    Joined:
    Aug 1, 2012
    #5
    It was an accident, my internet went out and I thought it didn't post but ended up posting three times :/
     
  6. macrumors newbie

    Joined:
    Nov 1, 2007
    Location:
    Columbus, OH
    #6
    I have a 2012 11" MacBook Air and I've experienced the same issue since owning it. By chance do you use an android phone? I have a Galaxy Nexus, and thus I have android file transfer installed for when I need to transfer files via MTP. Anyway, just like you said, the camera works fine until you sleep the computer for extended periods of time. After awaking the computer, just like you stated, I can no longer use the facetime camera in any of my apps. It says no camera detected.

    Rebooting fixes this problem, until you sleep the computer. After poking around I figured out that, after waking the computer, if I go to activity monitor and find the "android file transfer agent" process and close it, the camera starts working again. I'm not sure why, but there seems to be an issue with that process running in the background after you sleep and/or leave your laptop running for extended periods of time. Hopefully this is the same case with you. If not keep us posted. I never had this problem with the 2010 Mbp that I had running Lion. I'm assuming it's an issue with the MacBook Air and/or Mountain Lion, but I could be wrong.
     
  7. thread starter macrumors member

    Joined:
    Aug 1, 2012
    #7
    Actually, yeah... I have a Galaxy Nexus as well.

    Edit: DAMN. That fixed it. THANK YOU SO MUCH.
     
  8. siphyn87, Oct 14, 2012
    Last edited: Oct 15, 2012

    macrumors newbie

    Joined:
    Nov 1, 2007
    Location:
    Columbus, OH
    #8
    No problem man. Glad to have helped. Hopefully Google updates the app. What I did in the mean time is I removed it from the startup programs in system preferences. Then, go to the app in your applications folder and show package contents. Go to the resources folder. Select the "android file transfer agent" file that is inside the resources folder and rename it to something different. This will prevent the app from auto starting from now on, and causing issues with the camera.
     
  9. macrumors newbie

    Joined:
    Jul 4, 2012
    #9
    Thank you so much siphyn87... I have a Galaxy Nexus as well, and this fixed my problem - I ended up uninstalling the Android File Transfer software altogether (I'll just use AirDroid for wireless transfer). I was going to bring this in for a hardware repair, but clearly that is not necessary. :)
     
  10. macrumors newbie

    Joined:
    Nov 1, 2007
    Location:
    Columbus, OH
    #10
    Hey no problem. Also, if you do what I said to do in my previous post, the app won't give you any problems. The only thing is it won't autostart when you plug in the phone. You'll have to manually start the app, but at least you won't have to deal with webcam issues from here on out.
     
  11. macrumors newbie

    Joined:
    Aug 22, 2012
  12. macrumors newbie

    Joined:
    Dec 6, 2012
    #12
  13. macrumors newbie

    Joined:
    Jul 27, 2012
    #13
    I have/had the same problem I think I found the solution. I hadn't did a time machine back up in a long time like 190 days. I recently did one and for the past 4 hours my cam has been working after a long sleep for the first time in months. So try doing that.

    I Have a '12 Macbook Air, been having this problem on and off ever since i got the computer.
     
  14. macrumors newbie

    Joined:
    May 16, 2011
    Location:
    London, Ontario
    #14
    There is no connected camera

    Come on Apple, will you fix this damned problem already? What the hell is the use of my $1700 brand-spanking new macbook pro and I can't do facetime with my kids when travelling overseas? reset this, SMC that...sometimes it works, most times it does not, and I am frustrated. I may never buy another Apple product if they don't stop taking their customers for granted. I am really getting sick of the lack of attention to the very real problems with their operating system.
     
  15. macrumors regular

    GenesisJLS

    Joined:
    Apr 21, 2009
    #15
    I'm experiencing the same issue on my MBA 2012. The randomness of this is the most frustrating aspect of it. Like many others have said, the camera occasionally works when you reset the SMC. However, sometimes I find it beneficial to simply drain the battery to absolute zero and charge again.
     
  16. macrumors regular

    Joined:
    Apr 15, 2013
    Location:
    Houston, TX
    #16
    I had this same problem on my 13 inch MBP from last year. It isn't a hardware defect. I got really annoyed one day and reinstalled osx (through the Internet recovery). This time I didn't restore from time machine backup and I never had the problem again. This was about 7 months ago
     

Share This Page