1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Can anyone run Server Admin Tools under Leopard?!?!?

Discussion in 'Mac OS X Server, Xserve, and Networking' started by Moof1904, Jan 7, 2008.

  1. macrumors 65816

    I'm running a Tiger server and I use the Server Admin Tools to configure it remotely from other computers on the network (saves me from running to the server room to make the slightest change to the server settings).

    After upgrading the office computers to Leopard, the server admin tools have disappeared on the recently upgraded machines. Attempting to reinstall ServerAdminTools10.4.11 on any of the macs running Leopard fails with the message that the ServerAdminTools10.4.11 "can't be installed on this drive for an unknown reason."

    It's absurd to think that I can access and configure a Tiger server only from macs running Tiger. Has anyone been able to install the Server Admin Tools under Leopard?
  2. macrumors 68040


    Maybe the 10.5 admin tools will be able to manage a 10.4 server?
  3. macrumors P6


    i guess you could try it.
  4. macrumors 65816

    Thanks for the heads up. I didn't realize that there was a later server admin tool than ServerAdminTools 10.4.11. I hunted around Apple's support site and found ServerAdminTools 10.5 and am installing them now. I'll see if they not only run under Leopard, but if they also work to admin a Tiger Server.

    ****! No. I downloaded and installed ServerAdminTools10.5 and when I tried to access my Tiger server, I get the message, "this server is too old to be for this version of the server admin tools blah blah."

    Brilliant Apple: Tiger Server compatible admin tools won't run under Leopard and the Leopard compatible admin tools won't talk to a Tiger server on the network.

    How pathetic. Does Apple think that I'm going to upgrade a $1000 piece of perfectly working server software just because the five macs on my network are now running Leopard instead of Tiger? Or does Apple think that just because I'm still running a Tiger file server I must keep a separate Tiger computer or boot drive handy just to periodically administer my Tiger server?
  5. macrumors 603

    Huh? This should work just fine, as it has in the past (the 10.4 server tools worked fine with 10.3 servers, for example).

    I just tested--installed the 10.5 server admin tools from Apple's site on a clean Leopard install, connected to my Tiger (10.4.11) server, and I can access and change settings normally. A few things don't work (as has been the case in the past) if they're features that only a 10.5 server has, but that's it.

    The 10.5 admin tools are prettier, too.

    I don't have a 10.3 server running anywhere to test with, but you say you're getting an error trying to work with a 10.4 one?
  6. macrumors 603

    I just wanted to add (now that I'm home) that the 10.4.11 admin tools also work fine on 10.5. It is odd that the installer won't let you install them, but there's an easy workaround:

    Download the package from Apple, and on the disk image go to Installers --> Packages. Do a Show Package Contents on ServerAdminTools.pkg, locate Archive.pax.gz, copy it outside the package somewhere, double click it to decompress completely (on my system I only needed to click once, and Finder went right ahead and de-paxed it (or whatever), leaving a folder called Archive 2, within which you'll find an "Applications" folder that contains all the server admin tools--just copy them to where you want them.

    It would obviously be nicer if the installer worked properly, but I'm not having any trouble with either set of tools, so maybe there's something different in your setup that's causing the 10.5 admin tools to act up...
  7. x19
    macrumors newbie

    The 10.5 Server tools work with 10.4.11 servers and later. I like the new interface, but get a little frustrated at things that won't work using the 10.5 tools that would work with the 10.4 tools.
  8. macrumors member

    Your server needs to be running 10.4.11
  9. macrumors 65816

    Ah. I'm running 10.4.10

    Thanks for the info. I'll upgrade immediately and see if my 10.5 server tools behave properly. I really don't want to keep running to my old Ti laptop running Tiger to diddle with the server.

    Woo hoo! It worked.

    I upgraded to 10.4.11 and the 10.5 server tools work perfectly fine now. Thanks everyone!
  10. macrumors 65816

    What doesn't work with the 10.5 tools?

    What are some of the things that you've encountered that do not work under the 10.5 tools?
  11. x19
    macrumors newbie

    I've only come across one that really frustrated me. In 10.4 Workgroup Manager you were able to set the computer name in WGM and have it apply to the computer once it was bound to the network. They must have changed the way that works as it is now found under login preferences and is 10.5 only, whereas it used to be a check box when adding a computer to the directory.

Share This Page